Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Dial Backup

Recently, I configured routers to iniate dial backup upon a serial interface losing its connection. What I'd like to do is be able to get the router to dial our central office once it realizes it is no longer receiving eigrp hello packets on the same serial interface. So my question is, can this be done and if it can be done how do go about doing it? Any help would be appreciated.

Thanks,

George Davidson

Menards Inc.

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: Dial Backup

Hi George!

We have set up the same type of backup for all of the routers in our company. A great software feature to use is dialer-watch. It montiors the routing table and intiates the modem if the route is deleted from the table. Make sure you don't use a directly connected route. Here is a config for a 1720, using ospf. I think it works with eigrp.

chat-script Dialout ABORT ERROR ABORT BUSY "" "AT" OK "ATDT \T" TIMEOUT 45 CONNECT \C

modemcap entry USR_MODEM:MSC=&F1S0=1

interface Async5

description Backup modem to head office

bandwidth 33

no ip address

encapsulation ppp

dialer in-band

dialer pool-member 1

async default routing

interface Dialer1

ip unnumbered FastEthernet0 :use ethernet ip address to connect

encapsulation ppp

ip tcp header-compression

dialer pool 1

dialer idle-timeout 300

dialer watch-disable 60

dialer string 416xxxxxxx

dialer watch-group 1

no cdp enable

ppp authentication chap

ppp chap hostname ??????????

ppp chap password ??????????

router ospf 100

no log-adjacency-changes

network x.x.6.4 0.0.0.3 area 0.0.0.2

network x.x.20.0 0.0.0.255 area 0.0.0.2

ip route 0.0.0.0 0.0.0.0 x.x.6.5

ip route 0.0.0.0 0.0.0.0 Dialer1 2 :add a second default route with a higher matric, you may

not need this.

access-list 101 deny ospf any any :put eigrp instead

access-list 101 permit ip any any

dialer watch-list 1 ip x.x.4.0 255.255.255.0

dialer watch-list 1 delay disconnect 60

dialer-list 1 protocol ip list 101

line aux 0

exec-timeout 0 0

no exec

modem Out

modem autoconfigure type USR_MODEM

transport none

autoselect ppp

stopbits 1

speed 115200

flowcontrol hardware

Have fun!

4 REPLIES
New Member

Re: Dial Backup

Hi George!

We have set up the same type of backup for all of the routers in our company. A great software feature to use is dialer-watch. It montiors the routing table and intiates the modem if the route is deleted from the table. Make sure you don't use a directly connected route. Here is a config for a 1720, using ospf. I think it works with eigrp.

chat-script Dialout ABORT ERROR ABORT BUSY "" "AT" OK "ATDT \T" TIMEOUT 45 CONNECT \C

modemcap entry USR_MODEM:MSC=&F1S0=1

interface Async5

description Backup modem to head office

bandwidth 33

no ip address

encapsulation ppp

dialer in-band

dialer pool-member 1

async default routing

interface Dialer1

ip unnumbered FastEthernet0 :use ethernet ip address to connect

encapsulation ppp

ip tcp header-compression

dialer pool 1

dialer idle-timeout 300

dialer watch-disable 60

dialer string 416xxxxxxx

dialer watch-group 1

no cdp enable

ppp authentication chap

ppp chap hostname ??????????

ppp chap password ??????????

router ospf 100

no log-adjacency-changes

network x.x.6.4 0.0.0.3 area 0.0.0.2

network x.x.20.0 0.0.0.255 area 0.0.0.2

ip route 0.0.0.0 0.0.0.0 x.x.6.5

ip route 0.0.0.0 0.0.0.0 Dialer1 2 :add a second default route with a higher matric, you may

not need this.

access-list 101 deny ospf any any :put eigrp instead

access-list 101 permit ip any any

dialer watch-list 1 ip x.x.4.0 255.255.255.0

dialer watch-list 1 delay disconnect 60

dialer-list 1 protocol ip list 101

line aux 0

exec-timeout 0 0

no exec

modem Out

modem autoconfigure type USR_MODEM

transport none

autoselect ppp

stopbits 1

speed 115200

flowcontrol hardware

Have fun!

New Member

Re: Dial Backup

Hello again!

I just read your message again and relized you are specfically asking about kicking the link up after a hello has been missed. I think the dialer watch should still help you. If the hello is not recieved the route will be dropped, and the dialer watch should bring up the backup link.

Silver

Re: Dial Backup

You can use either dial on demand or dialer watch to get ISDN backup for a serial link based on routing exchanges. If you choose to use dialer watch, make sure you are using IOS 12.1(7) or later, earlier releases have problems.

Whichever approach you choose, the trick is to have a route learned via EIGRP which goes away when the preferred link has problems. If you use dial on demand, you also have to ensure that there is "interesting" traffic to force dialing. These issues (and many more) are addressed in detail in my book High Availability Networking with Cisco. Chapters four and five are dedicated to dial backup scenarios, including discussion of what works (and what does not work) under various conditions.

Good luck and have fun!

Vincent C Jones

www.networkingunlimited.com

New Member

Re: Dial Backup

Hi Vincent !!

I posted a porblem that is occuring with a 3620 router with 8AM modems. I can't get the speed past 21.6kbps, yet I have a shiva modem with the same line that I can connect at 26.6kbps. Take a look at the post I left on Jan 6, if you have time.

Do you have any ideas on how to increase the speed of the connection.

Thanks

Randy McIver

90
Views
0
Helpful
4
Replies