Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Dial-In to Access Server : Line hangs up after approx. 160 sec.

I am using a 3660 Access Router.

ISDN and analog modems.

I configured group-asynch interfaces - Dial In to these interfaces is successful - the asynch interface comes up but disconnects automatically after approx. 160 sec.

(additionally I am using TACACS authentification on a Cisco ACS - The server is setup by default - (User/Password added - no other entries made ! )

Unfortunately I noticed this bevaviour after changing over to this ACS -

we were using Windows NT Active Dir. before .

I see the following errors:

TTY78: Async Int reset: Dropping DTR

*Mar 1 00:55:22: Modem 2/13 Mica: in modem state TERMINATING

*Mar 1 00:55:22: Modem 2/13 Mica: in modem state IDLE

*Mar 1 00:55:22: %ISDN-6-DISCONNECT: Interface Serial1/0:7 disconnected from xxxxx xxxxx xxxxxx , call lasted 136 seconds

*Mar 1 00:55:22: Modem 2/13 Mica: DISCONNECT after 00:02:16, due to reason (0xDF00) Host Disconnect.

*Mar 1 00:55:23: TTY78: DSR was dropped

*Mar 1 00:55:23: tty78: Modem: READY->(unknown)

*Mar 1 00:55:24: TTY78: dropping DTR, hanging up

*Mar 1 00:55:24: tty78: Modem: HANGUP->(unknown)

*Mar 1 00:55:24: %LINK-5-CHANGED: Interface Async78, changed state to reset

*Mar 1 00:55:25: TTY78: cleanup pending. Delaying DTR

*Mar 1 00:55:25: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async78, changed state to down

*Mar 1 00:55:26: TTY78: cleanup pending. Delaying DTR

*Mar 1 00:55:27: TTY78: cleanup pending. Delaying DTR

*Mar 1 00:55:27: TTY78: no timer type 0 to destroy

*Mar 1 00:55:27: TTY78: no timer type 1 to destroy

*Mar 1 00:55:27: TTY78: no timer type 3 to destroy

*Mar 1 00:55:27: TTY78: no timer type 4 to destroy

*Mar 1 00:55:27: TTY78: no timer type 2 to destroy

*Mar 1 00:55:27: AAA/MEMORY: free_user (0x6179F508) user='baumg' ruser='NULL' port='Async78' rem_addr='436765400458' authen_type=PAP service=PPP priv=1

*Mar 1 00:55:27: Async78: allowing modem_process to continue hangup

*Mar 1 00:55:28: TTY78: restoring DTR

*Mar 1 00:55:29: TTY78: autoconfigure probe started

*Mar 1 00:55:29: %LINK-3-UPDOWN: Interface Async78, changed state to down

*Mar 1 00:57:15: TTY226: Line reset by "Virtual Exec"

*Mar 1 00:57:15: TTY226: Modem: (unknown)->READY

I attached the current running-config:

RAS#sh run

Building configuration...

Current configuration : 4994 bytes

!

aaa new-model

aaa authentication login NO_AUTH line

aaa authentication ppp default if-needed group tacacs+

memory-size iomem 15

modem country mica austria

ip subnet-zero

!

!

no ip domain-lookup

!

ip dhcp-server 10.249.20.7

async-bootp dns-server 10.249.20.5 10.249.20.7

async-bootp nbns-server 10.249.20.5 10.249.20.7

isdn switch-type primary-net5

isdn voice-call-failure 0

chat-script reset "" at&fx3 "OK"

chat-script CALLBACK ABORT ERROR ABORT BUSY "" "AT" OK "ATDT \T" TIMEOUT 30 CONNECT \c

chat-script offhook "" "ATH1" OK

!

controller E1 1/0

pri-group timeslots 1-31

description ISDN-Line for DialIn

!

interface FastEthernet0/0

ip address 10.129.10.2 255.255.255.0

ip helper-address 10.249.20.7

duplex auto

speed auto

!

interface Serial1/0:15

description ISDN-Line for DialIn

ip unnumbered FastEthernet0/0

encapsulation ppp

isdn switch-type primary-net5

isdn incoming-voice modem

isdn T321 0

peer default ip address dhcp

no cdp enable

ppp authentication pap chap

interface Group-Async1

description Asyn Interface Remoteeinwahl

ip unnumbered FastEthernet0/0

encapsulation ppp

dialer in-band

async mode dedicated

peer default ip address dhcp

ppp callback accept

ppp authentication pap chap

group-range 65 92

!

router ospf 1

log-adjacency-changes

redistribute connected subnets

redistribute static

network 10.129.10.0 0.0.0.255 area 0

network 10.129.250.0 0.0.0.3 area 0

network 10.129.250.4 0.0.0.3 area 0

network 10.129.250.8 0.0.0.3 area 0

!

ip local pool dial 10.129.10.10 10.129.10.60

ip classless

ip radius source-interface FastEthernet0/0

logging trap debugging

logging 10.129.2.140

dialer-list 1 protocol ip permit

tacacs-server host 10.129.7.140

tacacs-server key xxxxxxxxxx

snmp-server community xxxxxx

snmp-server community xxxxxx

radius-server host 10.249.20.9 auth-port 1645 acct-port 1646

radius-server host 10.249.20.22 auth-port 1645 acct-port 1813 key 7 xxxxxxxxxxxxxxx

radius-server retransmit 3

radius-server key 7 xxxxxxxxx

line con 0

exec-timeout 0 0

password 7 xxxxxxx

login authentication NO_AUTH

line 65 94

script modem-off-hook offhook

script callback CALLBACK

refuse-message ^CCC No Modems availble ^C

modem InOut

modem autoconfigure type mica

rotary 1

transport preferred telnet

transport input all

autoselect during-login

autoselect ppp

callback forced-wait 5

line aux 0

password 7 xxxxxxxxxxxxxx

transport input all

line vty 0 4

exec-timeout 30 0

password 7 xxxxxxxxxxxxxxx

login authentication NO_AUTH

!

end

Thx for your help !

Hans

1 REPLY
Cisco Employee

Re: Dial-In to Access Server : Line hangs up after approx. 160 s

Duplicate question...Can you ping the router from the clients when the connection is established?? If yes then pl. Add the following command in the config

config t

dialer-list 1 protocol ip permit

!

interface group-async 1

dialer-group 1

dialer idle-timeout 600

Above config should not disconnect the line before 10 mins.

If you can't ping across, we need to see the debugs

debug ppp nego

debug dialer

debug aaa per

debug aaa authorization

212
Views
0
Helpful
1
Replies