Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Dial-in with a 2612

Hi you guys ! I hope you can help me with this issue.

I´m seting up a 2612 with a 16-NM-AM module and a Token Ring Interface.

The goal is, any remote user can connect via modem and access to any resource into the LAN.

Router can reach any host in the LAN.

Router can reach any IP address outside my network

but If a call by modem (the same router):

modem answers the call

can set up ppp connection

I can get my IP address for my external Server (windows Based DHCP server)

But I can´t reach any host into my network.

I can ping to my own IP address

I do ping to IP address into the network but it doesn´t answer.

What could I do to solve this issue!

I´m giving my actual configuration! something is wrong!?

Current configuration : 1227 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname haras

!

enable secret 5 xxxxxxxxxxxxxxxxxxxx

enable password xxxxxxxxxxxxxxxxxxxx

!

username user1 password 0 user1

username user2 password 0 morris

ip subnet-zero

no ip routing

!

!

ip domain-name mydomain.com

!

!

!

!

interface Loopback1

ip address 10.110.4.a 255.255.255.0

!

interface Ethernet0/0

ip address

no ip route-cache

no ip mroute-cache

half-duplex

!

interface TokenRing0/0

ip address 10.110.4.b

no ip route-cache

no ip mroute-cache

ring-speed 16

!

interface Group-Async1

ip unnumbered Loopback1

ip helper-address 10.110.4.c (ip address for Windows Server)

encapsulation ppp

dialer in-band

dialer idle-timeout 600

dialer-group 1

autodetect encapsulation ppp

async mode interactive

peer default ip address dhcp

ppp authentication chap

group-range 33 48

!

ip default-gateway X.X.X.X (my defualt ip address)

ip classless

ip route

ip http server

ip pim bidir-enable

!

access-list 1 permit any

dialer-list 1 protocol ip list 1

!

line con 0

line 33 48

modem InOut

transport input all

autoselect ppp

line aux 0

line vty 0 4

password xxxxx

login

!

end

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: Dial-in with a 2612

For routing command "ip routing" is needed.

Also you have to change ip subnet on to 0/0 or lo 1, currently both ranges overlaps

kind regards peter

5 REPLIES

Re: Dial-in with a 2612

First thing I saw is that lo0 and To0/0 have overlapping ip adresses. This might cause problems with ARP resolution. This could work if your 2612 is the default gateway while Cisco assigns host-routes to the ppp users. This requires that data is sent to this system as default gateway but I suspect it is not. When you have another router you need to run EIGRP or OSPF for the host routes to be advertised.

I would rather assign a different ip range to the dial-in users and route between the two networks.

Please check that each user gets a different IP address. In a simlar setup I have seen that ppp user connections requesting an address all get the same address while all requests are served with a single mac-address from the router. In this case I would use an IP pool on the router to serve the ppp-clients.

Regards,

Leo

New Member

Re: Dial-in with a 2612

could you explain in detail, actually I have the problem that a remote user can´t resolve names, and can´t ping any host in to the network.

New Member

Re: Dial-in with a 2612

HI Leo

I need your help. I have a cisco 1601 R router with ISDN BRI WAN port. I want to configure this particular port for remote access such that my employees use company resources from home computers. I want a remote user should call from his normal desktop pcs with an analog modem and PSTN line to call my ISDN number and that is redirected to my network. Employess can browse and use their Pcs' printers, internet facility, and also can do PC-to_Phone from home when they get connected to our office netwrok. Our office network has a broadband connection from an ISP so only problem is remote connection thorugh ISDN BRI. I did the configuration but it is disconnecting after 30-40 secs. I checked cisco documents and I founf the same connecting scenario but using 3640 router.. Is it possible that I use 1601 R router.

One of my friend told me he wil help me but my cisco is not able to accept telnet. I have configured and I am able to do the same from my office pcs'.

My telnet details are:

telnet x.x.x.x

password: xxx

enable passowrd: xxx

Plz help!!

Sam

New Member

Re: Dial-in with a 2612

Could you put the config and debug output of ISDN for this router ?

New Member

Re: Dial-in with a 2612

For routing command "ip routing" is needed.

Also you have to change ip subnet on to 0/0 or lo 1, currently both ranges overlaps

kind regards peter

112
Views
0
Helpful
5
Replies