Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Dial-in with V.110 Protokoll on 3725 + NM-30DM Modul

Hello,

i will dial-in with protokoll V.110, but when i use "sh modem config 2/0" then:

S29 = 6 V.90 modem standard

I will change it to:

S29 = 8 V.110.

How can i do that!!!

I will work with this Protokoll on this Router only.

5 REPLIES
VIP Purple

Re: Dial-in with V.110 Protokoll on 3725 + NM-30DM Modul

Hello,

which IOS version are you using ? You need at least 12.2(8)T, I think the 3725 ships with 12.2(3), so you would need to upgrade.

Regards,

Georg Pauwen

New Member

Re: Dial-in with V.110 Protokoll on 3725 + NM-30DM Modul

OK, check it up.....

Question:

Can i flash the digital-Moduls (Firmwareupgrade)?

Is it nessesary?

If i want use the string "modemcap" and wand save the configuration then shows follow error:

"This command has no effect on this line; use modem AT commands instead"

Is it an Bug?

Frank

New Member

Re: Dial-in with V.110 Protokoll on 3725 + NM-30DM Modul

OK,

i did dial-in in my company and was on the router of our costumer.

Here details......

#############################################

bvrr02#dir

Directory of flash:/

1 -rw- 7507936 Mar 01 1993 00:06:38

c3725-i-mz.122-13.T8.bin

2 -rw- 16773120 Mar 01 1993 04:19:16

c3725-is-mz.122-13.T8.bin

31932416 bytes total (12713984 bytes free)

bvrr02#

#############################################

Defautl IOS is "c3725-i-mz.122-13.T8.bin"

later i did try flash the IOS

"c3725-is-mz.122-13.T8.bin"

For me is it not the first time to flash cisco routers, but when i use the command "sh ver", then i see the old IOS. When is use the command "sh ru". Then i see the new IOS. What is wrong?

I did change config-register from 0x2102 to 0x2101 then i download the new IOS. Then change it the boot system flash to the new IOS (boot system flash c3725-is-mz.122-13.T8.bin) and change to 0x2102 and made a reboot. That`s all. Was the new IOS not correctly download. I did need around 3 times to download the IOS on this router, because the have in our company many switch and V-LAN`s. My Workstation was the TFTP-Server and work with the virtual Networkdriver on one NIC and simulate two NIC`s then.

OK, i think i will delete the new IOS and try a new download from the website and then in the router.....

What it work:

I can dial-in with default setting on a client. PPP over ISDN ect.....

If i wand dial-in with V.110 setting on a client, i can`t dial in and get an error on a client. "no open Ports....."

The client is a Notebook with whe ISDN-Card. Here can i use AT-commands an change to V.110. Ohter way is to use my mobilphone with V.110 Protocoll. I can dial-in on ISDN-Cards with my Mobilphone, but not on this router.....

Help me, please.

VIP Purple

Re: Dial-in with V.110 Protokoll on 3725 + NM-30DM Modul

Hello,

do you have at least portware 2.7.4.0 ? If you can, upgrade to 2.9.4.0.

Check what you see when you issue the command show modemcap x (whereby x is your digital modem). It probably says S29=6. Can you change that to S29=8 with the edit modemcap x command (in config mode) ?

Regards,

Georg

New Member

Re: Dial-in with V.110 Protokoll on 3725 + NM-30DM Modul

I can`t connect via V.110

Can you help me, please.

#####################

General OS:

Modem control/process activation debugging is on

Dial on demand:

Dial on demand events debugging is on

CSM Modem Management:

Modem Management Call Switching Module debugging is on

The following ISDN debugs are enabled on all DSLs:

debug isdn error is ON.

debug isdn q931 is ON.

############################

xxx2#

*Mar 13 15:35:27.572: ISDN Se1/0:15 Q931: RX <- SETUP pd = 8 callref = 0x0072

Sending Complete

Bearer Capability i = 0x8890214840BB

Standard = CCITT

Transer Capability = Unrestricted Digital

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA98381

Exclusive, Channel 1

Calling Party Number i = 0x21, 0x83, 'xxxxxxxxx'

Plan:ISDN, Type:National

Low Layer Compat i = 0x8890, '!H@', 0xBB

*Mar 13 15:35:27.576: CSM: MODEM_REPORT from 1/0:0, call_id=0x14, event=0x1, cause=0x0, dchan_idb=0x6194F328

*Mar 13 15:35:27.576: CSM: Next free modem = 2/0; statbits = 10040

*Mar 13 15:35:27.576: Modem 2/0 CSM: TTY statbits = 10040

*Mar 13 15:35:27.576: CSM: Next free modem = 2/1; statbits = 10040

*Mar 13 15:35:27.576: Modem 2/1 CSM: TTY statbits = 10040

*Mar 13 15:35:27.576: CSM: Next free modem = 2/2; statbits = 10040

*Mar 13 15:35:27.576: Modem 2/2 CSM: TTY statbits = 10040

*Mar 13 15:35:27.576: CSM: Next free modem = 2/3; statbits = 10040

*Mar 13 15:35:27.576: Modem 2/3 CSM: TTY statbits = 10040

*Mar 13 15:35:27.576: CSM: Next free modem = 2/4; statbits = 10040

*Mar 13 15:35:27.576: Modem 2/4 CSM: TTY statbits = 10040

*Mar 13 15:35:27.576: CSM: Next free modem = 2/5; statbits = 10040

*Mar 13 15:35:27.576: Modem 2/5 CSM: TTY statbits = 10040

*Mar 13 15:35:27.576: CSM: Next free modem = 2/6; statbits = 10040

*Mar 13 15:35:27.576: Modem 2/6 CSM: TTY statbits = 10040

*Mar 13 15:35:27.576: CSM: Next free modem = 2/7; statbits = 10040

*Mar 13 15:35:27.576: Modem 2/7 CSM: TTY statbits = 10040

*Mar 13 15:35:27.576: CSM: Next free modem = 2/8; statbits = 10040

*Mar 13 15:35:27.576: Modem 2/8 CSM: TTY statbits = 10040

*Mar 13 15:35:27.576: CSM: Next free modem = 2/9; statbits = 10040

*Mar 13 15:35:27.576: Modem 2/9 CSM: TTY statbits = 10040

*Mar 13 15:35:27.576: CSM: Next free modem = 2/10; statbits = 10040

*Mar 13 15:35:27.576: Modem 2/10 CSM: TTY statbits = 10040

*Mar 13 15:35:27.576: CSM: Next free modem = 2/11; statbits = 10040

*Mar 13 15:35:27.576: Modem 2/11 CSM: TTY statbits = 10040

*Mar 13 15:35:27.576: CSM: Next free modem = 2/12; statbits = 10040

*Mar 13 15:35:27.576: Modem 2/12 CSM: TTY statbits = 10040

*Mar 13 15:35:27.576: CSM: Next free modem = 2/13; statbits = 10040

*Mar 13 15:35:27.576: Modem 2/13 CSM: TTY statbits = 10040

*Mar 13 15:35:27.576: CSM: Next free modem = 2/14; statbits = 10040

*Mar 13 15:35:27.576: Modem 2/14 CSM: TTY statbits = 10040

*Mar 13 15:35:27.576: CSM: Next free modem = 2/15; statbits = 10040

*Mar 13 15:35:27.576: Modem 2/15 CSM: TTY statbits = 10040

*Mar 13 15:35:27.576: CSM: Next free modem = 2/16; statbits = 10040

*Mar 13 15:35:27.576: Modem 2/16 CSM: TTY statbits = 10040

*Mar 13 15:35:27.576: CSM: Next free modem = 2/17; statbits = 10040

*Mar 13 15:35:27.576: Modem 2/17 CSM: TTY statbits = 10040

*Mar 13 15:35:27.576: CSM: Next free modem = 2/18; statbits = 10040

*Mar 13 15:35:27.576: Modem 2/18 CSM: TTY statbits = 10040

*Mar 13 15:35:27.576: CSM: Next free modem = 2/19; statbits = 10040

*Mar 13 15:35:27.576: Modem 2/19 CSM: TTY statbits = 10040

*Mar 13 15:35:27.576: CSM: Next free modem = 2/20; statbits = 10040

*Mar 13 15:35:27.576: Modem 2/20 CSM: TTY statbits = 10040

*Mar 13 15:35:27.576: CSM: Next free modem = 2/21; statbits = 10040

*Mar 13 15:35:27.576: Modem 2/21 CSM: TTY statbits = 10040

*Mar 13 15:35:27.576: CSM: Next free modem = 2/22; statbits = 10040

*Mar 13 15:35:27.576: Modem 2/22 CSM: TTY statbits = 10040

*Mar 13 15:35:27.576: CSM: Next free modem = 2/23; statbits = 10040

*Mar 13 15:35:27.576: Modem 2/23 CSM: TTY statbits = 10040

*Mar 13 15:35:27.576: CSM: Next free modem = 2/24; statbits = 10040

*Mar 13 15:35:27.576: Modem 2/24 CSM: TTY statbits = 10040

*Mar 13 15:35:27.576: CSM: Next free modem = 2/25; statbits = 10040

*Mar 13 15:35:27.576: Modem 2/25 CSM: TTY statbits = 10040

*Mar 13 15:35:27.576: CSM: Next free modem = 2/26; statbits = 10040

*Mar 13 15:35:27.576: Modem 2/26 CSM: TTY statbits = 10040

*Mar 13 15:35:27.576: CSM: Next free modem = 2/27; statbits = 10040

*Mar 13 15:35:27.576: Modem 2/27 CSM: TTY statbits = 10040

*Mar 13 15:35:27.576: CSM: Next free modem = 2/28; statbits = 10040

*Mar 13 15:35:27.576: Modem 2/28 CSM: TTY statbits = 10040

*Mar 13 15:35:27.576: CSM: Next free modem = 2/29; statbits = 10040

*Mar 13 15:35:27.576: Modem 2/29 CSM: TTY statbits = 10040

*Mar 13 15:35:27.576: CSM incall failed with dchan index=1, idb state=4, sb=0

*Mar 13 15:35:27.576: CSM: MODEM_REPORT rcvd DEV_INCALL for call_id 0x14, No modem available

*Mar 13 15:35:27.576: ISDN Se1/0:15 **ERROR**: accept_incoming_csm_call: modem problem Requested circuit/channel not available(0x2C): b channel 0, call id 0x14

*Mar 13 15:35:27.576: CSM: MODEM_REPORT from 1/0:0, call_id=0x14, event=0x0, cause=0x0, dchan_idb=0x6194F328

*Mar 13 15:35:27.576: CSM: MODEM_REPORT rcvd DEV_IDLE for call_id 0x14, modem not found due to wrong b channel number or b channel is deallocated

*Mar 13 15:35:27.580: ISDN Se1/0:15 Q931: TX -> CALL_PROC pd = 8 callref = 0x8072

Channel ID i = 0xA98381

Exclusive, Channel 1

bvrr02#

*Mar 13 15:35:27.580: ISDN Se1/0:15 Q931: TX -> DISCONNECT pd = 8 callref = 0x8072

Cause i = 0x80AC - Requested circuit/channel not available

*Mar 13 15:35:27.780: ISDN Se1/0:15 Q931: RX <- RELEASE pd = 8 callref = 0x0072

*Mar 13 15:35:27.780: CSM: MODEM_REPORT from 1/0:0, call_id=0x14, event=0x0, cause=0x0, dchan_idb=0x6194F328

*Mar 13 15:35:27.780: CSM: MODEM_REPORT rcvd DEV_IDLE for call_id 0x14, modem not found due to wrong b channel number or b channel is deallocated

*Mar 13 15:35:27.780: ISDN Se1/0:15 Q931: TX -> RELEASE_COMP pd = 8 callref = 0x8072

bvrr02#

##########################################

version 12.2

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

no service dhcp

!

hostname xxxxx

!

boot system flash c3725-is-mz.122-13.T8.bin

boot system flash

boot system flash c3725-i-mz.123-5.bin

enable password xxxxxxxxx

!

username xxxxxxxxx password 0 xxxxxxxx

modem country mica germany

ip subnet-zero

!

!

no ip domain lookup

!

isdn switch-type primary-net5

!

modemcap entry new:MSC=&F&D2S34=9600S29=8

!

controller E1 1/0

pri-group timeslots 1-31

description "SMS-Dialin der Fahrzeuge"

!

!

!

interface Loopback0

ip address 172.22.20.1 255.255.255.0

!

interface Loopback1

ip address 172.22.61.1 255.255.255.0

!

interface FastEthernet0/0

description "LAN - BVR Duesseldorf"

ip address 192.168.41.16 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial1/0:15

no ip address

encapsulation ppp

dialer rotary-group 10

dialer-group 5

isdn switch-type primary-net5

isdn incoming-voice data

no cdp enable

ppp authentication chap

ppp multilink

!

interface Group-Async0

ip unnumbered Loopback0

encapsulation ppp

dialer in-band

dialer idle-timeout 900

dialer-group 5

async mode interactive

peer default ip address pool ASYNC

no keepalive

no fair-queue

ppp authentication chap

ppp multilink

group-range 65 94

!

interface Dialer10

ip unnumbered Loopback1

encapsulation ppp

dialer in-band

dialer idle-timeout 900

dialer-group 5

peer default ip address pool ISDN

ppp authentication chap

ppp multilink

!

ip local pool ASYNC 172.22.60.2 172.22.60.254

ip local pool ISDN 172.22.61.2 172.22.61.254

ip classless

ip route 172.29.199.0 255.255.255.0 192.168.41.210

ip route 193.73.132.0 255.255.255.0 192.168.41.210

ip http server

!

!

!

line con 0

line 65 94

flush-at-activation

modem autoconfigure type new

terminal-type m

line aux 0

line vty 0 4

exec-timeout 0 0

password xxxxxxx

logging synchronous

login

!

end

167
Views
0
Helpful
5
Replies
CreatePlease login to create content