Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

dial-on-demand with 4 bri problem

I have a problem with a Cisco 2610Xm + 4 bri router that call another Cisco 2610Xm + 4 bri router.

I have configured the caller with a dialer profile and 4 different dialer strings, then I've added the "dialer order" parameter with the round-robin option (the problem is similar with other options too).

The problem is: the router calls using only two dieler strins and not four... looking at "show isdn history" the router try continuously to call only two numbers ignoring the others...

this is a sh run:

!

version 12.2

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname CALLER

!

enable password 7 ...

!

username CALLED password 7 ...

ip subnet-zero

!

!

no ip domain lookup

isdn switch-type basic-net3

!

!

!

!

interface FastEthernet0/0

ip address 10.X.Y.Z 255.255.255.0

duplex auto

speed auto

!

interface Serial0/0

no ip address

shutdown

no fair-queue

!

interface BRI1/0

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

no fair-queue

no cdp enable

ppp authentication chap

ppp multilink

!

interface BRI1/1

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

no fair-queue

no cdp enable

ppp authentication chap

ppp multilink

!

interface BRI1/2

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

no fair-queue

no cdp enable

ppp authentication chap

ppp multilink

!

interface BRI1/3

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

no fair-queue

no cdp enable

ppp authentication chap

ppp multilink

!

interface Dialer1

ip address negotiated

encapsulation ppp

load-interval 30

dialer pool 1

dialer remote-name CALLED

dialer order round-robin

dialer idle-timeout 600

dialer string 0...1

dialer string 0...2

dialer string 0...3

dialer string 0...4

dialer load-threshold 1 either

dialer-group 1

no cdp enable

ppp authentication chap

ppp multilink

!

ip classless

ip route 10.A.B.0 255.255.255.0 Dialer1

no ip http server

ip pim bidir-enable

!

!

dialer-list 1 protocol ip permit

!

line con 0

line aux 0

line vty 0 4

password 7 ...

login

!

!

end

4 REPLIES
VIP Purple

Re: dial-on-demand with 4 bri problem

Hello,

I have a feeling that this might be related to the ppp multilink feature you have configured, in combination with the dialer load-threshold setting of 1. Can you try and take the multilink setting out, or increase the dialer load-threshold to something higher, like 127 ? Also, can you post the output of debug dialer ?

Regards,

GP

New Member

Re: dial-on-demand with 4 bri problem

I've tried to set no multilink but the problem wasn't solved. Now I've increased the load-threshold but it doesn't seem to work...

the output of "debug dialer" is:

*Mar 3 22:30:35.910: BRI1/0: wait for isdn carrier timeout, call id=0x9BE8

*Mar 3 22:30:50.999: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BR1/0, TEI 68 changed to down

*Mar 3 22:30:59.052: BR1/0 DDR: rotor dialout [priority]

*Mar 3 22:30:59.052: BR1/0 DDR: Attempting to dial NUMBER1

*Mar 3 22:30:59.316: %ISDN-6-LAYER2UP: Layer 2 for Interface BR1/0, TEI 69 changed to up

*Mar 3 22:31:01.272: BRI1/0: wait for isdn carrier timeout, call id=0x9BE9

*Mar 3 22:31:04.273: BR1/0 DDR: rotor dialout [priority]

*Mar 3 22:31:04.273: BR1/0 DDR: Dialing cause ISDN fast roll-over

*Mar 3 22:31:04.273: BR1/0 DDR: Attempting to dial NUMBER2

*Mar 3 22:31:06.232: BRI1/0: wait for isdn carrier timeout, call id=0x9BEA

*Mar 3 22:31:21.300: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BR1/0, TEI 69 changed to down

*Mar 3 22:31:29.101: BR1/0 DDR: rotor dialout [priority]

*Mar 3 22:31:29.101: BR1/0 DDR: Attempting to dial NUMBER1

*Mar 3 22:31:29.374: %ISDN-6-LAYER2UP: Layer 2 for Interface BR1/0, TEI 70 changed to up

*Mar 3 22:31:31.593: BRI1/0: wait for isdn carrier timeout, call id=0x9BEB

*Mar 3 22:31:34.594: BR1/0 DDR: rotor dialout [priority]

*Mar 3 22:31:34.594: BR1/0 DDR: Dialing cause ISDN fast roll-over

*Mar 3 22:31:34.594: BR1/0 DDR: Attempting to dial NUMBER2

*Mar 3 22:31:36.578: BRI1/0: wait for isdn carrier timeout, call id=0x9BEC

*Mar 3 22:31:51.694: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BR1/0, TEI 70 changed to down

*Mar 3 22:31:59.151: BR1/0 DDR: rotor dialout [priority]

*Mar 3 22:31:59.151: BR1/0 DDR: Attempting to dial NUMBER1

*Mar 3 22:31:59.395: %ISDN-6-LAYER2UP: Layer 2 for Interface BR1/0, TEI 71 changed to up

New Member

Re: dial-on-demand with 4 bri problem

Someone had already configured one Cisco with a 4 bri module to call another Cisco with 4 bri module? Can you give me a sample configuration? Thanks a lot! Happy new year

New Member

Re: dial-on-demand with 4 bri problem

problem solved by IOS upgrade.

187
Views
0
Helpful
4
Replies