Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Dial up Internet Access

User has nothing but 56k internet access. he also has a 1601 router with 4 pcs. can i configure the router to provide internet access to all four computers as slow as it may be.

does anyone have config examples?

thanks

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: Dial up Internet Access

Yes, this is possible. This used to be very common. Here is an actual config...

interface FastEthernet0

ip address 10.1.1.1 255.255.255.0

no ip directed-broadcast

ip nat inside

no cdp enable

!

interface Async5

ip address negotiated

no ip directed-broadcast

ip nat outside

encapsulation ppp

dialer in-band

dialer idle-timeout 3000

dialer string 98536660

dialer-group 1

async mode dedicated

no fair-queue

no cdp enable

ppp authentication chap callin

ppp chap hostname username@ic.wcom.net

ppp chap password yourpasswordhere

!

ip nat inside source list 10 interface Async5 overload

ip classless

ip route 0.0.0.0 0.0.0.0 Async5

no ip http server

!

access-list 10 permit 10.1.1.0 0.0.0.255

dialer-list 1 protocol ip list 10

no cdp run

!

line aux 0

password cisco

autoselect during-login

autoselect ppp

login

modem InOut

modem autoconfigure type hayes_optima

transport input all

stopbits 1

speed 115200

flowcontrol hardware

Notice the setup for NAT, and the ability to dynamically assign the IP address the modem gets when connecting to your ISP. Of course the username and password has been changed to protect the innocent. Let me know if you need more help.

8 REPLIES

Re: Dial up Internet Access

New Member

Re: Dial up Internet Access

Yes, this is possible. This used to be very common. Here is an actual config...

interface FastEthernet0

ip address 10.1.1.1 255.255.255.0

no ip directed-broadcast

ip nat inside

no cdp enable

!

interface Async5

ip address negotiated

no ip directed-broadcast

ip nat outside

encapsulation ppp

dialer in-band

dialer idle-timeout 3000

dialer string 98536660

dialer-group 1

async mode dedicated

no fair-queue

no cdp enable

ppp authentication chap callin

ppp chap hostname username@ic.wcom.net

ppp chap password yourpasswordhere

!

ip nat inside source list 10 interface Async5 overload

ip classless

ip route 0.0.0.0 0.0.0.0 Async5

no ip http server

!

access-list 10 permit 10.1.1.0 0.0.0.255

dialer-list 1 protocol ip list 10

no cdp run

!

line aux 0

password cisco

autoselect during-login

autoselect ppp

login

modem InOut

modem autoconfigure type hayes_optima

transport input all

stopbits 1

speed 115200

flowcontrol hardware

Notice the setup for NAT, and the ability to dynamically assign the IP address the modem gets when connecting to your ISP. Of course the username and password has been changed to protect the innocent. Let me know if you need more help.

New Member

Re: Dial up Internet Access

thank you for the info. this router does not have an aux port 1601R. i created the config on the serial interface. it dials out but can not connect to the isp.

here is my config file.

service compress-config

hostname Router

ip subnet-zero

no ip domain-lookup

interface Ethernet0

ip address 10.0.0.1 255.255.255.0

no ip directed-broadcast

ip nat inside

no keepalive

interface Serial0

physical-layer async

ip address negotiated

no ip directed-broadcast

ip nat outside

encapsulation ppp

dialer in-band

dialer idle-timeout 3000

dialer string 9545223610

dialer-group 1

async mode dedicated

no fair-queue

no cdp enable

ppp authentication pap chap

ppp chap hostname

ppp chap password

ppp pap sent-username

ip nat inside source list 10 interface Serial0 overload

ip classless

ip route 0.0.0.0 0.0.0.0 Serial0

access-list 10 permit 10.0.0.0 0.0.0.255

dialer-list 1 protocol ip list 10

line con 0

logging synchronous

transport input none

line 1

autobaud

autoselect during-login

autoselect ppp

login

modem InOut

modem autoconfigure type usr_sportster

transport input all

stopbits 1

flowcontrol hardware

line vty 0 4

thanks for your help.

New Member

Re: Dial up Internet Access

Do the modems attempt to train? If you supply a "debug ppp authen" and a "debug ppp neg" that would also help. If you at least connect to the modem, if most likely is PPP failing somewhere.

Are you sure your ISP performs CHAP authentication? There are some that do PAP only still.

New Member

Re: Dial up Internet Access

here are the results of debug ppp

0:04:33: Se0 LCP: TIMEout: State REQsent

00:04:33: Se0 LCP: O CONFREQ [REQsent] id 5 len 20

00:04:33: Se0 LCP: ACCM 0x000A0000 (0x0206000A0000)

00:04:33: Se0 LCP: MagicNumber 0xD0BEEE2C (0x0506D0BEEE2C)

00:04:33: Se0 LCP: PFC (0x0702)

00:04:33: Se0 LCP: ACFC (0x0802)

Router#Router#

00:07:16: Se0 LCP: TIMEout: State REQsent

00:07:16: Se0 LCP: O CONFREQ [REQsent] id 42 len 25

00:07:16: Se0 LCP: ACCM 0x000A0000 (0x0206000A0000)

00:07:16: Se0 LCP: AuthProto CHAP (0x0305C22305)

00:07:16: Se0 LCP: MagicNumber 0xD0C1498D (0x0506D0C1498D)

00:07:16: Se0 LCP: PFC (0x0702)

00:07:16: Se0 LCP: ACFC (0x0802)

Bronze

Re: Dial up Internet Access

Did you debug ppp authentication?

New Member

Re: Dial up Internet Access

yes i did nothing came up

New Member

Re: Dial up Internet Access

thank you so much for your help. the problem was the modem. i bought a newer us robotics modem and it works just fine.

cheers

98
Views
0
Helpful
8
Replies