Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Dial-up ISDN Routing Question

Hello Once Again.

I'm wondering if this will work.

On my 1720 I have a Dial-up ISDN line configured as a DDR backup for my Serial line (See Previous Post).

All works well when I take the serial line down, the ISDN dials up the ISP and connects. I can ping out from the router to addresses on the Internet but packets from the Fast Ethernet interface do not go out.

Running a "ip route command" at the router I see that the "gateway of last resort" (0.0.0.0 .0.0.0.0) is connected to "Dialer0" but a trace route from a machine on my LAN shows that packets stop at the Fast Ethernet interface on the router.

So after that long intro here's my question.

Will ISP's allow traffic out on their networks which is not from an IP address on their network? The obvious answer is no, I think. The network for the Fast Ethernet is 1.1.1.1 x.x.x.x but the network for the ISDN interface is 2.2.2.2 y.y.y.y

Why can't I route packets through do the Dialer0 int?

Thanks for reading this

Greg

4 REPLIES

Re: Dial-up ISDN Routing Question

Mostly, when you dial up to an ISP you have to use on the BRI.

First verify that you can send packets over the ISDN line.

Routing from an IP segment 1.x.x.x towards the Internet will normally require NAT. Do you have on your int s0/0?

If this is the case, you will need it on your ISDN as well.

Last but not least, you need to know how your ISP handles your traffic and setup your router accordingly.

New Member

Re: Dial-up ISDN Routing Question

Thanks for the response. I can get out over the ISDN line from the router. Here is my running config.

I did not know if the 1720 series supportted NAT.

Greg

Current configuration:

!

version 12.0

service timestamps debug datetime msec

service timestamps lo

no service password-encryption

!

hostname Metro_1720

!

enable secret 5 $1$t.o8$PgF2G3LT/Kx.PlXjf/p4g/

!

username Metro2 password 0

!

!

!

!

memory-size iomem 25

ip subnet-zero

no ip domain-lookup

!

isdn switch-type basic-5ess

isdn voice-call-failure 0

!

!

!

interface Serial0

description 768K line to Frontier_AZ

backup delay 10 30

backup interface Dialer0

ip address 64.211.1.86 255.255.255.252

no ip directed-broadcast

service-module t1 timeslots 1-12

service-module t1 remote-alarm-enable

!

interface BRI0

description ISDN backup to Frontier_ROC

no ip address

no ip directed-broadcast

encapsulation ppp

dialer rotary-group 0

isdn switch-type basic-5ess

no fair-queue

no cdp enable

!

interface FastEthernet0

description connected to EthernetLAN

ip address 64.211.20.65 255.255.255.224

no ip directed-broadcast

full-duplex

!

interface Dialer0

description Dailer for ISDN to Frontier_ROC

ip address negotiated

no ip directed-broadcast

encapsulation ppp

no ip split-horizon

dialer in-band

dialer idle-timeout 300

dialer string 7774660

dialer hold-queue 10

dialer load-threshold 200 outbound

dialer-group 1

no fair-queue

no cdp enable

ppp authentication pap chap callin

ppp chap hostname Metro2

ppp chap password 7 0215094E5E051D2C

ppp pap sent-username Metro2 password 7 0215094E5E051D2C

ppp multilink

!

ip classless

ip route 0.0.0.0 0.0.0.0 Serial0

ip route 0.0.0.0 0.0.0.0 Dialer0 250

no ip http server

!

access-list 101 permit ip any any

access-list 101 permit icmp any any

dialer-list 1 protocol ip permit

snmp-server engineID local 0000000902000002B9CC0B70

snmp-server community public RO

snmp-server location 205 LaGrange Ave

snmp-server contact Greg Young,(716) 254-2988 x238,GYoung@Metrocircuits.com

!

line con 0

exec-timeout 0 0

password

login

transport input none

line aux 0

line vty 0 1

password

login

line vty 2 4

password

login

!

end

Re: Dial-up ISDN Routing Question

I suppose you are using private addressing for the workstations on LAN. YOu should be using NAT on the router, to connect to the internet. Your BRI port is getting an IP add from the ISP, which is a public IP and thats the reason why you can reach the internet.

New Member

Re: Dial-up ISDN Routing Question

Thanks for responding.

Yes we are using Private IP Addresses on the LAN via Novell BorderManager which is before the router on the LAN side. To be honest I'd rather not change that.

So now I need to figure out how to enable NAT for the BRI0/Dialer0 and FastEthernet0 configuration but still be able to keep my static IP Address on the FastEthernet int so things work for routing to the Serial0 int.

Sheeeeeeeesh

Greg

198
Views
0
Helpful
4
Replies
CreatePlease to create content