Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Dialer Watch: BRI will not go down after primary is up

I have r5 configured to watch network 200.0.0.2/32 which is the loopback address of the other isdn router, r2. The primary link between the two routers is a frame relay network. The routing protocol is eigrp. The problem is that r5 will always dial to r2 and istall the route over isdn link even if the primary link is up. The " debug ip routing" command shows me that the router does this because the route to r2's loopback interface has a lower admin distance over isdn as you can see from the output below. What could be the problem?

r5#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is not set

200.0.0.0/32 is subnetted, 2 subnets

C 200.0.0.2 is directly connected, BRI0

C 200.0.0.5 is directly connected, Loopback0

150.50.0.0/16 is variably subnetted, 2 subnets, 2 masks

C 150.50.9.0/26 is directly connected, BRI0

C 150.50.100.0/27 is directly connected, Serial0

====================

r5#clear int bri 0

r5#

04:14:21: %ISDN-6-DISCONNECT: Interface BRI0:1 disconnected from 8358661 r2, call lasted 1381 seconds

04:14:21: %LINK-3-UPDOWN: Interface BRI0:1, changed state to down

04:14:22: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down

r5#

04:14:22: RT: del 200.0.0.2/32 via 0.0.0.0, connected metric [0/0]

04:14:22: RT: delete subnet route to 200.0.0.2/32

04:14:22: RT: add 200.0.0.2/32 via 150.50.9.2, eigrp metric [100/40640000]

04:14:22: RT: del 200.0.0.2/32 via 150.50.9.2, eigrp metric [100/40640000]

04:14:22: RT: add 200.0.0.2/32 via 150.50.100.2, eigrp metric [100/2297856]

04:14:22: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, changed state to down

04:14:23: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to down

r5#

04:14:23: is_up: 1 state: 4 sub state: 1 line: 0

r5#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is not set

200.0.0.0/32 is subnetted, 2 subnets

D 200.0.0.2 [100/2297856] via 150.50.100.2, 00:00:07, Serial0

C 200.0.0.5 is directly connected, Loopback0

150.50.0.0/16 is variably subnetted, 2 subnets, 2 masks

C 150.50.9.0/26 is directly connected, BRI0

C 150.50.100.0/27 is directly connected, Serial0

r5#

04:15:22: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up

r5#

04:15:24: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up

r5#

04:15:24: is_up: 1 state: 4 sub state: 1 line: 0

04:15:24: RT: closer admin distance for 200.0.0.2, flushing 1 routes

04:15:24: RT: add 200.0.0.2/32 via 0.0.0.0, connected metric [0/0]

r5#

04:15:25: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, changed state to up

04:15:25: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to up

r5#

04:15:28: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 8358661 r2

r5#

===========================

r5#show ip int brief

Interface IP-Address OK? Method Status Protocol

BRI0 150.50.9.5 YES NVRAM up up

BRI0:1 unassigned YES unset up up

BRI0:2 unassigned YES unset down down

Ethernet0 150.50.7.5 YES NVRAM administratively down down

Loopback0 200.0.0.5 YES NVRAM up up

Serial0 150.50.100.5 YES NVRAM up up

Serial1 unassigned YES NVRAM administratively down down

Virtual-Access1 unassigned YES TFTP up up

r5#

=====================

r5#show run

Building configuration...

Current configuration : 1721 bytes

!

version 12.1

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname r5

!

logging rate-limit console 10 except errors

!

ip subnet-zero

no ip finger

no ip domain-lookup

!

isdn switch-type basic-ni

cns event-service server

!

!

!

!

!

interface Loopback0

ip address xxx.xxx.xx.5 255.255.255.255

!

interface Ethernet0

ip address xxx.xx.7.5 255.255.255.128

shutdown

!

interface Serial0

ip address 150.50.100.5 255.255.255.224

encapsulation frame-relay

frame-relay map ip 150.50.100.2 501 broadcast

frame-relay map ip 150.50.100.5 501

frame-relay map ip 150.50.100.6 501 broadcast

frame-relay lmi-type cisco

!

interface Serial1

no ip address

shutdown

!

interface BRI0

ip address 150.50.9.5 255.255.255.192

encapsulation ppp

dialer watch-disable 5

dialer map ip 200.0.0.2 name r2 broadcast 8358661

dialer map ip 150.50.9.2 name r2 broadcast 8358661

dialer watch-group 1

dialer-group 1

isdn switch-type basic-ni

isdn spid1 0835866201 8358662

isdn spid2 0835866401 8358664

ppp multilink

!

router eigrp 100

passive-interface Loopback0

network 150.50.0.0

network 200.0.0.0

distance 100 0.0.0.0 255.255.255.255

distance 100 150.50.9.5 0.0.0.0

distance 100 150.50.9.2 0.0.0.0

no auto-summary

no eigrp log-neighbor-changes

!

ip kerberos source-interface any

ip classless

ip http server

!

!

map-class dialer myclass

access-list 101 deny eigrp any any

access-list 101 permit ip any any

dialer watch-list 1 ip 200.0.0.2 255.255.255.255

dialer-list 1 protocol ip list 101

!

alias exec br show ip interface brief

!

line con 0

exec-timeout 0 0

logging synchronous

transport input none

line aux 0

line vty 0 4

login

!

end

r5#

===========================

r5#show dialer

BRI0 - dialer type = ISDN

Dial String Successes Failures Last DNIS Last status

8358661 10 8 00:09:16 successful

0 incoming call(s) have been screened.

0 incoming call(s) rejected for callback.

BRI0:1 - dialer type = ISDN

Idle timer (120 secs), Fast idle timer (20 secs)

Wait for carrier (30 secs), Re-enable (15 secs)

Dialer state is multilink member

Dial reason: Dialing on watched route loss

Connected to 8358661 (r2)

BRI0:2 - dialer type = ISDN

Idle timer (120 secs), Fast idle timer (20 secs)

Wait for carrier (30 secs), Re-enable (15 secs)

Dialer state is idle

r5#

6 REPLIES
Bronze

Re: Dialer Watch: BRI will not go down after primary is up

Your configuration includes both the dialer watch-group and the dialer-group. I don't believe that the dialer-group is necessary when you have a dialer-watch group. Try eliminating the dialer-group and see if the dial backup behavior acts as you expect.

HTH

Mark

New Member

Re: Dialer Watch: BRI will not go down after primary is up

dou you receive the watched route by serial link? If you do, the dial-back-up should not be triggered!!!

New Member

Re: Dialer Watch: BRI will not go down after primary is up

If the route being watched is seen through the serial link the dial-back-up should not be initiated. The problem when the metric through isdn is lower than normal link appears when the isdn must be disconnected ( when primary is up). If you use ospf you could use "ip ospf cost" under isdn interface to increase the metric or under the other interface to decrease the metric, so the metric on isdn to be the largest. If you want to use eigrp try to see if you can achieve the same thing by redistributing the route being watched with some metric....

Adi

New Member

Re: Dialer Watch: BRI will not go down after primary is up

EIGRP calculate is metric by default of Bandwidth + Delay.

EIGRP cannot determine the true bandwidth of a connection it relies on the user to configure this with the bandwidth command on the physical interface.

I see no bandwidth statement configured. This means that your two interfaces have relied on their defaults. So EIGRP is probably preferring the link with less delay. In this case it must be your ISDN link. Try manually setting bandwidth statements on your interfaces. You'll need your Serial link to 'show' a higher bandwidth than the ISDN.

New Member

Re: Dialer Watch: BRI will not go down after primary is up

I had issues running dialer watch with eigrp. What version of code are you running? Cisco states that dialer watch was not stable until 12.1(7) I believe. I ended up in 12.2 train for everything to be stable. It looks like dialer watch is not recognizing the valid route seen via eigrp.

Mark

New Member

Re: Dialer Watch: BRI will not go down after primary is up

I think using BRI int as backup will solve ur problem.

int s0

backup interface bri0

backup delay 20 30

Amit Shrivastava

amtiger0@yahoo.com

India

134
Views
0
Helpful
6
Replies