Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Dialer watch cannot work with ppp multilink 128k ISDN backup

Initially I have a leased line, backup by 64k ISDN using dialer watch and OSPF. So when the leased line fails, the 64k ISDN will kick in due to lost route and the ISDN will disconnect when the leased line is restored.

Recently I want to backup my leased line using 128k ISDN by adding additional command like ppp multilink and dialer load-threshold 1 either. When my leased line fails, the 128k ISDN will kick in but when the leased line is restored, this 2 channels ISDN never get disconnected! It still connected after 3 hours.....The ISDN by default comes with 128k, so it has only one phone number.

Anyone cares to enlighten me?

Thanks a lot.

Branch Config: Cisco 1721

abc#sh ru

Building configuration...

Current configuration : 1975 bytes

!

! Last configuration change at 12:23:46 UTC Wed Apr 30 2003

! NVRAM config last updated at 12:23:50 UTC Wed Apr 30 2003

!

version 12.2

service timestamps debug datetime

service timestamps log datetime

service password-encryption

!

hostname abc

!

logging buffered 4096 debugging

enable secret 456

!

username xxxxxx password xxxx

ip subnet-zero

no ip domain lookup

ip host tp 10.100.100.2

!

!

isdn switch-type basic-net3

!

!

!

interface Loopback0

ip address 172.30.90.1 255.255.255.0

!

interface Tunnel0

bandwidth 2000

ip address 10.205.1.34 255.255.255.252

ip tcp adjust-mss 1436

keepalive 10

tunnel source Ethernet0

tunnel destination 10.100.100.2

!

interface BRI0

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

ppp authentication chap

!

interface Ethernet0

ip address 192.168.1.2 255.255.255.252

half-duplex

!

interface FastEthernet0

ip address 10.200.90.1 255.255.255.0

speed auto

!

interface Dialer0

bandwidth 128

ip address 10.205.2.34 255.255.255.252

encapsulation ppp

ip ospf hello-interval 30

dialer pool 1

dialer remote-name GVCore2

dialer idle-timeout 10

dialer string 67854127

dialer load-threshold 1 either

dialer watch-group 1

dialer-group 1

ppp authentication chap

ppp multilink

!

router ospf 1

log-adjacency-changes

network 10.0.0.0 0.255.255.255 area 0

!

ip classless

ip route 10.100.100.0 255.255.255.252 192.168.1.1

no ip http server

!

!

dialer watch-list 1 ip 10.199.99.0 255.255.255.0

dialer watch-list 1 delay route-check initial 15

dialer watch-list 1 delay disconnect 20

dialer-list 1 protocol ip deny

snmp-server community public RO

snmp-server enable traps tty

!

line con 0

logging synchronous

stopbits 1

line aux 0

line vty 0 4

password xxxx

login

!

scheduler max-task-time 5000

no scheduler allocate

end

HQ config: Cisco 2621XM

GVCore2#sh ru

Building configuration...

Current configuration : 5344 bytes

!

! Last configuration change at 12:16:18 UTC Wed Apr 30 2003

! NVRAM config last updated at 12:16:19 UTC Wed Apr 30 2003

!

version 12.2

service timestamps debug datetime

service timestamps log datetime

service password-encryption

!

hostname GVCore2

!

logging buffered 4096 debugging

enable secret xxxx

!

username xxxx password xxx

ip subnet-zero

!

!

no ip domain lookup

!

isdn switch-type basic-net3

!

!

!

!

interface Loopback0

ip address 172.30.95.1 255.255.255.0

!

interface FastEthernet0/0

ip address 10.199.99.12 255.255.255.0

no ip redirects

duplex auto

speed auto

no standby redirect

standby 1 ip 10.199.99.10

!

interface BRI0/0

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

ppp authentication chap

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface BRI0/1

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

ppp authentication chap

!

interface BRI1/0

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

ppp authentication chap

!

interface BRI1/1

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

ppp authentication chap

!

interface BRI1/2

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

ppp authentication chap

!

interface BRI1/3

no ip address

shutdown

isdn switch-type basic-net3

!

interface Dialer8

bandwidth 128

ip address 10.205.2.33 255.255.255.252

encapsulation ppp

ip ospf hello-interval 30

dialer pool 1

dialer remote-name abc

dialer idle-timeout 60

dialer-group 1

ppp authentication chap

ppp multilink

!

router ospf 1

log-adjacency-changes

network 10.199.99.0 0.0.0.255 area 0

network 10.205.2.0 0.0.0.255 area 0

default-information originate

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.199.99.21

ip route 10.200.20.0 255.255.255.0 10.199.99.11

ip route 172.16.0.0 255.255.0.0 10.199.99.30

ip route 192.168.1.0 255.255.255.252 10.199.99.11

ip route 202.160.0.0 255.255.0.0 10.199.99.11

ip http server

!

!

dialer-list 1 protocol ip permit

snmp-server community public RO

snmp-server enable traps tty

!

line con 0

logging synchronous

line aux 0

line vty 0 4

password 456

login

!

!

end

6 REPLIES
Bronze

Re: Dialer watch cannot work with ppp multilink 128k ISDN backup

Check the ospf interface cost of the isdn 128k versus the leased line. The isdn route may be better now that the bandwidth has increased so the leased line route will not be put into the route table. If thats is the problem fix it with higher ospf cost on the dialer interface.

New Member

Re: Dialer watch cannot work with ppp multilink 128k ISDN backup

When the leased line is restored, all the routes in routing table are leased line route. I have checked already.

Bronze

Re: Dialer watch cannot work with ppp multilink 128k ISDN backup

So it not that it is still using the isdn, it just isnt hanging it up. I would think you need "ip ospf demand circuit" on the dialer interface but you said it was working with 64k. Try deb ip packet and see whats crossing the link.

New Member

Re: Dialer watch cannot work with ppp multilink 128k ISDN backup

Looks to me like you are still running CDP on your BRI and Dialer interfaces. This will definitevly keep it up. You might want to disable CDP on these interfaces with the command

no cdp enable

Or disable it entirely on the router with the global command

no cdp run

New Member

Re: Dialer watch cannot work with ppp multilink 128k ISDN backup

Finally my problem solved by using dialer load-threshold (2 and above) either.

The ISDN backup link refuse to disconnect if I use dialer load-threshold 1 either. It sounds wierd to me but it works.....

New Member

Re: Dialer watch cannot work with ppp multilink 128k ISDN backup

Remove dialer-group 1 when using Dialer watch- group on watched interfaces

Use either but not both

127
Views
0
Helpful
6
Replies