Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

DIALER WATCH IDLE TIMEOUT

Hello

I use dialler watch and it works fine.

When the primary link fail then the backup interface is activated (BRI)

My question is when the primary link is down and the backup (BRI) link is idle I want to disconnect and connect only when map interesting traffic.

I use dialler idle-timeout and access-list for the interesting traffic

Configuration:

interface BRI0

description *** (BACKUP) ***

ip unnumbered Loopback1

encapsulation ppp

no ip route-cache

load-interval 30

dialer idle-timeout 121

dialer string 8962488888

dialer hold-queue 5

dialer watch-group 1

dialer-group 1

isdn switch-type basic-net3

no fair-queue

no cdp enable

ppp pap sent-username xxx password xxxxxx

ppp multilink

dialer watch-list 1 ip xx.xx.xx.xx 255.255.255.xxx

dialer watch-list 1 delay connect 30

dialer-list 1 protocol ip list 111

access-list 111 deny ospf any any

access-list 111 permit icmp any any

access-list 111 permit tcp any any eq smtp

access-list 111 permit tcp any any eq pop3

access-list 111 permit tcp any any eq 8080

access-list 111 permit tcp any any eq www

access-list 111 permit tcp any any eq telnet

access-list 111 permit tcp any any eq ftp

access-list 111 permit tcp any any eq domain

access-list 111 permit udp any any eq domain

access-list 111 deny ip any any

Router-Name#sh dialer

BRI0 - dialer type = ISDN

Dial String Successes Failures Last DNIS Last status

8888888888 2 0 2d21h successful Default

0 incoming call(s) have been screened.

0 incoming call(s) rejected for callback.

BRI0:1 - dialer type = ISDN

Idle timer (121 secs), Fast idle timer (20 secs)

Wait for carrier (30 secs), Re-enable (15 secs)

Dialer state is idle

BRI0:2 - dialer type = ISDN

Idle timer (121 secs), Fast idle timer (20 secs)

Wait for carrier (30 secs), Re-enable (15 secs)

Dialer state is multilink member

Dial reason: Dialing on watched route loss

Current call connected 2d21h

Connected to 8888888888 (Remote-name)

George

2 REPLIES
Silver

Re: DIALER WATCH IDLE TIMEOUT

You can use floating routes instead. Give more distance to your BRI/Dialer route. As soon as your primary goes that, it will down low distance route as well and your secondary route/BRI will kick in.

HTH.

New Member

Re: DIALER WATCH IDLE TIMEOUT

I use OSPF to the primary link (Fastethernet)

and default route to BRI

how can i do it with floating routes ???

I also use OSPF to BRI0 when is connecting

interface FastEthernet0

description *** Primary Link ***

ip address 10.10.10.20 255.255.255.0

ip accounting access-violations

ip nat outside

speed 10

interface BRI0

description *** BACKUP ***

ip unnumbered Loopback1

full-duplex

interface Loopback1

description *** Dial BACKUP ***

ip address 192.168.1.1 255.255.255.255

router ospf 50

log-adjacency-changes

redistribute connected subnets

redistribute static subnets

network 10.10.10.20 0.0.0.0 area 3

network 192.168.1.1 0.0.0.0 area 3

!

ip default-gateway 10.10.10.30

ip route 0.0.0.0 0.0.0.0 BRI0 180

Goerge

109
Views
0
Helpful
2
Replies