Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Dialer Watch over PRI to PRI

I am trying to set up a dialer watch on a PRI ISDN to dial into another PRI. I think I have everything set up correctly, but my PRI dials every 2 minutes for approximately 25 seconds, then hangs up.

13 REPLIES
Cisco Employee

Re: Dialer Watch over PRI to PRI

We need to see the running config from the router. You can enable the following debug to see what kind of traffic is triggring the call. 25 secs is enough to connect the isdn call but not sure the data transfer is happening or not.

debug dialer

debug isdn q931

debug ppp nego

term mon

Here is the link which will explain you how to debug that too

http://www.cisco.com/warp/public/793/access_dial/bri_isdn_11048.html

Community Member

Re: Dialer Watch over PRI to PRI

Hi,

Thanks for the debug dialer hint. Looks like my problem is not being able to dial out using Dialer watch, but it looks like the dialer will not stop callin, even though the router sees the primary route become available again. Please see below:

3w4d: DDR: Dialer Watch: watch-group = 5

3w4d: DDR: network 10.141.0.0/255.255.248.0 UP,

3w4d: DDR: primary UP

3w4d: %ISDN-6-DISCONNECT: Interface Serial4/0:22 disconnected from 7007335012 PHL-3662-01, call las

ted 32 seconds

3w4d: %LINK-3-UPDOWN: Interface Serial4/0:22, changed state to down

3w4d: DDR: Dialer Watch: watch-group = 5

3w4d: DDR: network 10.141.0.0/255.255.248.0 UP,

3w4d: DDR: primary UP

3w4d: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial4/0:22, changed state to down

3w4d: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to down

3w4d: %LINK-3-UPDOWN: Interface Serial4/0:22, changed state to up

3w4d: Vi1 Debug: Condition 1, interface Di141 triggered, count 1

3w4d: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up

3w4d: Vi1 DDR: Dialer statechange to up

3w4d: Vi1 DDR: Dialer call has been placed

3w4d: Vi1 PPP: Using dialer call direction

3w4d: Vi1 PPP: Treating connection as a callout

3w4d: Vi1 PPP: Phase is ESTABLISHING, Active Open [0 sess, 1 load]

3w4d: Vi1 CHAP: Using alternate hostname SCK-3662-01

3w4d: Vi1 LCP: O CONFREQ [Closed] id 1 len 33

3w4d: Vi1 LCP: AuthProto CHAP (0x0305C22305)

3w4d: Vi1 LCP: MagicNumber 0x8BFFC1DE (0x05068BFFC1DE)

3w4d: Vi1 LCP: MRRU 1524 (0x110405F4)

3w4d: Vi1 LCP: EndpointDisc 1 SCK-3662-01 (0x130E0153434B2D333636322D3031)

3w4d: Vi1 PPP: Phase is UP [0 sess, 1 load]

3w4d: Vi1 IPCP: O CONFREQ [Closed] id 1 len 10

3w4d: Vi1 IPCP: Address 10.141.232.9 (0x03060A8DE809)

3w4d: Vi1 IPCP: I CONFREQ [REQsent] id 1 len 10

3w4d: Vi1 IPCP: Address 10.141.232.1 (0x03060A8DE801)

3w4d: Vi1 IPCP: O CONFACK [REQsent] id 1 len 10

3w4d: Vi1 IPCP: Address 10.141.232.1 (0x03060A8DE801)

3w4d: Vi1 IPCP: I CONFACK [ACKsent] id 1 len 10

3w4d: Vi1 IPCP: Address 10.141.232.9 (0x03060A8DE809)

3w4d: Vi1 IPCP: State is Open

3w4d: Vi1 DDR: dialer protocol up

3w4d: Di141 IPCP: Install route to 10.141.232.1

3w4d: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial4/0:22, changed state to up

3w4d: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to up

Community Member

Re: Dialer Watch over PRI to PRI

In advance, I appreciate your help!!

Here's the current config, with non-essential information deleted/changed

Current configuration : 8717 bytes

!

version 12.2

no parser cache

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname SCK-3662-01

!

logging buffered 16000 debugging

logging console critical

!

username PHL-3662-01 password 7 1309120606090D24

clock timezone GMT 0

ip subnet-zero

!

no ip bootp server

ipx routing 0008.21cd.2230

!

isdn switch-type primary-4ess

call rsvp-sync

!

!

fax interface-type fax-mail

mta receive maximum-recipients 0

!

controller T1 4/0

framing esf

linecode b8zs

pri-group timeslots 1-24

username PHL-3662-01 password 7 1309120606090D24

clock timezone GMT 0

ip subnet-zero

!

!

!

no ip bootp server

ipx routing 0008.21cd.2230

!

isdn switch-type primary-4ess

call rsvp-sync

!

fax interface-type fax-mail

mta receive maximum-recipients 0

!

controller T1 4/0

framing esf

linecode b8zs

pri-group timeslots 1-24

!

ip address 10.11.0.145 255.255.255.252

no ip proxy-arp

ipx network DAC6000

serial restart-delay 0

--More--

3w4d: Vi1 Debug: Condition 1, interface Di141 cleared, count 0

3w4d: %ISDN-6-DISCONNECT: Interface Serial4/0:22 disconnected from 7007335012 PHL-3662-01, call las

ted 32 seconds

3w4d: %LINK-3-UPDOWN: Interface Serial4/0:22, changed state to down

3w4d: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial4/0:22, changed state to down

3w4d: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to down

3w4d: %LINK-3-UPDOWN: Interface Serial4/0:22, changed state to up

3w4d: Vi1 Debug: Condition 1, interface Di141 triggere no cdp enable

!

!

interface ATM3/IMA0.40 point-to-point

description To Philadelphia, PA

ip address 10.1.0.5 255.255.255.252

no ip proxy-arp

pvc 4/40

vbr-nrt 3000 384 32

oam-pvc manage

!

!

3w4d: %LINK-3-UPDOWN: Interface Virtual-Access1, changed sinterface !

3w4d: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial4/0:22, changed state to up

interface Serial4/0:23

description ISDN backup to PHL

no ip address

encapsulation ppp

no ip route-cache

no keepalive

dialer rotary-group 141

isdn switch-type primary-4ess

no cdp enable

ppp authentication chap

!

interface Dialer141

bandwidth 64

ip address 10.141.232.9 255.255.248.0

encapsulation ppp

no keepalive

dialer in-band

dialer idle-timeout 30

dialer watch-disable 15

dialer map ip 10.141.232.1 name PHL-3662-01 class sdn broadcast 7005551212 (changed for this display only)

dialer map ip 10.141.0.0 name PHL-3662-01 class sdn broadcast 7005551212 (changed for this display only)

dialer load-threshold 10 outbound

dialer watch-group 5

dialer-group 2

no cdp enable

ppp authentication chap

ppp chap hostname SCK-3662-01

ppp chap password 7 07032458430C100B

ppp multilink

multilink max-links 6

!

router eigrp 1011

redistribute static

passive-interface ATM3/IMA0.135

network 10.0.0.0

auto-summary

no eigrp log-neighbor-changes

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.11.1.9

no ip http server

!

!

map-class dialer sdn

dialer outgoing sdn

logging trap debugging

logging 10.11.1.19

access-list 101 permit ip host 10.141.232.9 host 10.141.232.1

access-list 101 deny ip any any

access-list 101 deny eigrp any any

dialer watch-list 5 ip 10.141.0.0 255.255.248.0

dialer-list 2 protocol ip list 101

no cdp run

!

!

dial-peer cor custom

!!

end

SCK-3662-01#

3w4d: %ISDN-6-CONNECT: Interface Serial4/0:22 is now connected to 7007335012 PHL-3662-01

Silver

Re: Dialer Watch over PRI to PRI

With a default configuration, it takes 22 seconds for an authentication failure to clear the line. Watch out for names and passwords, case is significant and Cisco does not like embedded spaces. Also make sure that selection of authentication protocols (PAP, CHAP, whatever) and direction (who authenticates who) are configured consistently.

Good luck and good hunting!

Vincent C Jones

www.networkingunlimited.com

Community Member

Re: Dialer Watch over PRI to PRI

Hi Vincent,

I bought your book...Excellent reference and explanations. It looks like I am dialing out OK, but for some reason the dialer watch keeps kicking in even after it looks like it sees the primary (watched) route come up. I posted a running config just a few minutes ago, if you can take a look and offer any other suggestions, that would be great. Also, why do most references, including Cisco and your book not show a PRI dialing to another PRI? Is this unusual, or should it not be done? Please excuse me if this question is too simplistic! Thanks and again, great book!

Bronze

Re: Dialer Watch over PRI to PRI

Check this bug

bugid=CSCdv77179

Community Member

Re: Dialer Watch over PRI to PRI

Man, that's disappointing to find, but thanks for pointing it out to me! I guess I'll have to find another method, like floating static route perhaps to do what I want.

Thanks greatly!

George

Silver

Re: Dialer Watch over PRI to PRI

While the bug cited may ba a critical one for you, it is not the problem with your calls failing after about 25 seconds. I think if you do a "debug ppp authentication" you will get some hints as to why CHAP authentication is failing.

Thanks for the good vibes on my book.

Vincent C Jones

www.networkingunlimited.com

Community Member

Re: Dialer Watch over PRI to PRI

Thanks for the tip...I did the debug ppp authentication, and changed my config to make it a little cleaner (not using the alternate hostname). It looks like the real problem is the Dialer Watch keeps dialing out even after the primary comes back up.

I looked up the bug mentioned above and it appears this gets fixed in 12(2)15. I'll install 12(2)16 and see if this fixes it.

Community Member

Re: Dialer Watch over PRI to PRI

I think I am getting close to getting this fixed. I finally have authentication and dialing configured. The only problem remaining is that after 300 seconds (the dialer idle-timeout expires), the dialer dials out to the watched router...after 300 seconds, the connnection momentarily drops, and then the dialer dials out again. I upgraded to IOS 12(2)16, but it doesn't seem to help.

Silver

Re: Dialer Watch over PRI to PRI

Are you sure there is traffic from host 10.141.232.9 to host 10.141.232.1 going out the dialer interface? That is the only traffic which has been defined as interesting. Dialer watch will dial a call, but you still need DDR correctly configured to keep the link up.

Good luck and have fun!

Vincent C Jones

www. networkingunlimited.com

P.S. EIGRP uses IP packets, so your "denies" (copied below) are redundant, doubly so since by default, there is an implied "deny any any" appended to the access list.

access-list 101 permit ip host 10.141.232.9 host 10.141.232.1

access-list 101 deny ip any any

access-list 101 deny eigrp any any

Community Member

Re: Dialer Watch over PRI to PRI

i am just trying to configure pri to connect to pri at a disaster recovery site. Is this something you are doing/have done?

Community Member

Re: Dialer Watch over PRI to PRI

Hi,

I have just finshed doing this. PRI-to-PRI dial backup. I used a dialer watch scheme. I had difficulty getting a 5-ess switch to talk to a 4-ess switch, so I had to dial from the 4-ess end. I got the circuit connected to the 5-ess rehomed to point to a 4-ess and it seems to wrok without problems.

119
Views
0
Helpful
13
Replies
CreatePlease to create content