Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

DIALING THE ISP

I have a Cisco 2621 with a WIC 1DSU 56/64K. I want to set it up so it can dial the local ISP and be able to log on and browse the internet thru the fasteth0/0. Can anyone please help me out.

Thanks for your time,

Singh

11 REPLIES
New Member

Re: DIALING THE ISP

Router (config)#interface FastEthernet0/0

Router (config-if)# ip address 192.168.5.1 255.255.255.0

Router (config-if)# no ip directed-broadcast

Router (config-if)# ip nat inside

Router (config-if)#interface BRI0

Router (config-if)# ip address negotiated

Router (config-if)# no ip directed-broadcast

Router (config-if)# ip nat outside

Router (config-if)# encapsulation ppp

Router (config-if)# dialer idle-timeout 180

Router (config-if)# dialer string 3328400

Router (config-if)# dialer-group 1

Router (config-if)# isdn switch-type basic-net3

Router (config-if)# ppp authentication pap chap callin

Router (config-if)# ppp chap hostname xxxx( Your ISP account)

Router (config-if)# ppp chap password xxxxx ( ISP account passeord )

Router (config-if)# ppp pap sent-username xxxx password xxxxx

Router (config-if)#exit

Router (config)#ip nat inside source list 10 interface BRI0 overload

Router (config)#ip route 0.0.0.0 0.0.0.0 BRI0

!

Router (config)#access-list 10 permit 192.168.5.0 0.0.0.255

Router (config)#access-list 10 permit 192.168.3.0 0.0.0.255

Router (config)#access-list 10 permit 10.0.0.0 0.255.255.255

Router (config)#access-list 10 permit 30.0.0.0 0.255.255.255

Router (config)#dialer-list 1 protocol ip permit

u try with this configuration.

your pc's should have gateway as your fastethernt 0/0 ip address

bye

New Member

Re: DIALING THE ISP

First I want to thank you for your assistant. I don't have bri0 on my 2621. I have 1 Serial network interface that is WIC 1DSU 56/64K DSU/CSU. I tried typing in bri0 and it gave me an error. So please help if you know how to program this serial int to dial the isp.

Thanks for your time,

singh

New Member

Re: DIALING THE ISP

I think you have WIC Async/sync module. This interface is used for serial 128kbps as well as dial up 56 kbps. we can connect analog modem to this interface using 60 pin towards router serial and 25 (or) 9 pin towards analog modem

you need to get cable to connect. we can connect to isp in this way.

Re: DIALING THE ISP

Unless I misunderstand, you wouldn't normally use a WIC-1DSU-56K to "dial" an ISP, this would be used for a dedicated line to the ISP. If so, you would get the IP address(es) from your ISP, configure the serial interface for the WIC with that IP info. Then set up routing (probably static routes or BGP, again, ask the ISP), NAT (probably), firewalling of some kind (DEFINITELY, imho), plug in the line, and off you go.

If I'm wrong, by all means (someone should) let me know....

New Member

Re: DIALING THE ISP

If I do get a dedicated line to the ISP with a static IP address can you please guide me to how I would program WIC-1DSU-56K serial interface by giving me an example. I have tried everything with my knowledge and couldn't get it up and running.

Thanks you for your time,

Singh

Re: DIALING THE ISP

Surely. Here's the sample config:

version 12.2

service timestamps debug datetime localtime

service timestamps log datetime localtime

service password-encryption

!

hostname ISP-Router

!

logging buffered 65536 debugging

logging console informational

logging monitor informational

enable secret

!

clock timezone PST -8

clock summer-time PDT recurring

ip subnet-zero

ip cef

!

!

ip name-server 198.6.1.146

ip name-server 198.6.1.195

!

!

!

!

interface Ethernet0/0

description Office Ethernet

ip address 192.168.1.254 255.255.255.0

no ip redirects

!

interface Serial0/0

description Link to ISP

bandwidth 56

ip address 192.168.255.254 255.255.255.252

encapsulation frame-relay IETF

no ip mroute-cache

frame-relay interface-dlci 500

frame-relay lmi-type ansi

!

!

ip classless

ip default-network 0.0.0.0

ip route 192.168.1.0 255.255.255.0 ethernet0/0

ip route 0.0.0.0 0.0.0.0 192.168.255.253

!

!

snmp-server community public RO

snmp-server enable traps tty

!

!

!

line con 0

exec-timeout 5 0

password

login

line aux 0

exec-timeout 5 0

password

login

line vty 0 4

exec-timeout 5 0

password

login

line vty 5 16

exec-timeout 5 0

password

login

!

ntp server x.x.x.x

ntp server x.x.x.x prefer

end

The Serial0 interface in this case is config'd as Frame-Relay, might or might not be in your case, if not remove the "encapsulation" and "frame-relay" lines. The example uses 192.168.1.0/24 as your "inside" LAN address, and the 192.168.255.252/30 as the ISP-assigned WAN addresses (obviously they won't use those on the actual Internet). If you only have a single LAN network, the 192.168.1.0/24 net, you won't need the "ip route 192.168.1.0 255.255.255.0 ethernet0/0" statement. The "ip default-network" and "ip route 0.0.0.0 0.0.0.0 192.168.255.253" makes the Internet your default route - anything not otherwise routed will go out through the Serial0 to the Internet.

This example does NOT include NAT (which you WILL need if you use private addresses in your LAN), nor any firewalling. But a 2621 *should* be able to run the Firewall Feature Set (do they still call it that?) for the traffic on a 56K line.

Start with the basics here and see how you make out. No guarantees but I hope this gets you started.

New Member

Re: DIALING THE ISP

Ptrivino, thanks for your assistant again, I am new to Cisco routers and can you please elaborate me the setup like you had show in the beginning by setting 56/64k csu/dsu. If you can it would be very grate full. Also would I still be using all the command shown under interface bri0 into serial0/0.

Thanks again,

Singh

Re: DIALING THE ISP

First, no, I don't think you'll use much of the BRI0 stuff in the other submitted config - a BRI port *does* dial, so it's quite different.

It would be a little tough to walk you through the whole configuration, but here's an idea - go to http://www.cisco.com/univercd/cc/td/doc/clckstrt/cfgmkr/download.htm and get the ConfigMaker application. It will walk you through configuring the device, in a wizard-like manner (I believe that's how it works, it came out after I'd fought my way through the basics), and you'll come up with a config somewhat similar to what I posted, but you'll understand the setup better. Also, the whole Cisco.com site is full of configuration documents, reference guides, etc. It can be a bit overwhelming at first, but they really do have everything on the web site. These forums (and I'm pretty new here, myself) are really aimed at answering "small" questions - but you should definitely keep reading the posts, you'd be amazed at how much you'll learn by following along.

If you have some specific questions, drop me a line at ptrivino@alarismed.com, and I'll see if I can help.

New Member

Re: DIALING THE ISP

New Member

Re: DIALING THE ISP

Hi, I want to thank you for responding. I tried clicking the link but I don't have access to secured ciso site. If there is anyway you can paste that config or copy and email the page, I would really appreciate it.

Thanks for your time,

Singh

New Member

Re: DIALING THE ISP

129
Views
0
Helpful
11
Replies