Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Dialup Keeps Disconnecting

I have a unique dial-up setup for a remote LAN. My LAN consists of Aironet wireless products and a Cisco1602 R router. This LAN is not a standard LAN as it has no PC connected to it. The host stations consist of GPS devices and Lantronix IP servers. The GPS devices send data ever 10 seconds via the WLAN to my NOC. The router connects to the Internet via a Dial-up line. My problem is, that my router keeps disconnecting. Most of the time it will reconnect but on a few occasions it has had to be touched my a remote operator (myself) via telnet or consol to get it to reconnect.

Why does it keep disconnecting?

Debug modem and debug dialer outputs

01:06:59: TTY0: timer type 1 expired

01:06:59: TTY0: Exec-timeout expired

01:06:59: TTY0: destroy timer type 1

01:06:59: TTY0: Line reset by "Exec"

01:07:00: TTY0: Modem: (unknown)->READY

01:07:00: TTY0: destroy timer type 0

01:07:00: TTY0: no timer type 1 to destroy

01:07:00: TTY0: no timer type 3 to destroy

01:07:00: TTY0: no timer type 4 to destroy

01:07:00: TTY0: no timer type 2 to destroy

Site_Controller>

01:11:34: TTY0: EXEC creation

01:11:34: TTY0: create timer type 0, 599980 seconds

01:11:34: TTY0: create timer type 1, 600 seconds

Running Config

Current configuration:

!

version 12.1

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Site_Controller

!

enable secret 5 $1$8N4R$sLtyZJ3bBNoTdphJuvBCg.

enable password killroy

!

!

!

!

!

ip subnet-zero

ip name-server 209.70.44.6

ip name-server 46.53.183.40

!

chat-script rstmdm "" "AT&FS0=1&B1&C1&D2&H1&K1&M4&R2" OK

chat-script dialnum ABORT ERROR ABORT BUSY "" "ATDT \T" TIMEOUT 60 CONNECT

!

!

!

interface Ethernet0

ip address 192.168.103.1 255.255.255.0

ip nat inside

!

interface Serial0

no ip address

shutdown

service-module 56k clock source line

service-module 56k network-type dds

!

interface Serial1

physical-layer async

ip address 209.71.44.243 255.255.255.0

ip nat outside

encapsulation ppp

dialer in-band

dialer rotary-group 0

dialer-group 1

async default routing

async mode dedicated

no cdp enable

!

interface Dialer0

ip address negotiated

ip nat outside

encapsulation ppp

keepalive 60

dialer in-band

dialer idle-timeout 600

dialer string 8388090

dialer-group 1

no cdp enable

ppp authentication pap callin

ppp pap sent-username happyman password 7 09424B1D1F0A05110E5D

!

ip nat inside source list 18 interface Dialer0 overload

ip nat outside source static udp 209.74.44.11220052 209.74.44.1121033 extendab

le

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer0

no ip http server

!

access-list 18 permit 192.168.103.0 0.0.0.255

access-list 18 permit any

access-list 100 permit ip 192.168.0.0 0.0.255.255 any

dialer-list 1 protocol ip permit

!

line con 0

session-timeout 35791

location Mezure's lab in Bend OR.

absolute-timeout 10000

logging synchronous level 0

history size 100

transport input none

line 2

script dialer dialnum

script reset rstmdm

modem InOut

modem autoconfigure type netforce1

transport input all

stopbits 1

speed 115200

flowcontrol hardware

line vty 0 4

password killroy

login

!

end

3 REPLIES
Cisco Employee

Re: Dialup Keeps Disconnecting

"debug dialer" will let us know about why the line is disconnected and connected again..How soon you have notice the line is connecting and disconnecting? Now try increasing the idle-timeout from 600 secs (10 mins) to 20 mins (1200 sec).

So just post the "debug dialer" with "debug modem" to know the reason..

Bronze

Re: Dialup Keeps Disconnecting

Modem, chat and PPP debugs will give more clues as to why it keeps disconnecting.

Also see if removing keepalive command from dialer helps.

~Zulfi

Bronze

Re: Dialup Keeps Disconnecting

Note too that the debug you have is for the console port; with the debugs requested, you want to see TTY2 and serial 1 as the line and interface.

170
Views
0
Helpful
3
Replies