Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Differences between AUX ports?

Folks,

The following config *does* work on a 2500 and a 2600,

and does *not* work on a 1721 nor a 3640. Same config,

same cable, same modem, same user, same phone line....

Goal: Dial out using the AUX interface connected to a modem.

- The modem is physically a usr_courier, but the line:

modem autoconfigure type usr_courier

does not break a router that works and does not make

a router that does not work go.

- On the 2600, the interface is async65

- On the 3640, the interface is async129

- On the 1721, the interface is async5

What am I missing here? Ideas welcomed!

I was expecting the AUX port to behave the same way

on every router....

version 12.1

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname cisco

!

enable password 7 13061E010803

!

ip subnet-zero

no ip domain-lookup

!

interface Ethernet0

ip address 192.168.1.1 255.255.255.0

!

interface Async1

ip address negotiated

encapsulation ppp

dialer in-band

dialer idle-timeout 0

dialer string 448-4090

dialer-group 1

async mode dedicated

ppp authentication chap pap callin

ppp chap hostname xxxxx

ppp chap password yyyyy

ppp pap sent-username xxxxx password yyyyy

!

ip classless

ip route 0.0.0.0 0.0.0.0 Async1

!

dialer-list 1 protocol ip permit

!

line con 0

line aux 0

modem InOut

modem autoconfigure type usr_courier

no exec

transport input all

speed 38400

flowcontrol hardware

line vty 0 4

password 7 110A1016141D

login

!

end

cisco#sh deb

General OS:

Modem control/process activation debugging is on

Dial on demand:

Dial on demand events debugging is on

Dial on demand packets debugging is on

PPP:

PPP authentication debugging is on

PPP protocol negotiation debugging is on

PPP packet display debugging is on

Chat Scripts:

Chat scripts activity debugging is on

cisco#ping 1.2.3.4

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 1.2.3.4, timeout is 2 seconds:

00:09:11: As1 DDR: ip (s=192.168.1.1, d=1.2.3.4), 100 bytes, outgoing interesting (ip PERMIT)

00:09:11: As1 DDR: Dialing cause ip (s=192.168.1.1, d=1.2.3.4)

00:09:11: As1 DDR: Attempting to dial 448-4090

00:09:11: CHAT1: Attempting async line dialer script

00:09:11: CHAT1: no matching chat script found for 448-4090

00:09:11: CHAT1: Dialing using Modem script: d0efault-d0ials0cript & System script: none

00:09:11: CHAT1: process started

00:09:11: CHAT1: Asserting DTR

00:09:11: TTY1: Set DTR to 1

00:09:11: CHAT1: Chat script d0efault-d0ials0cript started

00:09:11: CHAT1: Sending string: ATZ

00:09:11: CHAT1: Expecting string: OK

00:09:12: CHAT1: Completed match for expect: OK.

00:09:12: CHAT1: Sending string: AT

00:09:12: CHAT1: Expecting string: OK

00:09:12: CHAT1: Completed match for expect: OK

00:09:12: CHAT1: Sending string: ATDT\T<448-4090>

00:09:12: CHAT1: Expecting string: CONNECT

00:09:13: As1 DDR: ip (s=192.168.1.1, d=1.2.3.4), 100 bytes, outgoing interesting (ip PERMIT).

00:09:15: As1 DDR: ip (s=192.168.1.1, d=1.2.3.4), 100 bytes, outgoing interesting (ip PERMIT).

00:09:17: As1 DDR: ip (s=192.168.1.1, d=1.2.3.4), 100 bytes, outgoing interesting (ip PERMIT).

00:09:19: As1 DDR: ip (s=192.168.1.1, d=1.2.3.4), 100 bytes, outgoing interesting (ip PERMIT).

Success rate is 0 percent (0/5)

cisco#

00:09:34: CHAT1: Completed match for expect: CONNECT

00:09:34: CHAT1: Chat script d0efault-d0ials0cript finished, status = Success

00:09:34: TTY1: destroy timer type 1

00:09:34: TTY1: destroy timer type 0

00:09:35: TTY1: DSR was dropped

00:09:35: tty1: Modem: READY->(unknown)

00:09:36: TTY1: dropping DTR, hanging up

00:09:36: TTY1: Set DTR to 0

00:09:36: As1 DDR: disconnecting call

00:09:36: TTY1: Async Int reset: Dropping DTR

00:09:36: TTY1: Set DTR to 0

00:09:36: tty1: Modem: HANGUP->(unknown)

00:09:36: As1 LCP: State is Closed

00:09:36: As1 DDR: cdp, 13 bytes, outgoing uninteresting (no list matched)

00:09:36: As1 DDR: sending broadcast to default destination -- failed, not connected

00:09:37: TTY1: cleanup pending. Delaying DTR

00:09:38: TTY1: cleanup pending. Delaying DTR

00:09:39: TTY1: cleanup pending. Delaying DTR

00:09:40: TTY1: cleanup pending. Delaying DTR

00:09:41: TTY1: destroy timer type 0

00:09:41: TTY1: destroy timer type 1

00:09:41: TTY1: destroy timer type 3

00:09:41: TTY1: destroy timer type 4

00:09:41: TTY1: destroy timer type 2

00:09:41: Async1: allowing modem_process to continue hangup

00:09:41: TTY1: restoring DTR

00:09:41: TTY1: Set DTR to 1

00:09:41: TTY1: autoconfigure probe started

00:09:51: As1 DDR: re-enable timeout

00:09:52: As1 DDR: cdp, 285 bytes, outgoing uninteresting (no list matched)

00:09:52: As1 DDR: sending broadcast to default destination -- failed, not connected

2 REPLIES
New Member

Re: Differences between AUX ports?

Hi,

Check this - was working fine on 3640, 2500, 1750 and 3800 series

line aux 0

no flush-at-activation

modem InOut

modem autoconfigure type 5600zdx - this is a custom modemcap entry for Multitech modem

no exec

transport preferred none

transport input all

transport output none

autoselect ppp

autohangup

speed 38400

flowcontrol hardware

HTH

Rgds

Giedrius #10257

New Member

Re: Differences between AUX ports?

Giedrius,

Thanks for your contribution.

I have tried several variations of this on a 1721, and got nowhere.

However, I found something interesting.

I tried to troubleshoot this issue on an old c3000 running the 2500 code (the nice part of doing this is that you can indeed rule out if the IOS is the problem or the hardware).

On the 3000, using the standard db25-RJ45 adapters, it does not work (exactly the same symptoms as the 1721). However, I used an RS232 signal breaker, and I found that by shorting the DCD (8) and DSR (6) pins on the router side, I got it to work.

Since there is no DCD signal in any RJ45 AUX port, I came to the unfortunate conclusion that some routers have the DCD and DSR signals internally shorted, and some other routers don't. Someone please prove me wrong?

Michel.

147
Views
0
Helpful
2
Replies
CreatePlease to create content