Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Digital modems and ISDN Pri

I am trying to configure integrated digital modem via ISDN-PRI link on a cisco 3660 router. Following is the basic configuration;

( using NM-30DM and NM-1CE1B modules);

hostname Router

!

!

modem country mica united-kingdom

ip subnet-zero

!

isdn switch-type primary-net5

modemcap entry mica

!

controller E1 4/0

pri-group timeslots 1-31

!

!

interface Loopback0

ip address 172.30.1.1 255.255.255.0

!

!

interface Serial4/0:15

ip unnumbered Loopback0

encapsulation ppp

isdn switch-type primary-qsig

isdn incoming-voice modem

isdn T310 40000

isdn negotiate-bchan

isdn bchan-number-order ascending

!

interface Group-Async1

ip unnumbered Loopback0

encapsulation ppp

dialer in-band

dialer pool-member 2

async mode dedicated

no peer default ip address

ppp authentication chap

group-range 161 190

!

line con 0

line 161 190

modem InOut

modem autoconfigure type mica

transport input all

line aux 0

line vty 0 4

login

!

ISDN seems to be OK as per the following 'sh isdn status';

Router#sh isdn status

Global ISDN Switchtype = primary-net5

ISDN Serial4/0:15 interface

dsl 0, interface ISDN Switchtype = primary-qsig

**** Slave side configuration ****

Layer 1 Status:

ACTIVE

Layer 2 Status:

TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED

Layer 3 Status:

0 Active Layer 3 Call(s)

Active dsl 0 CCBs = 0

The Free Channel Mask: 0x7FFF7FFF

Number of L2 Discards = 0, L2 Session ID = 1

Total Allocated ISDN CCBs = 0

But, when I try to make a dial using internal digital modems, I get the following error message;

01:39:26: ISDN Serial4/0:15: isdn_is_bchannel_available: No Free B-channels

I try to change the b-channel selection order ( ascending /descending) and other parameters, but still no improvement.

What could be the possible reasion ?

1 REPLY
Silver

Re: Digital modems and ISDN Pri

I beleive that on interface Serial4/0:15 you are missing dialer-pool 2 statement , this maps the physiacl int to the virtual interface

80
Views
0
Helpful
1
Replies
CreatePlease login to create content