Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Disabling CEF on Sup2/PFC2/MSFC2

Hi all,

Is anybody had experience with the above? Is anybody tried to disable CEF switching with Sup2/PFC/MSFC2 running Native IOS?

http://www.cisco.com/univercd/cc/td/doc/product/lan/cat6000/sft_6_1/configgd/cef.pdf

Above URL says, CEF cant be disabled (I think above document is focused on HYBRID OS).....But I am sure I saw the command in switch CLI running native IOS...Not sure what happens if I disable. We are facing a big trouble currently in network and we believe CEF is culprit and wanted to disable and see.

I appreciate if somebody can give the practical data.

TIA.

Subba Rao.S

3 REPLIES
New Member

Re: Disabling CEF on Sup2/PFC2/MSFC2

The default switching mechanimsm on a SUP2/MSFC2 is CEF and it cannot be disabled in either hybrid or native. You can only disable it on a sup1 which has default switching of MLS

New Member

Re: Disabling CEF on Sup2/PFC2/MSFC2

Hi. Your Documentation is true. There is no way to switch CEF on 6500 SE2/PFC2/MSFC2 off. The CEF is the forwarding central main function trough the box and in this case in hardware “burned” (on the PFC2 Card). If your using (native) IOS or CAT-OS with IOS only on the MSFC2 give the same result. The CEF forwarding replace the classic MLS existing in SE1-1A/PFC(1)/MSFC or at Catalyst 5000 before.

For basic troubleshooting use the following:

-show adjacent detail -> you find all next hope ip and mac address

-show ip cef -> show the CEF FIB forwarding base from the routing table

General remark: The HSRP Group numbers for ALL VLAN are limited to 16!

Andy

New Member

Re: Disabling CEF on Sup2/PFC2/MSFC2

Hi,

Thank you very much for all your suggestions. Currently we were facing a serious trouble in our netwrok with CEF in conjunction with load balancing (Default Universal per destination based).

I try to tell you my problem in brief. We have a medium sized campus network with three building blocks conencted in partial mesh fasion. All sites are connected with Dual 1 Giga MAN Links to the central site. We are using EIGRP in the core which derives 4 equal cost paths to every destination network. Initially load balancing was working fine based source+destination hash basis with CEF Switching.

Recently, on weekend we rebooted distribution switches in one of the building blocks for maintainance reason. Same day we confirmed that routing tables are OK as previous. only the change is sequence of nexhops in routing tables (Logically this should not be a problem)

Suprisingly, the next day customer network is partially down. Partially means from the client VLAN few of the PCs are unable to reach few of the servers at central site. Same thing is true with the other building blocks also. We have no answer to give to customer on this phenomina, we tried to do some needful stuff but we have no time to take even proper log of all switches.

First work around is we cleared CEF inconsistance and the cleared adjacency tables, then after few of the non-working PCs are started reaching server farm but few of working ones went down. We verified CEF tables and Adjacency in detal by comparing with arp tables,,,,everything is perfect.

Finally we stopped thinking logically and rebooted all the switches which solved all our problems. Now netwok is up, not sure how long it is going to be so.

I already opened few cases with TAC, they are doing their best but they too unable identify the concrete reason, more over we donot have complete log of all switches.

I knew it is rare phenomina and never expected with Cat6K.

Now customer asked us to disable CEF and see. I am sure I saw the command "no ip cef" but never used.

I appreciate any comments on above.

Thank you very much.

115
Views
0
Helpful
3
Replies
CreatePlease to create content