Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Disconnecting VLANs

Hello, I'm having a bit of a problem setting up a pair of VLANs on my existing network. I've only got one fastethernet interface going to my network. I need to keep the two VLANs apart. So here's my problem: when I try to configure the router (1721) for VLAN 2, I have no problem. But the moment I try to configure the subinterface for the original VLAN, everything stops working! Any help would be wonderful. Here's my current config:

Using 1138 out of 29688 bytes

!

version 12.3

service config

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname FV

!

boot-start-marker

boot-end-marker

!

enable secret xxxx

enable password xxxx

!

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

no aaa new-model

ip subnet-zero

ip cef

!

!

!

ip dhcp pool DHCPPool1

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

dns-server 192.168.254.100

!

no ftp-server write-enable

!

!

!

!

interface FastEthernet0

ip address 192.168.254.17 255.255.255.0

speed auto

no cdp enable

!

interface FastEthernet0.1

no cdp enable

!

interface FastEthernet0.2

encapsulation dot1Q 2

ip address 192.168.1.1 255.255.255.0

ip access-group 101 out

!

interface Serial0

ip address 10.254.0.2 255.255.255.252

no fair-queue

service-module t1 remote-alarm-enable

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.254.0.1 permanent

no ip http server

!

snmp-server community xxxx

snmp-server enable traps tty

!

line con 0

exec-timeout 0 0

line aux 0

line vty 0 4

password xxxx

login

!

!

end

----------

And what I've been trying to make subinterface 0.1 look like is this:

interface FastEthernet0.1

encapsulation dot1q 1 native

ip address 192.168.254.17 255.255.255.0

ip access-group 100 out

--------

Then I'd add access-lists to keep the two VLANs from speaking to each other and hopefully VLAN 2 would be able to use the same DNS server.

Anyway, any and ALL help would be greatly appreciated!

  • Other Network Infrastructure Subjects
6 REPLIES
Hall of Fame Super Silver

Re: Disconnecting VLANs

Jackson

I believe the first thing is to determine if the version of IOS that you are running supports VLAN subinterfaces. Can you post the output of show version that shows the complete file name for the IOS that you are running (this will give both the version and the feature set).

HTH

Rick

New Member

Re: Disconnecting VLANs

Ah, that would be a good idea! Here's the output of show version:

Cisco Internetwork Operating System Software

IOS (tm) C1700 Software (C1700-IPBASE-M), Version 12.3(6c), RELEASE SOFTWARE (f)

Copyright (c) 1986-2004 by cisco Systems, Inc.

Compiled Tue 20-Jul-04 07:00 by kellythw

Image text-base: 0x80008120, data-base: 0x80C74650

ROM: System Bootstrap, Version 12.2(7r)XM2, RELEASE SOFTWARE (fc1)

FV uptime is 1 hour, 7 minutes

System returned to ROM by reload

System image file is "flash:c1700-ipbase-mz.123-6c.bin"

cisco 1721 (MPC860P) processor (revision 0x400) with 55642K/9894K bytes of memo.

Processor board ID FOC09084LE0 (2748776065), with hardware revision 0000

MPC860P processor: part number 5, mask 2

Bridging software.

X.25 software, Version 3.0.0.

1 FastEthernet/IEEE 802.3 interface(s)

1 Serial network interface(s)

WIC T1-DSU

32K bytes of non-volatile configuration memory.

32768K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

Re: Disconnecting VLANs

Hi

As per u r output from show version u r having a IPBASE image u need to have IP PLUS image.

Hope this helps

Mahmood

New Member

Re: Disconnecting VLANs

Okay, so you're saying that the IPBASE image doesn't support subinterfaces, but that if I were to upgrade it to the IPPLUS image that it would? Do you know if the 1721 is capable of running IP PLUS?

Hall of Fame Super Silver

Re: Disconnecting VLANs

The 1721 is certainly capable of running IPPLUS feature set.

HTH

Rick

New Member

Re: Disconnecting VLANs

Now to figure out how to get that image. I'm an IT contractor for this company, so finding any sort of credentials for downloading should be challenging at best. Thanks!

122
Views
12
Helpful
6
Replies
This widget could not be displayed.