Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Domain suffix problem with DHCP

I have problem with getting a "domain suffix" to a XP

clint using DHCP (Win2K)

When we connect the client direct to the LAN, there is no problem getting the right TCP/IP configuration.

But when we use AS5200 and dialing the network via modem, we get every configuration (IP,Wins,DNS) except the Domain suffix.

We have tried with ip domain-name and no result.

Could please some one help me with this ?

Configuations on the AS5200 as follow.

version 12.0

no service pad

service timestamps debug datetime msec localtime

service timestamps log datetime

service password-encryption

!

hostname as5200

!

logging buffered 1000000 debugging

aaa new-model

aaa authentication login default tacacs+ local

aaa authentication login dialout tacacs+ local

aaa authentication enable default tacacs+ enable

aaa authentication ppp default tacacs+

aaa authentication ppp dialout tacacs+

aaa authorization exec default tacacs+

aaa accounting exec default start-stop tacacs+

aaa accounting commands 15 default start-stop tacacs+

aaa accounting network default start-stop tacacs+

aaa accounting connection default start-stop tacacs+

aaa accounting system default start-stop tacacs+

enable secret 5 XXXXXXXXXXXXXXXXXXXXXXXXXXXX

!

username XXXXX password 7 XXXXXXXXXXXXXXXX

ip subnet-zero

no ip domain-lookup

ip address-pool dhcp-proxy-client

ip dhcp-server XXX.XXX.XXX.XXX

async-bootp nbns-server XXX.XXX.XXX.XXX

async-bootp dns-server XXX.XXX.XXX.XXX

isdn switch-type primary-net5

clock timezone MET 1

clock summer-time MET recurring last Sun Mar 2:00 last Sun Oct 3:00

!

!

controller E1 0

framing NO-CRC4

clock source line primary

pri-group timeslots 1-31

!

controller E1 1

shutdown

clock source line secondary

!

buffers small permanent 75

buffers middle permanent 50

buffers big permanent 100

buffers Serial0:0 permanent 25

!

interface Ethernet0

ip address XXX.XXX.XXX.XXX 255.255.255.0

no ip directed-broadcast

no ip route-cache

no ip mroute-cache

!

interface Serial0

no ip address

no ip directed-broadcast

no ip route-cache

no ip mroute-cache

shutdown

!

interface Serial1

no ip address

no ip directed-broadcast

no ip route-cache

no ip mroute-cache

shutdown

!

interface Serial0:15

ip address XXX.XXX.XXX.XXX 255.255.255.0

ip access-group 101 in

no ip directed-broadcast

encapsulation ppp

no ip route-cache

dialer idle-timeout 300

(Excluded the dialer map)

dialer-group 1

isdn switch-type primary-net5

isdn incoming-voice modem

no peer default ip address

no fair-queue

no cdp enable

ppp authentication chap pap

ppp multilink

!

interface Group-Async1

ip unnumbered Ethernet0

no ip directed-broadcast

encapsulation ppp

no ip route-cache

no ip mroute-cache

async default routing

async dynamic address

async mode interactive

peer default ip address dhcp

no cdp enable

ppp authentication ms-chap chap pap

group-range 1 36

!

interface Dialer0

no ip address

no ip directed-broadcast

no ip route-cache

no ip mroute-cache

dialer-group 1

no cdp enable

!

interface Dialer1

no ip address

no ip directed-broadcast

no ip route-cache

no ip mroute-cache

!

router ospf 1

summary-address XXX.XXX.XXX.XXX 255.255.255.0

redistribute static subnets

network 0.0.0.0 255.255.255.255 area 0

!

ip classless

(Excluded ip route command)

!

(Excluded access-lists)

tacacs-server host XXX.XXX.XXX.XXX

tacacs-server timeout 30

tacacs-server key XXXXXXXXXXX

snmp-server community public RO

snmp-server community works RW

!

line con 0

transport input none

line 1 36

session-timeout 15

no exec

autoselect ppp

refuse-message ^CCC[!NMM!] Inga modem lediga^C

modem InOut

modem autoconfigure discovery

rotary 1

transport input all

line aux 0

line vty 0 4

password XXXXXXXXXXXXXXXX

history size 25

!

ntp clock-period XXXXXXXXX

ntp server XXXXXXXXXXXXX

end

  • Other Network Infrastructure Subjects
1 REPLY
VIP Purple

Re: Domain suffix problem with DHCP

Hello,

the config looks ok, my guess is this is more an issue with the XP clients. I did a search in the MS Knowledge Base and came up with these two issues, not sure if this applies to you:

http://support.microsoft.com/default.aspx?scid=kb;en-us;317288&Product=winxp

http://support.microsoft.com/default.aspx?scid=kb;en-us;299062&Product=winxp

Regards,

Georg

247
Views
0
Helpful
1
Replies
This widget could not be displayed.