Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Dot1q between two routers connected via 2950

Hi,

I have two 7200's connected to a 2950 (FE 22 + FE 24 - Both configured as trunks).

On the 7200's, I have the following:

7200-A

!

interface FastEthernet0/0.23

encapsulation dot1Q 23

ip address 192.168.1.1 255.255.255.252

no snmp trap link-status

!

7200-B

!

interface FastEthernet0/0.23

encapsulation dot1Q 23

ip address 192.168.1.2 255.255.255.252

no snmp trap link-status

!

2950:

!

interface FastEthernet0/22

switchport mode trunk

no ip address

duplex full

speed 100

!

interface FastEthernet0/24

switchport mode trunk

no ip address

duplex full

speed 100

!

But I cannot ping between the two routers?

9 REPLIES

Re: Dot1q between two routers connected via 2950

Hi Friend,

Can you cofirm if you have vlan 23 in your vlan database.

Can you check with "sh vlan" if vlan 23 is not present please create in going to vlan database mode.

Regards,

Ankur

Purple

Re: Dot1q between two routers connected via 2950

Hi,

Can you enter in 'switchport trunk encapsulation dot1q' under both interfaces Fa0/22 and Fa0/24 on your switch ? I'm pretty sure the 2950 defaults to ISL encapsulation on trunks.

Hope that helps - pls rate the post if it does.

Paresh

Re: Dot1q between two routers connected via 2950

Hi Paresh,

2950 only supports dot1q so I do not think this command will even work with 2950.

Regards,

Ankur

Purple

Re: Dot1q between two routers connected via 2950

Thanks Ankur,

I was confusing it with the 2900XL switches :-(

Paresh

Silver

Re: Dot1q between two routers connected via 2950

What are you trying to accomplish?

You don't need to configure a trunk on the router unless you want to route VLANs on the 2950 switch i.e.""router-on-a-stick" concept.

You can make both ports on the 2950 access ports by configuring the following:

int Fa0/22 , Fa0/24

switchport

switchport mode access

switchport access vlan 23

duplex full

speed 100

This makes both ports member of VLAN 23. You can now ping router 7200-B from 7200-A and vice versa.

HTH

Leon

* Please rate useful posts

Silver

Re: Dot1q between two routers connected via 2950

You can chech the status of the trunk with the following commands:

* show trunks

* show interface Fa0/22 switchport

* show interface Fa0/24 trunk

This should give you an impression what is allowed on the trunk and if VLAN 23 traverses the trunk.

Leon

New Member

Re: Dot1q between two routers connected via 2950

7200-A has dot1q ints for servers connected to the 2950 (Access Ports)....these are all currently successfully trunked down FE24

I want to connect 7200-B to 7200-A, and have dot1q Ints on both routers(As /30's) that can communicate (They will be used on 7200-B as Internet gateways for VRF's (With IP Nat enabled)....I was hoping that by having 7200-B connected to 2950 FE22, and configuring that port as a trunk also, that the dot1q ints on both routers could talk.

vlan 23 does exist on 2950, and is being trunked on both FE 22 + FE 24

I dont have any spare FE ports on 7200-A, hence the reason for me connecting 7200-B to the 2950.

Re: Dot1q between two routers connected via 2950

Hi Friend,

Can you check the arp entries in your router. I mean from router A can you check "sh ip arp for router B lan interface ip address.

Is it possible to paste the complete sh run from both the routers, looks like something fishy happening.

Ankur

New Member

Re: Dot1q between two routers connected via 2950

Howdy-

Try setting your native vlan to 23 on each of the interfaces on the 2950.

Traffic in the native VLAN is untagged and the default native VLAN is 1.

324
Views
0
Helpful
9
Replies