Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

dot1Q encap Between Cisco Router & HP Switch, and Voice/Data VLAN VoIP

Our issue is a bit complicated. We are implementing a ShoreTel VoIP phone system which supports VLAN tagging to separate Voice and Data traffic. At this location, we have a Cisco Router (currently obtaining model #) which is connected through a newly configured dot1Q trunk to an HP Switch (currently obtaining model # also). Below you will find configs for both devices (scrubbed for sensitive info).

In order to achieve Voice/Data separation, 2 DHCP scopes have been defined. By using DHCP option 156 and configuring this option on both scopes, the IP phones initially boot into the native (untagged for HP) VLAN and obtain a configuration as well as this option. This option specifies tagging 'on' and a VLAN to tag Voice traffic for. After resetting, the port is now tagged for the new VLAN and the second switchport in back of the phone is assigned untagged for the native VLAN. What I have here **SHOULD** work, but the only address phones ever get is native VLAN. This is driving me insane. Can someone please review my configs to ensure I'm not making a simple mistake? Also any suggestions would help..I'll rate posts.

Cisco Config

********************

!

version 12.4

!

no aaa new-model

ip cef

!

interface FastEthernet0/0

no ip address

ip nbar protocol-discovery

ip flow ingress

ip flow egress

duplex auto

speed auto

!

interface FastEthernet0/0.1

encapsulation dot1Q 1 native

ip address **.**.216.1 255.255.255.0

!

interface FastEthernet0/0.307

encapsulation dot1Q 307

ip address **.**.20.225 255.255.255.224

ip helper-address **.**.216.254

!

router eigrp 102

network **.**.20.224 0.0.0.31

network **.**.216.1 0.0.0.0

network **.**.96.82 0.0.0.0

no auto-summary

!

router eigrp 1

network **.**.16.8 0.0.0.3

network **.**.216.0 0.0.0.255

no auto-summary

!

HP CONFIG

********************

; J4813A Configuration Editor; Created on release #F.05.60

cdp run

no web-management

no telnet-server

interface 23

no lacp

exit

trunk 23 Trk1 Trunk

ip default-gateway **.**.216.1

vlan 1

name "Data VLAN"

untagged 1-22,24-Trk1

ip address **.**.216.6 255.255.255.0

exit

vlan 307

name "Voice"

ip address **.**.20.227 255.255.255.224

tagged 1-22,24-Trk1

exit

ip ssh

no aaa port-access authenticator active

spanning-tree Trk1 priority 4

1 REPLY

Re: dot1Q encap Between Cisco Router & HP Switch, and Voice/Data

Your config looks fairly OK. Have you read the following: http://www.bts1981.com/net.req.htm#dhcp

Otherwise, you sould debug the dhcp negotiation process to see where this goes wrong.

regards,

Leo

1613
Views
0
Helpful
1
Replies