Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

DOT1Q VLAN

I cant get dot1q vlans to work, when i use ISL it works perfect. What is wrong in my config ?

Router:

interface FastEthernet0/1

no ip address

speed 100

full-duplex

!

interface FastEthernet0/1.1

ip address 172.30.1.254 255.255.255.252

encapsulation dot1q 1 native

Switch:

interface FastEthernet0/1

duplex full

speed 100

switchport mode trunk

switchport trunk encapsulation dot1q

interface VLAN1

ip address 172.30.1.253 255.255.255.252

no ip directed-broadcast

no ip route-cache

VTP info:

VTP Version : 2

Configuration Revision : 3

Maximum VLANs supported locally : 254

Number of existing VLANs : 2

VTP Operating Mode : Server

VTP Domain Name : test

VTP Pruning Mode : Enabled

VTP V2 Mode : Enabled

VTP Traps Generation : Disabled

I cant access the switch from the router, but if i switch to ISL encapsulation it works, can somebody please give me a hint ?

Regards

Hakan

2 REPLIES
New Member

Re: DOT1Q VLAN

You can try this:

interface FastEthernet0/1

ip address 172.30.1.254 255.255.255.252

speed 100

full-duplex

!

interface FastEthernet0/1.1

I have meet this problem a month ago.I find cisco give two solutions: in the main interface config the ip address or like you configure the vlan native. I have a 7206, the IOS don't support the encapsulate dot1q 1 native, I configure the ip address in the main interface,it works well.But I don't know why you configuration can't work.

New Member

Re: DOT1Q VLAN

This worked in my practice rack with the switch configured for 2 vlans. However, I had to change it to ISL efore it started working, then when I changed it to 1Q, it continued to work. Go figure.

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.2

encapsulation dot1Q 2

ip address 192.168.12.1 255.255.255.0

no ip redirects

!

interface FastEthernet0/0.3

encapsulation dot1Q 3

ip address 192.168.13.1 255.255.255.0

no ip redirects

!

572
Views
0
Helpful
2
Replies
CreatePlease to create content