Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

ds1-ds2 running hsrp)

Hi

ps examine the design in the attachment;sw1 connected to sw2 via stack &sw1 connected to ds1 also sw2 connected to ds2.(ds1-ds2 running hsrp).this a good physical link or what?what is ur suggestion?this will work proprly?

10xs

9 REPLIES
Blue

Re: ds1-ds2 running hsrp)

yes, this design will work.

you can also use the HSRP to perform load balancing between the MSFCs/routers by alternating HSRP priorities of VLANs.

also, be sure to verify your SpanningTree config; rootBridge; BPDU guard/filter; rootGuard, etc...

see this link for more HSRP info:

http://www.cisco.com/en/US/products/hw/switches/ps646/products_configuration_guide_chapter09186a00801cdf27.html

see this link for more STP info:

http://www.cisco.com/en/US/tech/tk389/tk621/tsd_technology_support_protocol_home.html

New Member

Re: ds1-ds2 running hsrp)

Hi

Simple config(by alternating HSRP priorities of VLANs)please!

10xs

Re: ds1-ds2 running hsrp)

ds1

interface Ethernet0

ip address 171.16.6.5 255.255.255.0

standby 1 preempt

standby 1 ip 171.16.6.100

standby 1 track Serial0

standby 2 preempt

standby 2 ip 171.16.6.200

standby 2 track interface

standby 2 priority 95

ds2

Current configuration:

interface Ethernet0

ip address 171.16.6.6 255.255.255.0

standby 1 preempt

standby 1 ip 171.16.6.100

standby 1 track Serial0

standby 1 priority 95

standby 2 preempt

standby 2 ip 171.16.6.200

standby 2 track interface

you can configure like this

regards

Devang

Re: ds1-ds2 running hsrp)

here you can have any interface tracking which you would like to track... as i tracking serial 0 on above configuration... you can use as per your requirement...

regards

Devang

Blue

Re: ds1-ds2 running hsrp)

router1:

interface VLAN 10

standby 10 ip 10.10.1.1

standby 10 priority 105

standby 10 preempt

interface VLAN 15

standby 20 ip 10.15.1.1

standby 20 priority 110

standby 20 preempt

switch2:

interface VLAN 10

standby 10 ip 10.10.1.1

standby 10 priority 110

standby 10 preempt

interface VLAN 15

standby 20 ip 10.15.1.1

standby 20 priority 105

standby 20 preempt

this very basic hsrp config will provide the following:

switch1:

* provides primary routing for VLAN 15

* provides backup routing for VLAN 10

switch2:

* provides primary routing for VLAN 10

* provides backup routing for VLAN 15

you should also look into HSRP Tracking to track specific interfaces for up/down so HSRP can adjust accordingly. (document link previously provided)

i also like to set priorities on all hsrp groups above the default 100. (kind of a failsafe incase someone else adds an hsrp config to a specific group without setting a priority; keeps the new hsrp addition from becoming active accidentally)

i also like to keep hsrp priorities 5 points apart. so if you use Tracking (recommended) the hsrp priorities will not become the same as they would if they were 10 points apart. (tracking by default lowers the tracked interface HSRP priority by 10 when tracking discovers a down interface)

any further input from others on hsrp best practices is welcome.

New Member

Re: ds1-ds2 running hsrp)

Hi gpulos!

10xs for ur reply.great explanation!

New Member

Re: ds1-ds2 running hsrp)

Hi gpulos !

if i use ur config.what about the route bridge primary.and route bridge secondary on the 2 distribuation .i have 50 vlans.

Simple config ps!look i know the command:

spaning tree vlan x primary(ds1)

spaning tree vlan x secondary(ds2)

10xs

Blue

Re: ds1-ds2 running hsrp)

can you supply the configuration(s) of the switches?

not fully clear of your query. are you asking about spanningTree config and how to setup rootBridge and backup rootBridge properly?

Re: ds1-ds2 running hsrp)

yes it will work properly and you can also use the different HSRP standby group configuration in order to acive the optimum utilisation of you resources...

or you can say the loadbalancing with HSRP...

regards

Devang

140
Views
13
Helpful
9
Replies
CreatePlease login to create content