Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Dual Static route to the same destination but different hop

hi,

I would like to verify whether can i do this:

Router B: 49.11.50.251

Router C: 49.11.50.252

Host D: 10.1.5.5

At Router A, i configure the 2 static route to the same destination but throwing to the different hop, will it confuse the router? do i need to add a different AD?:

ip route 10.1.5.5 255.255.255.255 49.11.50.251

ip route 10.1.5.5 255.255.255.255 49.11.50.252

Reason why i do this is to access to Host D, i throw the route to Router B, in case Router B is dead, router A know how to throw the route to Router C. I can use HSRP on the purpose because HSRP is already use between this two router to track the serial link.

Any advice is greatly appreciated!!!

2 REPLIES

Re: Dual Static route to the same destination but different hop

If you add both the routes, without specifying an AD, both the routes would appear in the routing table. And depending on what type of switching (fast switching/process switching), the router will load balance the packets going out of A. If fast switching is enabled, it will per destination load balancing. while, it will do per packet LB, for fast switching disabled

Since you are using two static routes, as a failover meachanism, you can set the second route pointing to C, with a higher AD. Set the AD to 2. So your routes would look like,

ip route 10.1.5.5 255.255.255.255 49.11.50.251

ip route 10.1.5.5 255.255.255.255 49.11.50.252 2

The second route will kick in, only if the next-hop for the first route is inaccesible.

New Member

Re: Dual Static route to the same destination but different hop

Your best option would be to setup HSRP is possible. That way you have a Hot Swap IP address on both routers so you have a single address to point to no matter which is active. As follows:

ROUTER A

interface FastEthernet5/1/0

ip address 10.x.x.200 255.255.255.0

no ip redirects

ip nat inside

no ip route-cache distributed

full-duplex

ipx network x encapsulation SAP

standby priority 101 preempt

standby ip 10.x.x.1

ROUTER B

interface FastEthernet5/1/0

ip address 10.x.x.201 255.255.255.0

no ip redirects

full-duplex

ipx network x encapsulation SAP

standby ip 10.x.x.1

standby priority 100 preempt

283
Views
5
Helpful
2
Replies
CreatePlease login to create content