Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Duplex settings

On every Cisco course they told me to configure the duplex-settings on a switchport from the standard auto to a fixed half or full setting.

I experienced this always as good practice, because i had several cases where this "fixing" solved big throughput problems. Until today.

Today I had complaints of two users. The NIC's (Intel Pro100 S) in their WinNT-stations are configured to fixed 100Mbit and fixed full duplex. The switch(C3548-XL) has its ports configured fixed in 100/full. When I checked the switch, I saw the input/output error-counters go up on these two ports.

When I altered the duplex-setting from fixed to auto, the problem stopped. However, when I did a show interface, I saw that the negotiatian resulted in a full duplex setting! So, I changed it back to fixed full duplex and the problem was there again. Back to auto it was solved again.

Does anyone have a good explanation of this duplex-setting behavior? I noticed that problems with auto-duplex do more often happen with some branches of NIC's then with others. Is there a "preferrable" branch of NIC's when you use Cisco-switches?

2 REPLIES
New Member

Re: Duplex settings

This seems to be a bug in Intel NIC. There is a similar kind of bug in Intel NIC for Laptop PCMCIA. You can also check in Intel website or via e-mail.

Purple

Re: Duplex settings

You would think after all these years these manufacurers could make something that could consistently use the auto setting without a problem .

314
Views
0
Helpful
2
Replies