Cisco Support Community
Community Member

Dynamic DNS

Can we configure a DDNS client in a Cisco 827-4V (12.2(15) IOS).

The idea is to have an account in i.e. and by doing this getting the updated public IP address of the router.

VIP Purple

Re: Dynamic DNS


I don't think there is a restriction on the type of client that uses DDNS, so the 827-4V should work without a problem. I have heard that certain types of Linksys Wireless routers (WRT54G routers) are rejected by SPs unless a patch is installed, since these routers flood the provider network with unwanted traffic.



Community Member

Re: Dynamic DNS


But do you know how to configure the cisco?

VIP Purple

Re: Dynamic DNS

Hello Luis,

the most important thing is that you configure the command:

ip address negotiated

on your ATM or Dialer interface, this way your 827-4V gets a dynamic IP address from the provider. Here is a sample config for PPPoE and NAT:


protocol pppoe


!--- Internal Ethernet network.


interface Ethernet0

ip address

ip nat inside

!--- DSL interface.


interface ATM0

no ip address

no atm ilmi-keepalive


dsl operating-mode auto

hold-queue 224 in

!--- All defaults.

!--- PPPoE runs on top of AAL5SNAP, but the

!--- encap aal5snap command is not used.


interface ATM0.1 point-to-point

pvc 1/1

pppoe-client dial-pool-number 1

!--- pvc 1/1 is an example value that must be changed

!--- to match the value used by the ISP.


!--- The PPPoE client code ties into a dialer interface upon

!--- which a virtual-access interface is cloned.


interface Dialer1

ip address negotiated

ip mtu 1492

!--- Ethernet MTU is 1500 by default -- 1492 + PPPoE headers = 1500

ip nat outside

encapsulation ppp

dialer pool 1

!--- Ties to ATM interface.

ppp authentication chap callin

ppp chap hostname

ppp chap password


!--- Note: The ISP will instruct you regarding the

!--- type of authentication to use.

!--- To change from PPP CHAP to PPP PAP, replace

!--- ppp authentication chap callin

!--- ppp chap hostname

!--- ppp chap password

!--- with ppp authentication pap callin

!--- ppp pap sent-username password

!--- For NAT, overload on the Dialer1 interface

!--- and add a default route out since dialer IP address can change.

ip nat inside source list 1 interface Dialer1 overload

ip classless

ip route dialer1

no ip http server


access-list 1 permit

!--- For NAT.

For a listing of DDNS providers, check this link (scroll down to the bottom):



CreatePlease to create content