Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

Dynamic Routing Fails on Async

I've been trying connecting two routers via AUX ports as described in the document http://www.cisco.com/warp/public/793/access_dial/auxback.html. Connection is OK but dynamic routing protocols don't work. I tried EIGRP and RIP. With EIGRP I see that no neighborhood. What may be the problem?

Configurations:

router1:

--------------

interface Async4

ip address 10.1.2.1 255.255.255.252

no ip mroute-cache

encapsulation ppp

no ip route-cache

async dynamic routing

async mode dedicated

router eigrp 1

network 10.0.0.0

------------------------------------------------

router2:

---------

interface Async9

ip address 10.1.2.2 255.255.255.252

encapsulation ppp

async dynamic routing

async mode dedicated

router eigrp 1

network 10.0.0.0

6 REPLIES

Re: Dynamic Routing Fails on Async

Can you ping from one router to other through the async interface ?

Cisco Employee

Re: Dynamic Routing Fails on Async

First, Try to configure "async default routing" instead of "async dynamic routing". Since you have tried many routing protocols, here is the working config using OSPF,

http://www.cisco.com/warp/public/793/access_dial/multilink_2serial_async.html

Just to add, if yo can't ping once the connection is made, we need to troubleshoot that first.

If you can ping, then we need see "show ip eigrp interface" and verify that the async interface is included for eigrp or not..(it should based on ip address)

After that need to debug for "debug ip eigrp" to see the eigrp related activities.

Re: Dynamic Routing Fails on Async

Yes, I changed the "async dynamic routing" line with "async default routing" and it worked. I read command reference docs on these commands but I couldn't see a difference, what's the point here?

Thanks to everyone involved.

Bronze

Re: Dynamic Routing Fails on Async

This info might help:

[async dynamic routing]

A remote user who establishes a PPP or SLIP connection to this

asynchronous interface can enable routing by using the /routing

switch or the ppp/routing command. However, if you want to establish

routing by default on connections to an asynchronous interface,

use the async default routing command when you configure the interface.

You can compare this with the "async dynamic address" command under

the async interface configuration wherein the dialing side defines

the ip address that it will use, instead of the router assigning the

ip address.

Re: Dynamic Routing Fails on Async

Thanks a lot.

Re: Dynamic Routing Fails on Async

Yes, I can.

230
Views
0
Helpful
6
Replies
CreatePlease to create content