Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

EBGP & null interface:

Hi,

Per se If I've 20.1.192.0/18 network behind the backbone and want to advertise the same over my BGP.

Why do I need static routing at my end as

ip route 20.1.192.0 255.255.192.0 null 0

to see the subnet 20.1.192.0/18 at my neighbor's router.

Thanks

my-ASBR#

!

router bgp 200

network 20.1.192.0 mask 255.255.192.0

neighbor 202.54.66.194 remote-as 100

!

!

ip route 20.1.192.0 mask 255.255.192.0 null 0

!

neighbor-AS#

!

router bgp 100

network 202.54.66.0

neighbor 202.54.66.193 remote-as 200

!

3 REPLIES
New Member

Re: EBGP & null interface:

Hi,

The network command controls what are originated by your router.

Its not like when your running OSPF on an interface, and try run BGP on a specific interface. The network command will only work if the network you are trying to advertise is known to the router, whether connected, static or learned dynamically.

This also a way to advertise many small subnets as bigger subnet.

New Member

Re: EBGP & null interface:

Even though you have the network defined under BGP, BGP will not advertise a network unless the network exists in it's routing table. Hence the static route. This is to prevent black holes. That function can be disabled by putting the "no sync" command under BGP.

New Member

Re: EBGP & null interface:

BGP will not advertise any network unless there is an exact match in the routing table learn either via an IGP or by configuring static route as you did in your case. To verify it you can do the show command " show ip bgp neighbor < ip address > advertised-routes" and that will tell you the networks your router my-ASBR advertising. Hope this helps.

94
Views
0
Helpful
3
Replies
CreatePlease login to create content