Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

%EC-5-CANNOT_BUNDLE2: - Etherchannel wierdness or BUG???

Hi,

Has anyone come across such a problem where:

- after a power outage to a building, the port channel between the distribution switch and the edge switch unbundles.

- note, that the configuration on both ends of the uplink are identical as far as:

o Speed, duplex,

o Spanning tree port cost, priority, portfast

o jabber frames

o trunked vlans, native vlan & trunk mode as shown below:

Distribution Switch & Edge Switch

-------------------

interface Port-channel8

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-499,600-799

switchport mode trunk

interface GigabitEthernet1/0/17

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-499,600-799

switchport mode trunk

channel-group 8 mode on

spanning-tree portfast disable

However, after a power outage, in some cases we find that the ether-channel unbundles, with the following syslog message:

Aug 31 12:02:54 clay-28-402-rk1-fes1 33332: Aug 31 12:02:52: %EC-5-CANNOT_BUNDLE2: Gi2/0/24 is not compatible with Gi1/0/24 and will be suspended (trunk mode of Gi2/0/24 is dynamic, Gi1/0/24 is trunk) (clay-28-402-rk1-fes1-2)

...when the configs haven't been changed at all.

After changing cables, etc, the only thing that brings things back to normal is a power cycle of the distribution and edge switches.

Seem to think that it is a bug with ether-channels with this version of IOS:

c3750-ipbasek9-mz.122-25.SEB2

thanks,

Sheldon

3 REPLIES
Purple

Re: %EC-5-CANNOT_BUNDLE2: - Etherchannel wierdness or BUG???

We saw this on a different piece of equipment this morning , fix was to pull the port channel config and then reinstall it , so I would consider it a bug .

New Member

Re: %EC-5-CANNOT_BUNDLE2: - Etherchannel wierdness or BUG???

I'm glad, that at least someone else has experienced the same issue with this version of IOS!

Cisco Employee

%EC-5-CANNOT_BUNDLE2: - Etherchannel wierdness or BUG???

Thanks a lot.... Glen.Grant  Even I experienced the same issue and it got fixed after I removed and pasted again the port channel configuration

5337
Views
4
Helpful
3
Replies
CreatePlease login to create content