Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Cisco Employee

EIGRP and GRE

I need to pass EIGRP and IGRP through a gre tunnel through a pix! The tunnel is up through the pix and with show ip route: i see the route for the tunnel. however, I dont see the other routes for the other remote networks! any thoughts on what I am missing with this config! I also have neighbor statements pointing to each tunnel interface

Router2

interface Tunnel10

ip address 10.1.2.1 255.255.255.0

tunnel source Ethernet0/0

tunnel destination 10.1.3.1

!

interface Ethernet0/0

ip address 10.1.1.1 255.255.255.0

full-duplex

Router 1

interface Tunnel10

ip address 10.1.2.2 255.255.255.0

tunnel source Ethernet0/0

tunnel destination 10.1.1.1

!

interface Ethernet0/0

ip address 10.1.1.1 255.255.255.0

full-duplex

5 REPLIES
New Member

Re: EIGRP and GRE

take a look at this. Its about multicast but i think it applies.

http://www.cisco.com/warp/customer/707/tunnel_pix.shtml

Cisco Employee

Re: EIGRP and GRE

this is the exact doc I used to get this far! the tunnel is up, but not seeing routes passed through!

New Member

Re: EIGRP and GRE

Could you ping the interface tunnel frome each other?

The configurations you provided have same ip address on ethernet port.

Do some tests to confirm the cause of the problem, tunnel or multicast?

Cisco Employee

Re: EIGRP and GRE

I cant ping the destination tunnel interface!

Router2

interface Tunnel10

ip address 10.1.2.1 255.255.255.0

tunnel source Ethernet0/0

tunnel destination 10.1.3.1

!

interface Ethernet0/0

ip address 10.1.1.1 255.255.255.0

full-duplex

Router 1

interface Tunnel10

ip address 10.1.2.2 255.255.255.0

tunnel source Ethernet0/0

tunnel destination 10.1.1.1

!

interface Ethernet0/0

ip address 10.1.3.1 255.255.255.0

full-duplex

New Member

Re: EIGRP and GRE

Do your routers know how to get to the tunnel destination?

If the Ethernet interfaces in your config the ones that connect to the firewall, you may have to put static routes like so:

Router 1

ip route 10.1.1.1 255.255.255.0 10.1.3.2 (or whatever the firewall IP address is)

Router 2

ip route 10.1.3.1 255.255.255.0 10.1.1.2 (or whatever the firewall IP address is)

246
Views
0
Helpful
5
Replies
CreatePlease to create content