Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

eigrp message

"ignored route, dup router"

the only thing i know, about this message is, that this is a problem with identical router-id.

my question is, are there other know problem's with this message.

thank

hs

6 REPLIES

Re: eigrp message

Silver

Re: eigrp message

yes , you could have an issue with routes external to your as that are being redistributed into your AS , EIGRP only uses a RID with routes that are tagged with an external AS , If you have a network that is advertised to By a router that has the same RID as you , your router will ignore this update because it assumes that it is being advertised by himself.

Re: eigrp message

hi

let my explain a little bit precise.

i have a router, which is doing redistribution between eigrp and ospf.

please, have a look to the config example. router-id ospf is 172.22.5.1, router-id eigrp is 172.22.9.3.

interface Loopback0

ip address 172.22.5.1 255.255.255.255

!

interface Loopback1

description NTP-Source

ip address 172.22.9.3 255.255.255.255

!

interface FastEthernet1/0

no ip address

duplex full

speed 100

hold-queue 400 in

hold-queue 100 out

!

interface FastEthernet1/0.1

encapsulation isl 1

ip address 172.22.5.131 255.255.255.192

no ip redirects

standby 1 ip 172.22.5.129

standby 1 priority 105

standby 1 preempt

standby 1 track FastEthernet1/1 20

!

interface FastEthernet1/0.410

encapsulation isl 410

ip address 172.22.10.3 255.255.255.0

ip ospf priority 10

!

interface FastEthernet1/1

ip address 192.168.99.51 255.255.255.240

duplex full

speed 100

hold-queue 400 in

hold-queue 100 out

!

router eigrp 200

redistribute static metric 10000 1000 255 1 1500 route-map static2eigrp

redistribute ospf 1 metric 10000 1000 255 1 1500 route-map ospf2eigrp

passive-interface FastEthernet1/0.1

passive-interface FastEthernet1/0.410

network 192.168.99.0

no auto-summary

!

router ospf 1

router-id 172.22.5.1

redistribute eigrp 200 metric 1000 subnets tag 100 route-map eigrp2ospf

passive-interface FastEthernet1/0

network 172.22.5.1 0.0.0.0 area 0

network 172.22.9.3 0.0.0.0 area 0

network 172.22.10.0 0.0.0.255 area 0

Gold

Re: eigrp message

You must have two eigrp routers with the same router id.... Generally this happens because two routers have the same interface ip addresses, or you've moved an ip address from one router to another. First, check for duplicate ip addresses on the router doing redistribution and the router putting this message out, renumbering as needed, and then restart the eigrp processes on the two routers.

Russ.W

Silver

Re: eigrp message

A sh ip eigrp events will show you the subnets that are being ignored , you will also be able to track down the router with the dup RID , I have found that this happens most often when the loopback of a router gets changed , Eigrp will keep the original RID , to correct this you must remove & replace the proces or the cleanest way is to relaod the box eith the bogus RID. A sh ip eigrp topology will tell you the RID

Re: eigrp message

hi

thank you for your help.

regards

hansruedi

280
Views
0
Helpful
6
Replies
CreatePlease to create content