Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Eigrp Neighbor not on common subnet for VlanXXX

Ok, got my Eigrp static route redistributed. But now Eigrp on site 2 complaining that every vlan is not "common" on both sites.

Vlan192 links Site1 to Site2

Site1 EigrpConfig:

router eigrp 700

redistribute static metric 10000 1000 255 1 1500

network 10.20.0.0 0.0.255.255

network 192.168.0.0 0.0.3.255

no auto-summary

eigrp stub connected static

nterface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes

Vl2 0 0/0 0 0/10 0 0

Vl20 0 0/0 0 0/10 0 0

Vl22 0 0/0 0 0/10 0 0

Vl26 0 0/0 0 0/10 0 0

Vl28 0 0/0 0 0/10 0 0

Vl30 0 0/0 0 0/10 0 0

Vl32 0 0/0 0 0/10 0 0

Vl34 0 0/0 0 0/10 0 0

Vl36 0 0/0 0 0/10 0 0

Vl38 0 0/0 0 0/10 0 0

Vl40 0 0/0 0 0/10 0 0

Vl255 0 0/0 0 0/10 0 0

Vl192 1 0/0 9 0/10 50 0

Site2 posted next

4 REPLIES
New Member

Re: Eigrp Neighbor not on common subnet for VlanXXX

It means that the two EIGRP routers have seen each others hello packets on the VLAN but that they are in different subnets - both routers VLAN interfaces need to be in the same subnet.

HTH

Phil

New Member

Re: Eigrp Neighbor not on common subnet for VlanXXX

how can I put do this? The common interface they share is in the same subnet, 192.168.0.0/22. Site1 is 192.168.0.2, Site2 is 192.168.3.6, bothe /22.

But the other interfaces naturally are different IP subnets. Site 1 is 10.20.0.0/16, site2 10.120.0.0/16.

Is there a way to only get hello's sent from the 192.168.0.0/22 interfaces, not from the other interfaces?

thanks

New Member

Re: Eigrp Neighbor not on common subnet for VlanXXX

I used the passive-interface vlan command. on my site2 for all vlan's but 192.

That has stopped the warnings. Is this an acceptable "fix" to this?

New Member

Re: Eigrp Neighbor not on common subnet for VlanXXX

Here is site2

router eigrp 700

redistribute static metric 10000 1000 255 1 1500

network 10.120.0.0 0.0.255.255

network 10.223.2.204 0.0.0.0

network 192.168.0.0 0.0.3.255

no auto-summary

eigrp stub connected static

no eigrp log-neighbor-changes

no eigrp log-neighbor-warnings

Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes

Vl2 0 0/0 0 0/10 0 0

Vl40 0 0/0 0 0/10 0 0

Vl42 0 0/0 0 0/10 0 0

Vl50 0 0/0 0 0/10 0 0

Vl120 0 0/0 0 0/10 0 0

Vl192 1 0/0 1303 0/10 6512 0

Enable of eigrp log-neighbor-warnings gives the following on site2:

(Default-IP-Routing-Table:700): Neighbor 10.120.2.3 not on common subnet for Vlan50

IP-EIGRP(Default-IP-Routing-Table:700): Neighbor 192.168.3.9 not on common subnet for Vlan2

(Default-IP-Routing-Table:700): Neighbor 10.120.2.3 not on common subnet for Vlan50

IP-EIGRP(Default-IP-Routing-Table:700): Neighbor 192.168.0.182 not on common subnet for Vlan2

IP-EIGRP(Default-IP-Routing-Table:700): Neighbor 10.120.50.3 not on common subnet for Vlan2

ColoVpn6509>(config-router)#

IP-EIGRP(Default-IP-Routing-Table:700): Neighbor 192.168.3.9 not on common subnet for Vlan2

seems router is at a war with itself. only 192.168.0.2 isn't native to this 6509.

676
Views
5
Helpful
4
Replies
CreatePlease to create content