Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

EIGRP on Group Asyc. interface

hi,

I have EIGRP runing on Access server and I don't want each dail-up user to advertise its ip add. in the routing table of the backbone router

My problem is that I got the following

In backbone router tables

D 10.5.1.23/32 [90/24823296] via 10.254.254.10, 00:01:12, ATM3/1/ima1

AND

In the Access server routing table

C 10.5.1.23/32 is directly connected, Async205

So , I will have entry for each dail-up user in the backbone routing table !!!!

My access server config. is :

interface Loopback0

ip address 10.5.1.1 255.255.255.0

!

interface Group-Async1

ip unnumbered Loopback0

encapsulation ppp

ip tcp header-compression passive

async mode interactive

peer default ip address pool analog

ppp authentication chap pap

group-range 161 190

!

router eigrp 1

network 10.0.0.0

auto-summary

no eigrp log-neighbor-changes

!

ip local pool analog 10.5.1.2 10.5.1.61

How can I solve this problem ?

'Thanks

Mohamed Abdallah

3 REPLIES

Re: EIGRP on Group Asyc. interface

I assume your backbone router is connected to your access server on the fast ethernet or ethernet interface. On this interface of the access server, put a command on the interface mode.

(config)#interface fa0/0 (or interface e0/0 or interface e0)

(config-if)#ip summary-address eigrp 1 10.5.1.0 255.255.255.0

This will summarize all the host routes and send it as a single route to the backbone. WHen you enter this command, there would be a 10.5.1.0 /24 route on your routing table pointing to null0.

Hope this will help.

New Member

Re: EIGRP on Group Asyc. interface

Thanks for your help

my backbone is connected to the access server using ATM interface ( point to point PVC )

here is my access server config.

interface Loopback0

ip address 10.5.1.1 255.255.255.0

!

interface FastEthernet0/0

ip address 10.5.10.254 255.255.255.0

speed auto

full-duplex

!

interface ATM1/0

no ip address

atm vc-per-vp 256

no atm ilmi-keepalive

ima-group 0

scrambling-payload

impedance 120-ohm

!

interface ATM1/IMA0

description E1 link to Backbone Router

ip address 10.254.254.10 255.255.255.252

atm vc-per-vp 256

no atm ilmi-keepalive

pvc 2/35

protocol ip 10.254.254.9 broadcast

!

!

interface Group-Async1

ip unnumbered Loopback0

encapsulation ppp

ip tcp header-compression passive

async mode interactive

peer default ip address pool analog

ppp authentication chap pap

group-range 161 190

router eigrp 1

network 10.0.0.0

auto-summary

no eigrp log-neighbor-changes

!

ip local pool analog 10.5.1.2 10.5.1.61

line 161 190

modem InOut

autocommand ppp

transport input all

autoselect during-login

autoselect ppp

Should I enter the command "ip summary-address eigrp 1 10.5.1.0 255.255.255.0 "on the IMA group interface ?

should I disable the auto summary on EIGRP process on access server

using no auto summary command ?

Thanks

Mohamed

Re: EIGRP on Group Asyc. interface

Hi Mohammed,

You have to configure this command on the IMA group interface.

Looking at your ip address pool, I would suggest you to summarize the network to a more specific network address. Since you have only 60 address in the pool, it would be much better to get summarized into a network with 64 hosts addresses, rather than to be summarized into a network with 254 addresses (10.1.5.0/24 would have 254 host addresses in it)

In summary, the summary command would look like,

ip summary-address eigrp 1 10.5.1.0 255.255.255.192 (this would summarize to a network 10.5.1.0/26 - with 64 host in it)

107
Views
0
Helpful
3
Replies
CreatePlease login to create content