Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

EIGRP Question

Hi,

I am having a problem with an EIGRP router learning about a network from it's neighbor. I included the configs below. Router 2 does not know about the 192.168.253.x network behind interface S1.10. When I do a show ip eigrp nei, (on Router 2) it does show Router 1 as a neighbor. When I do a show ip eigrp top, it shows that it learned about all the 10.x.x.x networks from Router 1. The only way to get it to work is by gateway of last resort pointing to Router 1. Any ideas? Is the fact I'm using loopback 0 for ip unnumbered causing any problems? Thanks in advance for any help!

Router 1

interface Loopback0

ip address 172.17.0.1 255.255.255.0

no ip directed-broadcast

!

interface Ethernet0

ip address 10.1.1.251 255.255.255.0

no ip directed-broadcast

no ip proxy-arp

ip nat inside

!

interface Serial1

no ip address

no ip directed-broadcast

encapsulation frame-relay

no logging event subif-link-status

no logging event dlci-status-change

!

interface Serial1.10 point-to-point

ip address 192.168.253.134 255.255.255.252

no ip directed-broadcast

ip nat outside

frame-relay interface-dlci 865

!

interface Serial1.21 point-to-point

ip unnumbered Loopback0

no ip directed-broadcast

ip nat inside

frame-relay interface-dlci 21

!

router eigrp 2

network 10.0.0.0

network 172.17.0.0

network 192.168.0.0

no auto-summary

!

Router 2

interface Loopback0

ip address 172.17.0.2 255.255.255.0

no ip directed-broadcast

!

interface Ethernet0

ip address 10.5.1.1 255.255.255.0

no ip directed-broadcast

no ip proxy-arp

!

interface Serial1

no ip address

no ip directed-broadcast

encapsulation frame-relay

no logging event subif-link-status

no logging event dlci-status-change

!

interface Serial1.20 point-to-point

ip unnumbered Loopback0

ip directed-broadcast

frame-relay interface-dlci 20

!

interface Serial1.101 point-to-point

bandwidth 64

ip unnumbered Loopback0

no ip directed-broadcast

frame-relay interface-dlci 101

!

router eigrp 2

network 10.0.0.0

network 172.17.0.0

no auto-summary

2 REPLIES
New Member

Re: EIGRP Question

Under the router eigrp 2 you can add a neighbor statement of the serial interface of the router you are trying to see. (192.168.253.x ) Also, EIGRP uses bandwidth as part of it's cost metric - I did not see a band statement.

Also check to see if there is any acl's blocking you and you are both on the sams AS.

Hope that helps.

C

Gold

Re: EIGRP Question

There's no interface with 192.168.153.x for eigrp to pick up and advertise towareds router 1 here. You'll need to put this network on the router someplace, or you'll need to get eigrp running on the next hop router to advertise it to router 2, so that router 2 can pass it on to router 1. Other than this, you could configure a static on router 2, and redistribute that into eigrp (just remember the default metric if you redistribute static).

:-)

Russ

116
Views
0
Helpful
2
Replies
CreatePlease to create content