Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Eigrp to BRI

Dear All,

I got a weird problem. We are using Eigrp as a routing protocol. connectivity is thru leased line and ISDN as backup.

Now until the leased Ckt is UP I get all the routes theu EIGRP but when Leaseline is down and we dial thru ISDN then EIGRP doesnt work and I have to add the static routes.

We use 10.250.0.0 for serial port 10.155.0.0 for ethernet port and 10.155.208.0 for BRI port.

And I have added 10.0.0.0 network in EIGRP with same AS.

Pls solve my trouble.

Mangesh

5 REPLIES
New Member

Re: Eigrp to BRI

You should use "dialer-list" command in your configuration to trigger BRI interface for forwarding EIGRP packets. If it is present, can you check your interesting traffic definitions? Posting some part of the configuration may be useful..

Onur

New Member

Re: Eigrp to BRI

--begin ciscomoderator note-- The following post has been edited to remove potentially confidential information. Please refrain from posting confidential information on the site to reduce security risks to your network. -- end ciscomoderator note --

here is my config...

router1#sh run

Building configuration...

Current configuration : 2363 bytes

!

version 12.1

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname router1

!

enable secret

enable password

!

!

!

!

!

ip subnet-zero

ip name-server xxx.xx.1.30

ip name-server 10.1.0.37

!

isdn switch-type basic-net3

!

!

!

!

!

interface Ethernet0/0

description WAMAN CENTRE

ip address 10.155.5.1 255.255.255.0 secondary

ip address 10.155.7.1 255.255.255.0 secondary

ip address 10.155.6.1 255.255.255.0

no ip mroute-cache

no cdp enable

!

interface Serial0/0

description ****** LL to AHURA CENTRE******

bandwidth 2048

ip address 10.250.4.114 255.255.255.252

no ip mroute-cache

!

interface Serial0/1

backup interface Dialer0

no ip address

no ip mroute-cache

shutdown

no cdp enable

!

interface BRI1/0

description ***** ISDN Link to Marine Lines ****

ip address 10.155.208.101 255.255.255.0

encapsulation ppp

no ip mroute-cache

dialer pool-member 1

dialer pool-member 2

isdn switch-type basic-net3

ppp multilink

!

interface BRI1/1

ip address 10.155.208.102 255.255.255.0

encapsulation ppp

no ip mroute-cache

dialer idle-timeout 25000

dialer load-threshold 5 outbound

dialer-group 1

isdn switch-type basic-net3

isdn tei-negotiation first-call

ppp multilink

!

interface BRI1/2

ip address 10.155.208.103 255.255.255.0

ip accounting output-packets

encapsulation ppp

no ip mroute-cache

dialer idle-timeout 200

dialer-group 1

isdn switch-type basic-net3

isdn tei-negotiation first-call

!

interface BRI1/3

ip address 10.155.208.104 255.255.255.0

encapsulation ppp

no ip mroute-cache

dialer idle-timeout 200

dialer-group 1

isdn switch-type basic-net3

!

interface Dialer0

bandwidth 64

ip unnumbered BRI1/1

encapsulation ppp

dialer pool 1

dialer idle-timeout 200

dialer string 25247261

dialer-group 1

ppp multilink

!

interface Dialer1

bandwidth 64

ip unnumbered BRI1/0

encapsulation ppp

dialer pool 2

dialer-group 1

!

router eigrp 2101

redistribute static

network 10.0.0.0

auto-summary

no eigrp log-neighbor-changes

!

ip classless

no ip http server

!

dialer-list 1 protocol ip permit

dialer-list 2 protocol ip permit

snmp-server community --moderator edit--

!

end

Re: Eigrp to BRI

For these situations you might better configure a so-called "floating static route". This is a static route with a higher administrative distance than the EIGRP-derived route. When EIGRP drops dead, it floats to the surface and you remain connected.

EIGRP is not forwarded over ISDN while you have not added the keyword "broadcast" in the dialer map statement or because your dialer map or interface access-list blocks them. As EIGRP updates are multicasts, they are not sent over a dialer interface by default and an access-list in your dialer map like: permit ip 10.0.0.0/8 to 10.0.0.0/8 will also block them.

The effect of changing this can be that your ISDN line will remain up constantly. You may not want to do this to happen.

Regards,

Leo

Re: Eigrp to BRI

Just a guess....but do you have the "broadcast" statement in the ISDN interface's dialer map configuration? If not, the EIGRP hello packets will not pass. For example:

dialer map ip 10.155.1.1 name ROUTER broadcast 15551234567

Regards

New Member

Re: Eigrp to BRI

Thanks,

ok i agree I havent putted Broadcast , but if I am using Dialer profiles then i left only with dialer string so what in that case.....

pls help me..

125
Views
0
Helpful
5
Replies
CreatePlease login to create content