Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

EIGRP waited Static route

I have two router connected over a 2 meg frame relay running EIGRP over GRE tunnels.

I have two routers for backup using ISDN (2 meg).

I have setup waited static route on the ISDN router (wait of 250) to bring up the backup ISDN interface if I loose the main Frame relay.

I have a problem that the static routes for routes that are two hops away take precedence on my EIGRP routes (170/xxxxxx).

Any suggestions

Regards

12 REPLIES
VIP Purple

Re: EIGRP waited Static route

Hello,

I assume you mean that you have configured a floating static route with an admin distance of 250 ?

Can you post your config ?

Regards,

Georg

Gold

Re: EIGRP waited Static route

Could you post a show ip route with the statics and the eigrp routes in it?

Russ.W

New Member

Re: EIGRP waited Static route

I had to post the config separate. First routing and config of R1 Frame relay, second R2 ISDN and third EIGRP topology for network 10.30.41.0.

Check the Network 10.30.41.0 this is the one causing problem.

For example check the route for network 10.30.41.0

At the moment it is going via the ISDN backup when I would have

expected to go via the AFR

R1 AFR

router eigrp 300

redistribute connected

redistribute static

passive-interface Serial0/0

passive-interface Serial0/0.1

network 10.0.0.0

network 192.168.17.0

default-metric 2000000 1000 255 1 1500

auto-summary

no eigrp log-neighbor-changes

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.17.249

ip route 10.30.1.248 255.255.255.248 192.168.17.19

ip route 10.30.2.240 255.255.255.240 192.168.17.249

ip route 10.30.3.0 255.255.255.0 192.168.17.249

ip route 10.30.20.0 255.255.255.0 192.168.17.249

ip route 10.30.21.0 255.255.255.0 192.168.17.249

ip route 10.30.33.2 255.255.255.255 10.30.33.37

ip route 10.30.33.6 255.255.255.255 10.30.33.37

ip route 10.30.33.10 255.255.255.255 10.30.33.37

ip route 10.30.33.14 255.255.255.255 10.30.33.37

ip route 10.30.33.18 255.255.255.255 10.30.33.37

ip route 10.30.33.22 255.255.255.255 10.30.33.37

ip route 10.30.33.26 255.255.255.255 10.30.33.37

ip route 10.30.33.30 255.255.255.255 192.168.17.249

ip route 10.30.70.0 255.255.255.240 10.30.69.13

ip route 10.30.77.0 255.255.255.0 192.168.17.249

ip route 10.30.78.0 255.255.255.0 192.168.17.249

ip route 10.30.79.52 255.255.255.252 192.168.17.249

ip route 10.104.4.2 255.255.255.255 192.168.17.249

ip route 10.104.4.10 255.255.255.255 192.168.17.249

ip route 80.0.0.0 255.0.0.0 192.168.17.249

ip route 150.173.0.0 255.255.0.0 10.30.68.61

ip route 150.173.243.0 255.255.255.0 192.168.17.249

ip route 192.168.11.0 255.255.255.0 192.168.17.19

ip route 192.168.12.0 255.255.255.0 192.168.17.19

ip route 192.168.14.0 255.255.255.0 192.168.17.19

ip route 192.168.50.0 255.255.255.0 192.168.17.19

ip route 203.13.142.146 255.255.255.255 192.168.17.249

ip route 203.13.142.147 255.255.255.255 192.168.17.249

ip route 203.202.2.161 255.255.255.255 10.30.39.249

ip route 203.202.70.161 255.255.255.255 192.168.17.19

ip route 203.202.70.162 255.255.255.255 192.168.17.19

R1-AFR#sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is 192.168.17.249 to network 0.0.0.0

S 192.168.12.0/24 [1/0] via 192.168.17.19

203.13.142.0/32 is subnetted, 2 subnets

S 203.13.142.146 [1/0] via 192.168.17.249

S 203.13.142.147 [1/0] via 192.168.17.249

S 192.168.14.0/24 [1/0] via 192.168.17.19

155.195.0.0/32 is subnetted, 1 subnets

D EX 155.195.48.68 [170/297500416] via 10.30.33.26, 02:01:25, Tunnel10

S 80.0.0.0/8 [1/0] via 192.168.17.249

203.202.70.0/32 is subnetted, 2 subnets

S 203.202.70.162 [1/0] via 192.168.17.19

S 203.202.70.161 [1/0] via 192.168.17.19

203.202.2.0/32 is subnetted, 1 subnets

S 203.202.2.161 [1/0] via 10.30.39.249

S 192.168.11.0/24 [1/0] via 192.168.17.19

10.0.0.0/8 is variably subnetted, 50 subnets, 9 masks

S 10.30.20.0/24 [1/0] via 192.168.17.249

S 10.30.21.0/24 [1/0] via 192.168.17.249

D 10.40.32.0/23 [90/297246976] via 10.30.33.6, 04:31:36, Tunnel40

D 10.20.28.0/22 [90/297246976] via 10.30.33.10, 04:31:41, Tunnel22

D 10.0.0.0/8 is a summary, 1d07h, Null0

D EX 10.70.70.0/24 [170/284160] via 10.30.68.45, 1d07h, FastEthernet0/1

C 10.30.33.36/30 is directly connected, Serial0/0.1

D EX 10.31.0.0/16 [170/297500416] via 10.30.33.26, 02:01:25, Tunnel10

D 10.60.32.0/23 [90/297246976] via 10.30.33.18, 02:01:25, Tunnel60

S 10.30.3.0/24 [1/0] via 192.168.17.249

D 10.50.32.0/23 [90/297246976] via 10.30.33.2, 04:31:36, Tunnel50

D 10.30.60.8/30 [90/20514560] via 10.30.68.45, 00:00:29, FastEthernet0/1

D 10.30.60.9/32 [90/297758976] via 10.30.33.26, 00:00:28, Tunnel10

D 10.30.33.20/30 [90/297756416] via 10.30.33.22, 04:31:36, Tunnel20

D 10.30.60.10/32

[90/40514560] via 10.30.68.45, 00:00:28, FastEthernet0/1

S 10.30.33.22/32 [1/0] via 10.30.33.37

D 10.30.35.20/30

[90/46228736] via 10.30.68.45, 04:31:46, FastEthernet0/1

D 10.30.60.12/30 [90/46228736] via 10.30.68.45, 1d07h, FastEthernet0/1

D 10.30.33.16/30 [90/297756416] via 10.30.33.18, 02:01:29, Tunnel60

S 10.30.33.18/32 [1/0] via 10.30.33.37

D 10.30.35.16/30

[90/46228736] via 10.30.68.45, 04:31:40, FastEthernet0/1

D EX 10.32.0.0/16 [170/297500416] via 10.30.33.26, 02:01:29, Tunnel10

S 10.30.33.30/32 [1/0] via 192.168.17.249

D 10.30.33.24/30 [90/297756416] via 10.30.33.26, 02:01:29, Tunnel10

S 10.30.33.26/32 [1/0] via 10.30.33.37

D 10.30.36.0/22 [90/297246976] via 10.30.33.26, 02:01:29, Tunnel10

D 10.30.33.4/30 [90/297756416] via 10.30.33.6, 04:31:40, Tunnel40

S 10.30.33.6/32 [1/0] via 10.30.33.37

D 10.30.35.4/30 [90/46228736] via 10.30.68.45, 04:31:42, FastEthernet0/1

D 10.30.33.0/30 [90/297756416] via 10.30.33.2, 04:31:40, Tunnel50

S 10.30.33.2/32 [1/0] via 10.30.33.37

D 10.30.35.0/30 [90/46228736] via 10.30.68.45, 04:31:42, FastEthernet0/1

D 10.30.33.12/30 [90/297756416] via 10.30.33.14, 04:45:53, Tunnel70

S 10.30.33.14/32 [1/0] via 10.30.33.37

D 10.30.35.12/30

[90/46228736] via 10.30.68.45, 04:31:42, FastEthernet0/1

D EX 10.30.41.0/24 [170/284160] via 10.30.68.45, 02:01:29, FastEthernet0/1

D 10.30.33.8/30 [90/297756416] via 10.30.33.10, 04:31:44, Tunnel22

D 10.20.32.0/22 [90/297246976] via 10.30.33.22, 04:31:40, Tunnel20

S 10.30.33.10/32 [1/0] via 10.30.33.37

D 10.30.35.8/30 [90/46228736] via 10.30.68.45, 04:31:42, FastEthernet0/1

D 10.70.1.0/24 [90/297246976] via 10.30.33.14, 04:31:40, Tunnel70

C 10.30.68.0/23 is directly connected, FastEthernet0/1

S 10.30.70.0/28 [1/0] via 10.30.69.13

S 10.30.77.0/24 [1/0] via 192.168.17.249

S 10.30.78.0/24 [1/0] via 192.168.17.249

S 10.104.4.2/32 [1/0] via 192.168.17.249

S 10.104.4.10/32 [1/0] via 192.168.17.249

S 10.30.79.52/30 [1/0] via 192.168.17.249

S 10.30.2.240/28 [1/0] via 192.168.17.249

S 10.30.1.248/29 [1/0] via 192.168.17.19

C 192.168.17.0/24 is directly connected, FastEthernet0/0

S 192.168.50.0/24 [1/0] via 192.168.17.19

150.173.0.0/16 is variably subnetted, 2 subnets, 2 masks

S 150.173.0.0/16 [1/0] via 10.30.68.61

S 150.173.243.0/24 [1/0] via 192.168.17.249

S* 0.0.0.0/0 [1/0] via 192.168.17.249

New Member

Re: EIGRP waited Static route

second port R2 ISDNR2-ISDN

router eigrp 300

redistribute connected

redistribute static

passive-interface Dialer1

network 10.0.0.0

network 192.168.17.0

default-metric 2000000 1000 255 1 1500

auto-summary

no eigrp log-neighbor-changes

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.17.249

ip route 10.10.32.0 255.255.252.0 Dialer20

ip route 10.20.28.0 255.255.252.0 10.30.35.22 200

ip route 10.20.32.0 255.255.252.0 10.30.35.14 200

ip route 10.30.1.248 255.255.255.248 192.168.17.19

ip route 10.30.2.240 255.255.255.240 192.168.17.249

ip route 10.30.3.0 255.255.255.0 192.168.17.249

ip route 10.30.20.0 255.255.255.0 192.168.17.249

ip route 10.30.21.0 255.255.255.0 192.168.17.249

ip route 10.30.33.30 255.255.255.255 192.168.17.249

ip route 10.30.36.0 255.255.252.0 10.30.60.10 250

ip route 10.30.41.0 255.255.255.0 10.30.60.10 250

ip route 10.30.70.0 255.255.255.240 10.30.69.13

ip route 10.30.77.0 255.255.255.0 192.168.17.249

ip route 10.30.78.0 255.255.255.0 192.168.17.249

ip route 10.30.79.52 255.255.255.252 192.168.17.249

ip route 10.40.32.0 255.255.254.0 10.30.35.10 200

ip route 10.50.32.0 255.255.254.0 10.30.35.6 200

ip route 10.60.32.0 255.255.254.0 10.30.35.18 200

ip route 10.70.1.0 255.255.255.0 10.30.35.2 200

ip route 10.70.70.0 255.255.255.0 10.30.33.14

ip route 10.104.4.2 255.255.255.255 192.168.17.249

ip route 10.104.4.10 255.255.255.255 192.168.17.249

ip route 80.0.0.0 255.0.0.0 192.168.17.249

ip route 150.173.0.0 255.255.0.0 10.30.68.61

ip route 150.173.243.0 255.255.255.0 192.168.17.249

ip route 192.168.11.0 255.255.255.0 192.168.17.19

ip route 192.168.12.0 255.255.255.0 192.168.17.19

ip route 192.168.14.0 255.255.255.0 192.168.17.19

ip route 192.168.19.0 255.255.255.0 192.168.20.253

ip route 192.168.50.0 255.255.255.0 192.168.17.19

ip route 203.13.142.146 255.255.255.255 192.168.17.249

ip route 203.13.142.147 255.255.255.255 192.168.17.249

ip route 203.202.2.161 255.255.255.255 10.30.39.249

ip route 203.202.70.161 255.255.255.255 192.168.17.19

ip route 203.202.70.162 255.255.255.255 192.168.17.19

me680-2#sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is 192.168.17.249 to network 0.0.0.0

S 192.168.12.0/24 [1/0] via 192.168.17.19

203.13.142.0/32 is subnetted, 2 subnets

S 203.13.142.146 [1/0] via 192.168.17.249

S 203.13.142.147 [1/0] via 192.168.17.249

S 192.168.14.0/24 [1/0] via 192.168.17.19

155.195.0.0/32 is subnetted, 1 subnets

D EX 155.195.48.68 [170/297526016] via 10.30.68.46, 05:16:21, Ethernet0/0

[170/297526016] via 192.168.17.4, 05:16:21, Ethernet1/0

S 80.0.0.0/8 [1/0] via 192.168.17.249

203.202.70.0/32 is subnetted, 2 subnets

S 203.202.70.162 [1/0] via 192.168.17.19

S 203.202.70.161 [1/0] via 192.168.17.19

203.202.2.0/32 is subnetted, 1 subnets

S 203.202.2.161 [1/0] via 10.30.39.249

S 192.168.11.0/24 [1/0] via 192.168.17.19

10.0.0.0/8 is variably subnetted, 49 subnets, 9 masks

S 10.30.20.0/24 [1/0] via 192.168.17.249

S 10.30.21.0/24 [1/0] via 192.168.17.249

D 10.20.28.0/22 [90/297272576] via 10.30.68.46, 05:02:12, Ethernet0/0

D 10.40.32.0/23 [90/297272576] via 10.30.68.46, 1d07h, Ethernet0/0

S 10.70.70.0/24 [1/0] via 10.30.33.14

D 10.0.0.0/8 is a summary, 2w4d, Null0

D 10.30.33.36/30 [90/1787392] via 10.30.68.46, 1d07h, Ethernet0/0

D EX 10.31.0.0/16 [170/297526016] via 10.30.68.46, 05:16:21, Ethernet0/0

D 10.60.32.0/23 [90/297272576] via 10.30.68.46, 08:48:47, Ethernet0/0

S 10.30.3.0/24 [1/0] via 192.168.17.249

D 10.50.32.0/23 [90/297272576] via 10.30.68.46, 1d07h, Ethernet0/0

C 10.30.60.8/30 is directly connected, Dialer1

D 10.30.33.20/30 [90/297782016] via 10.30.68.46, 14:45:22, Ethernet0/0

C 10.30.60.10/32 is directly connected, Dialer1

D EX 10.30.33.22/32 [170/537600] via 10.30.68.46, 1d07h, Ethernet0/0

C 10.30.35.20/30 is directly connected, Dialer9

C 10.30.60.12/30 is directly connected, Dialer2

D 10.30.33.16/30 [90/297782016] via 10.30.68.46, 08:48:48, Ethernet0/0

D EX 10.30.33.18/32 [170/537600] via 10.30.68.46, 1d07h, Ethernet0/0

C 10.30.35.16/30 is directly connected, Dialer6

D EX 10.32.0.0/16 [170/297526016] via 10.30.68.46, 05:16:22, Ethernet0/0

S 10.30.33.30/32 [1/0] via 192.168.17.249

D 10.30.33.24/30 [90/297782016] via 10.30.68.46, 05:16:22, Ethernet0/0

D EX 10.30.33.26/32 [170/537600] via 10.30.68.46, 1d07h, Ethernet0/0

D 10.30.36.0/22 [90/297272576] via 10.30.68.46, 05:16:22, Ethernet0/0

D 10.30.33.4/30 [90/297782016] via 10.30.68.46, 1d07h, Ethernet0/0

D EX 10.30.33.6/32 [170/537600] via 10.30.68.46, 1d07h, Ethernet0/0

C 10.30.35.4/30 is directly connected, Dialer5

D 10.30.33.0/30 [90/297782016] via 10.30.68.46, 1d07h, Ethernet0/0

D EX 10.30.33.2/32 [170/537600] via 10.30.68.46, 1d07h, Ethernet0/0

C 10.30.35.0/30 is directly connected, Dialer4

D 10.30.33.12/30 [90/297782016] via 10.30.68.46, 1d07h, Ethernet0/0

D EX 10.30.33.14/32 [170/537600] via 10.30.68.46, 1d07h, Ethernet0/0

C 10.30.35.12/30 is directly connected, Dialer8

D 10.30.33.8/30 [90/297782016] via 10.30.68.46, 05:02:13, Ethernet0/0

S 10.30.41.0/24 [250/0] via 10.30.60.10

D 10.20.32.0/22 [90/297272576] via 10.30.68.46, 14:45:23, Ethernet0/0

D EX 10.30.33.10/32 [170/537600] via 10.30.68.46, 1d07h, Ethernet0/0

C 10.30.35.8/30 is directly connected, Dialer7

D 10.70.1.0/24 [90/297272576] via 10.30.68.46, 1d07h, Ethernet0/0

C 10.30.68.0/23 is directly connected, Ethernet0/0

S 10.30.70.0/28 [1/0] via 10.30.69.13

S 10.30.77.0/24 [1/0] via 192.168.17.249

S 10.30.78.0/24 [1/0] via 192.168.17.249

S 10.104.4.2/32 [1/0] via 192.168.17.249

S 10.104.4.10/32 [1/0] via 192.168.17.249

S 10.30.79.52/30 [1/0] via 192.168.17.249

S 10.30.2.240/28 [1/0] via 192.168.17.249

S 10.30.1.248/29 [1/0] via 192.168.17.19

C 192.168.17.0/24 is directly connected, Ethernet1/0

S 192.168.50.0/24 [1/0] via 192.168.17.19

150.173.0.0/16 is variably subnetted, 2 subnets, 2 masks

S 150.173.0.0/16 [1/0] via 10.30.68.61

S 150.173.243.0/24 [1/0] via 192.168.17.249

S* 0.0.0.0/0 [1/0] via 192.168.17.249

New Member

Re: EIGRP waited Static route

Topology for R1R1-AFR #sh ip eigrp topo 10.30.41.0 255.255.255.0

IP-EIGRP (AS 300): Topology entry for 10.30.41.0/24

State is Passive, Query origin flag is 1, 1 Successor(s), FD is 284160

Routing Descriptor Blocks:

10.30.68.45 (FastEthernet0/1), from 10.30.68.45, Send flag is 0x0

Composite metric is (284160/257280), Route is External

Vector metric:

Minimum bandwidth is 100000 Kbit

Total delay is 10100 microseconds

Reliability is 255/255

Load is 1/255

Minimum MTU is 1500

Hop count is 1

External data:

Originating router is 192.168.17.3

AS number of route is 0

External protocol is Static, external metric is 0

Administrator tag is 0 (0x00000000)

10.30.33.18 (Tunnel60), from 10.30.33.18, Send flag is 0x0

Composite metric is (310300416/297500416), Route is External

Vector metric:

Minimum bandwidth is 9 Kbit

Total delay is 1010000 microseconds

Reliability is 255/255

Load is 141/255

Minimum MTU is 1476

Hop count is 2

External data:

Originating router is 10.30.37.254

AS number of route is 0

External protocol is Static, external metric is 0

Administrator tag is 0 (0x00000000)

10.30.33.10 (Tunnel22), from 10.30.33.10, Send flag is 0x0

Composite metric is (310300416/297500416), Route is External

Vector metric:

Minimum bandwidth is 9 Kbit

Total delay is 1010000 microseconds

Reliability is 255/255

Load is 28/255

Minimum MTU is 1476

Hop count is 2

External data:

Originating router is 10.30.37.254

AS number of route is 0

External protocol is Static, external metric is 0

Administrator tag is 0 (0x00000000)

10.30.33.26 (Tunnel10), from 10.30.33.26, Send flag is 0x0

Composite metric is (297500416/257280), Route is External

Vector metric:

Minimum bandwidth is 9 Kbit

Total delay is 510000 microseconds

Reliability is 255/255

Load is 195/255

Minimum MTU is 1476

Hop count is 1

External data:

Originating router is 10.30.37.254

AS number of route is 0

External protocol is Static, external metric is 0

Administrator tag is 0 (0x00000000)

10.30.33.22 (Tunnel20), from 10.30.33.22, Send flag is 0x0

Composite metric is (310300416/297500416), Route is External

Vector metric:

Minimum bandwidth is 9 Kbit

Total delay is 1010000 microseconds

Reliability is 255/255

Load is 1/255

Minimum MTU is 1476

Hop count is 2

External data:

Originating router is 10.30.37.254

AS number of route is 0

External protocol is Static, external metric is 0

Administrator tag is 0 (0x00000000)

10.30.33.14 (Tunnel70), from 10.30.33.14, Send flag is 0x0

Composite metric is (310300416/297500416), Route is External

Vector metric:

Minimum bandwidth is 9 Kbit

Total delay is 1010000 microseconds

Reliability is 255/255

Load is 1/255

Minimum MTU is 1476

Hop count is 2

External data:

Originating router is 10.30.37.254

AS number of route is 0

External protocol is Static, external metric is 0

Administrator tag is 0 (0x00000000)

10.30.33.2 (Tunnel50), from 10.30.33.2, Send flag is 0x0

Composite metric is (310300416/297500416), Route is External

Vector metric:

Minimum bandwidth is 9 Kbit

Total delay is 1010000 microseconds

Reliability is 255/255

Load is 113/255

Minimum MTU is 1476

Hop count is 2

External data:

Originating router is 10.30.37.254

AS number of route is 0

External protocol is Static, external metric is 0

Administrator tag is 0 (0x00000000)

10.30.33.6 (Tunnel40), from 10.30.33.6, Send flag is 0x0

Composite metric is (310300416/297500416), Route is External

Vector metric:

Minimum bandwidth is 9 Kbit

Total delay is 1010000 microseconds

Reliability is 255/255

Load is 1/255

Minimum MTU is 1476

Hop count is 2

External data:

Originating router is 10.30.37.254

AS number of route is 0

External protocol is Static, external metric is 0

Administrator tag is 0 (0x00000000)

New Member

Re: EIGRP waited Static route

topology for R2R2-ISDN#sh ip eigrp topo 10.30.41.0 255.255.255.0

IP-EIGRP (AS 300): Topology entry for 10.30.41.0/24

State is Passive, Query origin flag is 1, 1 Successor(s), FD is 257280

Routing Descriptor Blocks:

0.0.0.0, from Rstatic, Send flag is 0x0

Composite metric is (257280/0), Route is External

Vector metric:

Minimum bandwidth is 2000000 Kbit

Total delay is 10000 microseconds

Reliability is 255/255

Load is 1/255

Minimum MTU is 1500

Hop count is 0

External data:

Originating router is 192.168.17.3 (this system)

AS number of route is 0

External protocol is Static, external metric is 0

Administrator tag is 0 (0x00000000)

Gold

Re: EIGRP waited Static route

Could you post a show ip route 10.30.41.0 255.255.255.0 ?

Russ.W

New Member

Re: EIGRP waited Static route

The below ip route is what I expect.

But after a while I loose the EIGRP update

only for this Network and it default to R2-ISDN

I just removed the static route

no ip route 10.30.41.0 255.255.255.0 Tunnel10

I receive the update from My other AFR router

10.30.33.26.

R1-AFR#sh ip route 10.30.41.0

Routing entry for 10.30.41.0/24

Known via "eigrp 300", distance 170, metric 297500416, type external

Redistributing via eigrp 300

Last update from 10.30.33.26 on Tunnel10, 00:00:07 ago

Routing Descriptor Blocks:

* 10.30.33.26, from 10.30.33.26, 00:00:07 ago, via Tunnel10

Route metric is 297500416, traffic share count is 1

Total delay is 510000 microseconds, minimum bandwidth is 9 Kbit

Reliability 255/255, minimum MTU 1476 bytes

Loading 241/255, Hops 1

R2-ISDN#sh ip route 10.30.41.0

Routing entry for 10.30.41.0/24

Known via "eigrp 300", distance 170, metric 297526016, type external

Redistributing via eigrp 300

Advertised by eigrp 300 (self originated)

Last update from 10.30.68.46 on Ethernet0/0, 00:00:45 ago

Routing Descriptor Blocks:

* 10.30.68.46, from 10.30.68.46, 00:00:45 ago, via Ethernet0/0

Route metric is 297526016, traffic share count is 1

Total delay is 511000 microseconds, minimum bandwidth is 9 Kbit

Reliability 255/255, minimum MTU 1476 bytes

Loading 241/255, Hops 2

Bronze

Re: EIGRP waited Static route

Hi,

The problem is with admin distance. By default, static routes are preferred than EIGRP. So, do this one in your ISDN router,

"ip route 10.30.41.0 ..... 100". This is floating static route, with which it can serve your purpose.

Regards...

Ashok.

With best regards... Ashok ----------- Pls kindly rate if helpful or answered your question.
Bronze

Re: EIGRP waited Static route

Hi,

Following to my earlier reply, sorry, change your static to "ip route 10.30.41.0 ... 200". At present, the admin distance by EIGRP route is 170. And i observed that you are not having any problem at FR router, is't it?

Regards..

Ashok.

With best regards... Ashok ----------- Pls kindly rate if helpful or answered your question.
New Member

Re: EIGRP waited Static route

Ashok.

I have a static on my ISDN router with a wait of 250

ip route 10.30.41.0 255.255.255.0 10.30.60.10 250

The problem is when it is advertised via Eigrp the cost chage to 170 the 250 cost is not reflected.

When the ISDN is up I get the following EIGRP on my FR router

D EX 10.30.41.0/24 [170/284160] via 10.30.68.45, 02:01:29, FastEthernet0/1

So when my frame relay links comes back the wait is also of 170. I would have thought that the Static wait of 250 would have been advertised via EIGRP

eg [250/284160]

Regards

Yves

Gold

Re: EIGRP waited Static route

Okay, so my guess is that you have two routers, one of which has the isdn connection, the other of which has the frame relay connection. When the frame link fails, the floating static on the isdn box comes up, and cuases interesting traffic to flow across the isdn link, which brings it up. You are, most likely, redistributing this floating static into eigrp, correct?

So, when the frame link comes back up, the redistributed static is staying in the routing table, rather than the frame link.... Can you bring the frame link down, forcing the isdn link to dial, then bring the frame back up, and then run show ip eigrp topo 10.30.41.0 255.255.255.0?

Is the route coming across the frame link an external, as well? If so, then it's not the admin distance (weight) that's causing the problem, it's the metric. On the frame router, you are comparing two routes, both externals, and the route redistributed on the isdn router has a better metric, so the frame router chooses that one. Since the frame router is using the isdn router as its primary path to the destination, it won't advertise the route learned through the frame relay to the isdn router, so the floating static is never beat by the lower admin distance eigrp route there, and it's never taken out of the table. In other words:

R1----R2

+--R3--+

-- R2 is redistributing x into eigrp

-- R3 and R1 are running eigrp

-- R2 and R3 are not running eigrp

-- R2 is redistributing x into eigrp

Now, if the path to x through R2 looks better than the path through R3, from R1's perspective, it's not going to advertise that it knows how to reach x to R2--it's going to use the path through R2 to reach x, so it's going to split horizon. This means that R2 is never going to know that a path through R1 is available, and the floating static will never be compared to the eigrp external learned from R1.

If the route originated by R3 were an internal, this wouldn't happen, because the internal would beat the external (administrative distance and eigrp preference) at R1, so the route wouldn't be split horizoned towards R2.

How can you fix this? Set the metric on the route redistributed at R2 so it's always worse than the metric of the route learned from R1, and originated by R3. In other words, if you're redistributing at R3 with a default metric of 1000 1 255 1 1500, then redistribute at R3 with a default metric of 100 10000 255 1 1500, or something like that.

Russ.W

255
Views
0
Helpful
12
Replies
CreatePlease login to create content