Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Encapsulation dot1q {vlan id} ? Not available from subinterface config???

I am trying to set up a 2651to route between two vlans on a single interface. I don't get the option for the encapsulation command at the subinterface?

Here is the version info:

IOS (tm) C2600 Software (C2600-I-M), Version 12.2(5d)

Am I missing something simple? Thanks for any help.

Brian Bosveld

4 REPLIES
Community Member

Re: Encapsulation dot1q {vlan id} ? Not available from subinterf

Must be an FastEthernet interface.

Community Member

Re: Encapsulation dot1q {vlan id} ? Not available from subinterf

Yep it's a fastethernet interface.

Here is a sh run:

**********************************

Current configuration : 703 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname MDcore

!

!

ip subnet-zero

!

!

!

interface FastEthernet0/0

ip address 192.168.32.1 255.255.255.0

speed 100

full-duplex

!

interface FastEthernet0/1

no ip address

speed 100

full-duplex

!

interface FastEthernet0/1.2

description MDTest

!

interface FastEthernet0/1.3

description MD

!

ip classless

ip http server

ip pim bidir-enable

!

dialer-list 1 protocol ip permit

dialer-list 1 protocol ipx permit

snmp-server community BttyQ294gh RO

!

line con 0

line aux 0

line vty 0 4

login

!

no scheduler allocate

end

*******************************

Probably more info than is needed. Thanks for the help

Brian

Cisco Employee

Re: Encapsulation dot1q {vlan id} ? Not available from subinterf

Brian

I used the feature navigator

http://www.cisco.com/cgi-bin/Support/FeatureNav/FN.pl

I selected feature "IEEE 802.1Q VLAN Trunking". Looks like you might have to have to upgrade to 12.2(8)T

Regards,

-Prashanth

Cisco Employee

Re: Encapsulation dot1q {vlan id} ? Not available from subinterf

You need the Plus feature set. You have IP only.

380
Views
0
Helpful
4
Replies
CreatePlease to create content