Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Etherchannel between 2 cat 6500 switches

Folks,

I have 2 6500 at the core. They are connected to each other using 2 gig ports bundled together. Is this configuration right? do i need to do anything else to make sure that the trunks are stable and do not cause any spanning tree issues.

interface GigabitEthernet6/5

no ip address

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode on

!

interface GigabitEthernet6/6

no ip address

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode on

  • Other Network Infrastructure Subjects
3 REPLIES
Cisco Employee

Re: Etherchannel between 2 cat 6500 switches

The configuration is technically correct, although we recommend using channel group desirable as well as trunk desirable. This enables the use of the underlying negotiation protocols and functions as an integrity check to ensure that the partner ports are transmitting and receiving properly. This is detailed in the best practices document:

Trunking (DTP):

http://www.cisco.com/en/US/products/hw/switches/ps700/products_white_paper09186a00801b49a4.shtml#cg4

Etherchannel (PAgP):

http://www.cisco.com/en/US/products/hw/switches/ps700/products_white_paper09186a00801b49a4.shtml#cg6

All that aside, this is ultimately a design guideline. Leaving it as it is will function as a trunked etherchannel properly.

HTH,

Bobby

New Member

Re: Etherchannel between 2 cat 6500 switches

Can you please send me a sample config?

Cisco Employee

Re: Etherchannel between 2 cat 6500 switches

interface GigabitEthernet6/5

no ip address

switchport

switchport trunk encapsulation dot1q

switchport mode dynamic desirable

channel-group 1 mode desirable

!

interface GigabitEthernet6/6

no ip address

switchport

switchport trunk encapsulation dot1q

switchport mode dynamic desirable

channel-group 1 mode desirable

your best bet is to first configure the port channel, and then configure all other characteristics under the interface port-channel1 interface. The physical interfaces that are members of the channel will inherit the configuration from the port-channel interface. This way you can avoid having a config mismatch that will cause the channel to be suspended (as well as a lot of frustration).

107
Views
5
Helpful
3
Replies
This widget could not be displayed.