Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Etherchannel between two 2950 switches

I have a etherchannel defined between 2 L2 switches using LACP as shown below. The etherchannel works fine, however when I hard code speed/duplex on both ends the etherchannel fails. What is causing this behaviour?

SW02:

interface Port-channel5

interface GigabitEthernet1/0/1

switchport mode trunk

channel-group 5 mode active

interface GigabitEthernet1/0/2

switchport mode trunk

channel-group 5 mode active

-----------------------------------------------

SW02:

interface Port-channel5

interface GigabitEthernet1/0/1

switchport mode trunk

channel-group 5 mode active

interface GigabitEthernet1/0/2

switchport mode trunk

channel-group 5 mode active

------------------------------------------------

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Etherchannel between two 2950 switches

I'll "me too" leolaohoo's suspicion.

Let me caveat my post:  I am performing a bit of technical regurgitation.  I read your post and noticed you were configuring gigabit interfaces, and remembered some articles I read some time ago.  I've provided a reference below but I have not personally been able to run this to ground yet.  I offer it here for your research, and in the hopes one of the other experienced folk can chime in and either confirm or "debunk"

http://etherealmind.com/ethernet-autonegotiation-works-why-how-standard-should-be-set/

For gigabit interfaces, auto-negotiation is "required" in order to set up the master-slave timing relationship of the interfaces.

Best regards,

Ed

6 REPLIES
Hall of Fame Super Gold

Etherchannel between two 2950 switches

however when I hard code speed/duplex on both ends the etherchannel fails. What is causing this behaviour?

My guess is:  static duplex and speed?

New Member

Etherchannel between two 2950 switches

Is static speed/duplex forbidden for etherchannel ports?

Hall of Fame Super Gold

Etherchannel between two 2950 switches

On the contrary.  Why would you want to configure the speed and duplex setting?

Remember, etherchannel must've gone down while you were configuring the port and speed one-interface-at-at-time. 

Re: Etherchannel between two 2950 switches

I'll "me too" leolaohoo's suspicion.

Let me caveat my post:  I am performing a bit of technical regurgitation.  I read your post and noticed you were configuring gigabit interfaces, and remembered some articles I read some time ago.  I've provided a reference below but I have not personally been able to run this to ground yet.  I offer it here for your research, and in the hopes one of the other experienced folk can chime in and either confirm or "debunk"

http://etherealmind.com/ethernet-autonegotiation-works-why-how-standard-should-be-set/

For gigabit interfaces, auto-negotiation is "required" in order to set up the master-slave timing relationship of the interfaces.

Best regards,

Ed

New Member

Etherchannel between two 2950 switches

Thank You very much for the link.

Now I have a 100Mbps switch in production which will be replaced with a Gbps switch. In the current switch, at several switch ports and other network devices (router/firewall) speed/duplex is hard coded to 100Mbps.

What should I do when I replace the switch with new Gbps? Should I set Autonegotiation at both the ends?

Re: Etherchannel between two 2950 switches

Thank you for the rating.

Regarding your replacement scenario, I'll give the standard engineering answer ("it depends"), but actually follow up with something I hope is more helpful.    I'm sincerely interested to see other's viewpoint on this as well, as it has changed over the years.

Many years ago (let's say a decade) I ran into problems with some devices not being able to auto-negotiate properly.  There was a tendancy for devices to fail or negotiate to half-duplex mode when a full-duplex connection was warranted.  At the time, the problems we experienced were mainly with traffic shaping devices and some other gear.  There were others using fixed settings as a standard practice, and we did the same since we had verifiable issues.

Fast forward to now.  I personally have not experienced auto-negotiation problems in a long time and am reading more from others in the field that auto-negotiation is the way to go (such as from the link provided).  Indeed, I've now run into the opposite scenario: I had a particular situation where a link between two devices defaulted to half-duplex EVEN THOUGH they were both set to 100/Full.  It turned out to be a race condition between a device and a Cisco router...the other device booted faster, didn't see anything on the link, and "helpfully" dropped down to half-duplex.  I confirmed the issue with the device vendor, who recommended setting ports to auto-negotiate as the fix (their software would not be updated for a bit of time).

I would recommend auto-negotiate as a standard practice, with the exception of areas where you have encountered specific problems.  Those latter cases should be caught through your pre-deployment testing, and discussed with the respective vendors so that you fully understand why the devices are behaving the way they are so that the proper mitigation measures can be put in place (i.e. - It is going to act the same way every time, and you can work with that).

Good luck!  -Ed

847
Views
0
Helpful
6
Replies
CreatePlease login to create content