Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Etherchannel issue on tunnel

i have a VPN tunnel between two of our offices. The links are provided by two service providers .Both links are 45 Mbps ethernet hands off. I have created ether channel between the two links.The connection is like

PIX ---- L3 switch1---Service providers----switch2----- PIX2. Port channel is working fine as a 90 Mbps link. But i can see in my MRTG that always one link is in use . other link trafic is in mere Kbps. Switch port channel config is as follows:

Switch 1:

vlan 10

name MAN_CONNECTION

!

!

interface Port-channel10

switchport trunk encapsulation dot1q

switchport trunk native vlan 10

switchport mode trunk

!

!

interface FastEthernet1/0/2

description "TTSL"

switchport trunk encapsulation dot1q

switchport trunk native vlan 10

switchport mode trunk

load-interval 30

duplex full

speed 100

channel-group 10 mode desirable non-silent

!

interface FastEthernet1/0/3

description "Airtel"

switchport trunk encapsulation dot1q

switchport trunk native vlan 10

switchport mode trunk

load-interval 30

duplex full

speed 100

channel-group 10 mode desirable non-silent

Switch 2:

vlan 10

name MAN_CONNECTION

!

!

interface Port-channel1

!

interface Port-channel10

switchport trunk encapsulation dot1q

switchport trunk native vlan 10

switchport mode trunk

logging event bundle-status

!

!

interface FastEthernet1/0/2

description "TTSL"

switchport trunk encapsulation dot1q

switchport trunk native vlan 10

switchport mode trunk

load-interval 30

duplex full

speed 100

channel-group 10 mode desirable non-silent

!

interface FastEthernet1/0/3

description "Airtel"

switchport trunk encapsulation dot1q

switchport trunk native vlan 10

switchport mode trunk

load-interval 30

duplex full

speed 100

channel-group 10 mode desirable non-silent

Can some body give a clue ,why only one link is loaded. both the links are 45 MBps.

Thank you

Ullas Upendran

7 REPLIES
Silver

Re: Etherchannel issue on tunnel

Load sharing is based on L2 information.

source address is PIX1

destination address is PIX2

XOR load-balances on this information. Because the source/destination address is the same for all frames no real load-balancing is performed.

http://www.cisco.com/en/US/tech/tk389/tk213/technologies_tech_note09186a0080094714.shtml

--Leon

New Member

Re: Etherchannel issue on tunnel

Thanks leon. But the switch i have on both sides are Layer 3 and is doing routing also .

the full switch config is as follows.

hostname MAN-Ulsoor-3750

!

aaa new-model

aaa authentication login default group tacacs+ local

aaa authentication enable default group tacacs+ enable

aaa accounting exec default start-stop group tacacs+

aaa accounting commands 1 default start-stop group tacacs+

aaa accounting commands 15 default start-stop group tacacs+

ip routing

!

vtp domain PIC

vtp mode transparent

!

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

!

!

vlan 10

name MAN_CONNECTION

!

!

interface Port-channel1

!

interface Port-channel10

switchport trunk encapsulation dot1q

switchport trunk native vlan 10

switchport mode trunk

logging event bundle-status

!

interface FastEthernet1/0/1

switchport trunk encapsulation dot1q

switchport trunk native vlan 10

switchport mode trunk

shutdown

!

interface FastEthernet1/0/2

description "TTSL"

switchport trunk encapsulation dot1q

switchport trunk native vlan 10

switchport mode trunk

load-interval 30

duplex full

speed 100

channel-group 10 mode desirable non-silent

!

interface FastEthernet1/0/3

description "Airtel"

switchport trunk encapsulation dot1q

switchport trunk native vlan 10

switchport mode trunk

load-interval 30

duplex full

speed 100

channel-group 10 mode desirable non-silent

!

interface FastEthernet1/0/23

description *** PIX-Ulsoor Standby ***

duplex full

speed 100

!

interface FastEthernet1/0/24

description *** PIX-Ulsoor Active ***

duplex full

speed 100

!

interface GigabitEthernet1/0/1

!

interface GigabitEthernet1/0/2

!

interface GigabitEthernet1/1/1

!

interface GigabitEthernet1/1/2

!

interface Vlan1

ip address 10.253.253.27 255.255.255.248

!

interface Vlan10

ip address 10.253.253.18 255.255.255.248

!

ip default-gateway 10.253.253.25

ip classless

ip route 0.0.0.0 0.0.0.0 10.253.253.25

ip route 10.253.253.0 255.255.255.248 10.253.253.17

ip route 10.253.253.8 255.255.255.248 10.253.253.17

ip route 161.85.28.0 255.255.254.0 10.253.253.17

ip route 161.85.97.0 255.255.255.0 10.253.253.17

ip route 161.85.99.0 255.255.255.0 10.253.253.17

ip route 161.85.102.0 255.255.255.0 10.253.253.17

ip route 161.85.103.0 255.255.255.0 10.253.253.17

no ip http server

ip tacacs source-interface Vlan1

!

Even if the sourse ip is of the switch ,load balancing is not possible? As my second link is always idle ,is there any way i can utilise it?

Thanks

Ullas

Re: Etherchannel issue on tunnel

ullas,

i think actully load balancing work lik this...

Load distribution is based on the source-MAC address of the incoming packet. Packets from different hosts use different ports in the channel, but packets from the same host use the same port in the channel.

When src-mac is used, load distribution based on the source and destination IP address is also enabled. For all IP traffic being routed, the switch chooses a port for transmission based on the source and destination IP address. Packets between two IP hosts always use the same port for packet transmission, but packets between any other pair of hosts might use a different transmission port.

Load distribution is based on the destination-host MAC address of the incoming packet. Packets to the same destination are sent on the same port, but packets to different destinations are sent on different ports in the channel.

may this will help you in configuration...

rate this post if it helps

regards

Devang

New Member

Re: Etherchannel issue on tunnel

Hi,

This command is suppose to allow for source and destination IP loadbalancing on a etherchannel.

Router(config)#port-channel load-balance src-dst-ip

Use

Router# show etherchannel load-balance

to view what type loadbalancing is in use.

Richard

New Member

Re: Etherchannel issue on tunnel

hi richard

the out put shows

MAN-Ulsoor-3750#sh etherchannel load-balance

Source MAC address

MAN-Ulsoor-3750#

thanks ullas

Silver

Re: Etherchannel issue on tunnel

Please refer to the documentation of your 3750 switch. See the Etherchannel documentation on Load Balancing:

http://www.cisco.com/univercd/cc/td/doc/product/lan/cat3750/12225see/scg/swethchl.htm#wp1275731

The problem is that you have a static source/destination which makes load-balancing accross an etherchannel difficult.

--Leon

New Member

Re: Etherchannel issue on tunnel

Hi all

i configured etherchannel load balancing with source ip on both the switches . Now i can see the traffic is evenly going in both the links.Thanks a lot

Ullas

213
Views
18
Helpful
7
Replies
CreatePlease to create content