Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

EtherChannel (Unknown duplex, Unknown Speed, unknown 0)

Hi..

I want to connect Cat4506 (Version 12.1(13)EW) and Cat 6509 (Version 12.1(8b)E13) over two gigabit fiber ethernet links. I configured etherchannel like this:

4506#sh run

interface Port-channel1

switchport

switchport trunk encapsulation isl

switchport mode trunk

!

interface GigabitEthernet1/1

switchport trunk encapsulation isl

switchport mode trunk

channel-group 1 mode on

!

interface GigabitEthernet1/2

switchport trunk encapsulation isl

switchport mode trunk

channel-group 1 mode on

6509#sh run

interface Port-channel1

no ip address

switchport

switchport trunk encapsulation isl

switchport mode trunk

!

interface GigabitEthernet3/1

no ip address

switchport

switchport trunk encapsulation isl

switchport mode trunk

channel-group 1 mode on

!

interface GigabitEthernet3/2

no ip address

switchport

switchport trunk encapsulation isl

switchport mode trunk

channel-group 1 mode on

On 4506 when i issue this command :

4506#show interfaces port-channel 1

Port-channel1 is up, line protocol is up (connected)

Hardware is EtherChannel, address is 000c.850e.a780 (bia 000c.850e.a780)

MTU 1500 bytes, BW 2000000 Kbit, DLY 10 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Unknown duplex, Unknown Speed, unknown 0

output flow-control is unsupported, input flow-control is unsupported

Members in this channel: Gi1/1 Gi1/2

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:01, output never, output hang never

Last clearing of "show interface" counters 00:17:59

Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 2000 bits/sec, 3 packets/sec

5 minute output rate 38000 bits/sec, 17 packets/sec

4190 packets input, 436595 bytes, 0 no buffer

Received 4067 broadcasts (0 multicast)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 input packets with dribble condition detected

20529 packets output, 5859682 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier

0 output buffer failures, 0 output buffers swapped out

What is the reason of "Unknown duplex, Unknown Speed, unknown 0"

Note:When i issue the same command on 6509 there is no problem:

6509#sh interfaces port-channel 1

Port-channel1 is up, line protocol is up

Hardware is EtherChannel, address is 0009.11f3.88e8 (bia 0009.11f3.88e8)

MTU 1500 bytes, BW 2000000 Kbit, DLY 10 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Full-duplex, 1000Mb/s

Members in this channel: Gi3/1 Gi3/2

ARP type: ARPA, ARP Timeout 04:00:00

Last clearing of "show interface" counters never

Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue :0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

28226 packets input, 7157872 bytes, 0 no buffer

Received 27461 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 input packets with dribble condition detected

6767 packets output, 717312 bytes, 0 underruns

0 output errors, 0 collisions, 1 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier

0 output buffer failures, 0 output buffers swapped out

2 REPLIES
Bronze

Re: EtherChannel (Unknown duplex, Unknown Speed, unknown 0)

It might be a bug with Cisco IOS 12.1(13)EW. Try to upgrade to 12.2(14)SY2 and see the output. And also because of port channel is the virtual interface, I think that output is not so important and hope your setup is working fine now.

New Member

Re: EtherChannel (Unknown duplex, Unknown Speed, unknown 0)

Did it channel? I would also like to know what the physical interfaces were configured like. Are they in the automatic duplexing and speed mode? This appears to be recommended even though the gig ports are 1000 full, there are additional benefits of auto negotiating and the negotiation is really a sham since the ports are 1000 full no-ifs-no-buts; in reality negotiation takes no time. See link below:

http://www.cisco.com/en/US/products/hw/switches/ps700/products_tech_note09186a00800a7af0.shtml#auto_neg_valid

472
Views
0
Helpful
2
Replies
CreatePlease to create content