Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Etherchannel

Dear friend

It concerns an internetworking solution that we have configured for an electrical company constituted with 3 buildings, A, B, C. In order to link them we have used 3 switchs : catalyst 6509 on Bloc A, catalyst 6006 on Bloc B, catalyst 3550-12G on Bloc C. In each floor there is different combination of catalyst type 3524 XL and 3548 XL with 2 GBIC ports. (look at the figure joined)

Would you give us advice in order to found an optimal combination of parameters for the activation of EtherChannel service between the 3 core switchs and even between each core switch and it’s switch’s floor.

I’ve just activated this service but unfortunately I’ve discovered this error : when I execute a ping between each core switch and it’s switch’s floor we obtain 100 % of success rate. But when I execute a ping between a hosts of the same or different floors we obtain only 65% of success rate.

Nb :

The rate of loss of the ping disappears when I disconnect the second link of EtherChannel

Thank you for the response.

Config catalyst 3550-12G :

DG-C-0-Cat3550#sh conf

Using 2457 out of 32768 bytes

!

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname DG-C-0-Cat3550

!

enable secret 5 --moderator edit--

!

ip subnet-zero

no ip finger

!

!

!

!

interface Port-channel1

switchport mode access

no ip address

snmp trap link-status

!

--More--

!

interface Port-channel2

switchport mode access

no ip address

snmp trap link-status

!

interface Port-channel3

switchport mode access

no ip address

snmp trap link-status

!

interface Port-channel10

switchport mode access

no ip address

snmp trap link-status

!

interface Port-channel30

switchport mode access

no ip address

snmp trap link-status

!

interface GigabitEthernet0/1

switchport mode access

no ip address

--More--

channel-group 2 mode on

!

interface GigabitEthernet0/2

switchport mode access

no ip address

snmp trap link-status

channel-group 2 mode on

!

interface GigabitEthernet0/3

switchport mode access

no ip address

snmp trap link-status

channel-group 3 mode on

!

interface GigabitEthernet0/4

switchport mode access

no ip address

snmp trap link-status

channel-group 3 mode on

!

interface GigabitEthernet0/5

switchport mode access

no ip address

snmp trap link-status

--More--

snmp trap link-status

channel-group 1 mode on

!

interface GigabitEthernet0/6

switchport mode access

no ip address

snmp trap link-status

channel-group 1 mode on

!

interface GigabitEthernet0/7

switchport trunk encapsulation isl

switchport mode access

no ip address

snmp trap link-status

channel-group 30 mode on

!

interface GigabitEthernet0/8

no ip address

snmp trap link-status

!

interface GigabitEthernet0/9

switchport mode access

no ip address

snmp trap link-status

--More--

snmp trap link-status

!

interface GigabitEthernet0/10

no ip address

snmp trap link-status

!

interface GigabitEthernet0/11

no ip address

snmp trap link-status

!

interface GigabitEthernet0/12

no ip address

snmp trap link-status

!

interface Vlan1

ip address 10.1.1.245 255.255.224.0

!

ip classless

ip http server

!

--moderator edit--

ip http server

!

--moderator edit--

!

line con 0

transport input none

line vty 0 4

password 7 --moderator edit--

login

line vty 5 15

password 7 --moderator edit--

login

!

end

-------------------------------------------------------------------------------------------------

Config catalyst 6509 :

DG-A-0-Cat6509> (enable) sh conf

This command shows non-default configurations only.

Use 'show config all' to show both default and non-default configurations.

..............

..................

..................

..................

..................

..

begin

!

# ***** NON-DEFAULT CONFIGURATION *****

!

!

#time: Wed Aug 7 2002, 06:07:15

!

--More--

!

#version 6.3(3)

!

set password --moderator edit--

set enablepass --moderator edit--

!

#system

set system name DG-A-0-Cat6509

!

#!

#snmp

--moderator edit--

--More--

set snmp trap enable syslog

set snmp trap enable system

!

#vtp

set vtp mode transparent

set vlan 1 name default type ethernet mtu 1500 said 100001 state active

set vlan 1002 name fddi-default type fddi mtu 1500 said 101002 state active

set vlan 1004 name fddinet-default type fddinet mtu 1500 said 101004 state activ

e stp ieee

set vlan 1005 name trnet-default type trbrf mtu 1500 said 101005 state active st

p ibm

set vlan 1003 name token-ring-default type trcrf mtu 1500 said 101003 state acti

ve mode srb aremaxhop 7 stemaxhop 7 backupcrf off

!

#ip

set interface sc0 1 10.1.1.191/255.255.224.0 10.1.31.255

set ip route 0.0.0.0/0.0.0.0 10.1.1.192

!

#spantree

#vlan <VlanId>

!

#set boot command

set boot config-register 0x2

--More--

set boot config-register 0x2

set boot system flash bootflash:cat6000-sup2.6-3-3.bin

!

#port channel

set port channel 3/1 1

set port channel 3/2 2

set port channel 3/3 3

set port channel 3/4 4

set port channel 3/5 5

set port channel 3/6 6

set port channel 3/7 7

set port channel 3/8 8

set port channel 3/9 9

set port channel 3/10 10

set port channel 4/3 13

set port channel 4/4 14

set port channel 4/5 15

set port channel 4/6 16

set port channel 4/7 17

set port channel 4/8 18

set port channel 4/1 21

set port channel 4/2 22

set port channel 4/10 23

set port channel 4/9 24

--More--

set port channel 4/9 24

set port channel 3/16 30

set port channel 4/16 31

set port channel 3/11 156

!

# default port status is enable

!

!

#module 1 : 2-port 1000BaseX Supervisor

set port trap 1/1-2 enable

set udld enable 1/1

!

#module 2 : 2-port 1000BaseX Supervisor

set port trap 2/1-2 enable

!

#module 3 : 16-port 1000BaseX Ethernet

set port trap 3/1-16 enableset port channel 4/9 24

set port channel 3/16 30

set port channel 4/16 31

set port channel 3/11 156

!

# default port status is enable

!

!

#module 1 : 2-port 1000BaseX Supervisor

set port trap 1/1-2 enable

set udld enable 1/1

!

#module 2 : 2-port 1000BaseX Supervisor

set port trap 2/1-2 enable

!

#module 3 : 16-port 1000BaseX Ethernet

set port trap 3/1-16 enable

set trunk 3/1 desirable isl 1-1005,1025-4094

set trunk 3/2 desirable isl 1-1005,1025-4094

set trunk 3/3 desirable isl 1-1005,1025-4094

set trunk 3/4 desirable isl 1-1005,1025-4094

set trunk 3/5 desirable isl 1-1005,1025-4094

set trunk 3/6 desirable isl 1-1005,1025-4094

set trunk 3/7 desirable isl 1-1005,1025-4094

--More--

set trunk 3/1 desirable isl 1-1005,1025-4094

set trunk 3/2 desirable isl 1-1005,1025-4094

set trunk 3/3 desirable isl 1-1005,1025-4094

set trunk 3/4 desirable isl 1-1005,1025-4094

set trunk 3/5 desirable isl 1-1005,1025-4094

set trunk 3/6 desirable isl 1-1005,1025-4094

set trunk 3/7 desirable isl 1-1005,1025-4094

--More--

set trunk 3/7 desirable isl 1-1005,1025-4094

set trunk 3/8 desirable isl 1-1005,1025-4094

set trunk 3/9 desirable isl 1-1005,1025-4094

set trunk 3/10 desirable isl 1-1005,1025-4094

set trunk 3/11 on isl 1-1005,1025-4094

set trunk 3/16 desirable isl 1-1005,1025-4094

set port channel 3/1-11 mode on

set port channel 3/16 mode off

!

#module 4 : 16-port 1000BaseX Ethernet

set port trap 4/1-16 enable

set trunk 4/1 desirable isl 1-1005,1025-4094

set trunk 4/2 desirable isl 1-1005,1025-4094

set trunk 4/3 desirable isl 1-1005,1025-4094

set trunk 4/4 desirable isl 1-1005,1025-4094

set trunk 4/5 desirable isl 1-1005,1025-4094

set trunk 4/6 desirable isl 1-1005,1025-4094

set trunk 4/7 desirable isl 1-1005,1025-4094

set trunk 4/8 desirable isl 1-1005,1025-4094

set trunk 4/9 desirable isl 1-1005,1025-4094

set trunk 4/10 desirable isl 1-1005,1025-4094

set trunk 4/16 desirable isl 1-1005,1025-4094

set port channel 4/1-10 mode on

set port channel 4/16 mode off

--More--

set trunk 3/7 desirable isl 1-1005,1025-4094

set trunk 3/8 desirable isl 1-1005,1025-4094

set trunk 3/9 desirable isl 1-1005,1025-4094

set trunk 3/10 desirable isl 1-1005,1025-4094

set trunk 3/11 on isl 1-1005,1025-4094

set trunk 3/16 desirable isl 1-1005,1025-4094

set port channel 3/1-11 mode on

set port channel 3/16 mode off

!

#module 4 : 16-port 1000BaseX Ethernet

set port trap 4/1-16 enable

set trunk 4/1 desirable isl 1-1005,1025-4094

set trunk 4/2 desirable isl 1-1005,1025-4094

set trunk 4/3 desirable isl 1-1005,1025-4094

set trunk 4/4 desirable isl 1-1005,1025-4094

set trunk 4/5 desirable isl 1-1005,1025-4094

set trunk 4/6 desirable isl 1-1005,1025-4094

set trunk 4/7 desirable isl 1-1005,1025-4094

set trunk 4/8 desirable isl 1-1005,1025-4094

set trunk 4/9 desirable isl 1-1005,1025-4094

set trunk 4/10 desirable isl 1-1005,1025-4094

set trunk 4/16 desirable isl 1-1005,1025-4094

set port channel 4/1-10 mode on

set port channel 4/16 mode off

--More--

set trunk 4/5 desirable isl 1-1005,1025-4094

set trunk 4/6 desirable isl 1-1005,1025-4094

set trunk 4/7 desirable isl 1-1005,1025-4094

set trunk 4/8 desirable isl 1-1005,1025-4094

set trunk 4/9 desirable isl 1-1005,1025-4094

set trunk 4/10 desirable isl 1-1005,1025-4094

set trunk 4/16 desirable isl 1-1005,1025-4094

set port channel 4/1-10 mode on

set port channel 4/16 mode off

!

#module 5 : 0-port Switch Fabric Module

!

#module 6 empty

!

#module 7 empty

!

#module 8 empty

!

#module 9 empty

!

#module 15 : 1-port Multilayer Switch Feature Card

!

#module 16 : 1-port Multilayer Switch Feature Card

end

DG-A-0-Cat6509> (enable)

-------------------------------------------------------------------------------------------------

Config catalyst 6006 :

DG-B-1-Cat6006> (enable) sh conf

This command shows non-default configurations only.

Use 'show config all' to show both default and non-default configurations.

.........

.................

.................

.................

..

begin

!

# ***** NON-DEFAULT CONFIGURATION *****

!

!

#time: Wed Aug 7 2002, 06:52:01

!

#version 5.5(1)

!

set password --moderator edit--

--More--

set enablepass --moderator edit--

!

#system

set system name DG-B-1-Cat6006

set system highavailability enable

set system highavailability versioning enable

!

#!

#snmp

--moderator edit--

!

--More--

set vlan 1 name default type ethernet mtu 1500 said 100001 state active

set vlan 1002 name fddi-default type fddi mtu 1500 said 101002 state active

set vlan 1004 name fddinet-default type fddinet mtu 1500 said 101004 state activ

e stp ieee

set vlan 1005 name trnet-default type trbrf mtu 1500 said 101005 state active st

p ibm

set vlan 1003 name token-ring-default type trcrf mtu 1500 said 101003 state acti

ve mode srb aremaxhop 7 stemaxhop 7 backupcrf off

!

#ip

set interface sc0 1 10.1.1.220/255.255.224.0 10.1.31.255

set ip route 0.0.0.0/0.0.0.0 10.1.1.192

!

#set boot command

set boot config-register 0x2

set boot system flash bootflash:cat6000-sup.5-5-1.bin

!

#port channel

set port channel 3/1 1

set port channel 3/3 2

set port channel 3/8 3

set port channel 3/2 4

set port channel 3/7 5

--More--

set port channel 3/7 5

set port channel 3/9 6

set port channel 3/6 7

set port channel 4/6 8

set port channel 3/5 9

set port channel 4/5 10

set port channel 3/4 11

set port channel 4/4 12

set port channel 4/3 14

set port channel 4/2 15

set port channel 4/9 16

set port channel 4/1 17

set port channel 4/8 18

set port channel 4/7 19

set port channel 1/1-2 45

set port channel 3/15-16 248

set port channel 3/10-12 253

set port channel 3/13-14 254

set port channel 4/10-12 255

set port channel 4/13-16 256

!

# default port status is enable

!

!

--More--

#module 1 : 2-port 1000BaseX Supervisor

set port trap 1/1-2 enable

!

#module 2 empty

!

#module 3 : 16-port 1000BaseX Ethernet

set port trap 3/1-16 enable

set port membership 3/1-16 static

set trunk 3/1 desirable isl 1-1005

set trunk 3/2 desirable isl 1-1005

set trunk 3/3 desirable isl 1-1005

set trunk 3/4 desirable isl 1-1005

set trunk 3/5 desirable isl 1-1005

set trunk 3/6 desirable isl 1-1005

set trunk 3/7 desirable isl 1-1005

set trunk 3/8 desirable isl 1-1005

set trunk 3/9 desirable isl 1-1005

set trunk 3/15 desirable isl 1-1005

set trunk 3/16 desirable isl 1-1005

set port channel 3/1-9 mode on

set port channel 3/15-16 mode off

!

#module 4 : 16-port 1000BaseX Ethernet

set port trap 4/1-16 enable

--More--

set port channel 3/15-16 mode off

!

#module 4 : 16-port 1000BaseX Ethernet

set port trap 4/1-16 enable

set port membership 4/1-16 static

set trunk 4/1 desirable isl 1-1005

set trunk 4/2 desirable isl 1-1005

set trunk 4/3 desirable isl 1-1005

set trunk 4/4 desirable isl 1-1005

set trunk 4/5 desirable isl 1-1005

set trunk 4/6 desirable isl 1-1005

set trunk 4/7 desirable isl 1-1005

set trunk 4/8 desirable isl 1-1005

set trunk 4/9 desirable isl 1-1005

set port channel 4/1-9 mode on

!

#module 5 empty

!

#module 6 empty

!

#module 15 : 1-port Multilayer Switch Feature Card

!

#module 16 empty

end

DG-B-1-Cat6006> (enable)

--------------------------------------------------------------------------------------------------

Config catalyst 3524/48 XL for floors on bulding A et B :

DG-A-0-Cat3548#sh conf

Using 2388 out of 32768 bytes

!

version 12.0

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname DG-A-0-Cat3548

!

enable secret 5 $1$npYH$B3D5vseUGlg.TzXp/p0dp1

!

!

!

!

!

!

ip subnet-zero

!

!

!

interface FastEthernet0/1

!

--More--

!

interface FastEthernet0/2

!

interface FastEthernet0/3

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

--More--

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

--More--

!

interface FastEthernet0/25

!

interface FastEthernet0/26

!

interface FastEthernet0/27

!

interface FastEthernet0/28

!

interface FastEthernet0/29

!

interface FastEthernet0/30

!

interface FastEthernet0/31

!

interface FastEthernet0/32

!

interface FastEthernet0/33

!

interface FastEthernet0/34

!

interface FastEthernet0/35

!

interface FastEthernet0/36

--More--

interface FastEthernet0/36

!

interface FastEthernet0/37

!

interface FastEthernet0/38

!

interface FastEthernet0/39

!

interface FastEthernet0/40

!

interface FastEthernet0/41

!

interface FastEthernet0/42

!

interface FastEthernet0/43

!

interface FastEthernet0/44

!

interface FastEthernet0/45

!

interface FastEthernet0/46

!

interface FastEthernet0/47

!

--More--

!

interface FastEthernet0/48

!

interface GigabitEthernet0/1

port group 10

!

interface GigabitEthernet0/2

port group 10

!

interface VLAN1

ip address 10.1.1.195 255.255.224.0

no ip directed-broadcast

no ip route-cache

!

ip default-gateway 10.1.1.192

cdp timer 5

cdp holdtime 10

--moderator edit--

--More--

cdp holdtime 10

--moderator edit--

!

line con 0

transport input none

stopbits 1

line vty 0 4

password 7 --moderator edit--

login

line vty 5 15

password 7 --moderator edit--

login

!

end

--------------------------------------------------------------------------------------------------

2 REPLIES
New Member

Re: Etherchannel

I can only suspect some STP issue here. Just check if you are creating any loop here by not running STP on some ports.

New Member

Re: Etherchannel

This may not solve your problem, but it would be a basic design approach that would make it simpler to trouble shoot what is not working correctly.

Since you are just showing the non-default configuration, I assume you made no modifications to Spanning Tree Protocol. If that is the case, then the bridge with the lowest MAC address was elected the root bridge for that VLAN. Not knowing where the root bridge is, you cannot predict/design which ports will be blocking and which ports will be forwarding anywhere that redundant links occur.

In summary, pick a root bridge, assign it as root, use Root Guard, to prevent someone from adding a switch with a lower priority and accidently changeing the root bridge.

Have you confirmed that the Etherchannel link came up properly from both ends. Confirm that you see the bundle from both switches. When we setup an etherchannel, we use desirable and silent on both sides.

You should also consider UDLD for all of your links between switches(especially fiber), I have recently seen a situation where not having that turned on, wrecked havoc on a very large core due to instability in the routing protocol when one switch had an uplink flapping(physical layer problem).

HTH

250
Views
0
Helpful
2
Replies
CreatePlease to create content