Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Extending vlans from the 6509 to 2950

I currently have (2) 6509's each has an MFSC card and (2) 48 port blades. All the ports on both blades are broken up into seperate vlans. There is an ISL trunk between the (2) 6509's. I need to extend the vlans out from the 6509's to (2) 2950 switches respectably, one from each of the 6509's and be able to trunk the 2950's together. Here is a small diag.

------- isl trunk -------

6509--------------------6509

------- --------

- -

- trunk? - trunk?

- -

------- isl trunk? ---------

2950------------------- 2950

------- ---------

I am having problems with the config, hell I am having problems just gettin started. I could really use some help. I have all the config's if you need them.

2 REPLIES
Community Member

Re: Extending vlans from the 6509 to 2950

Most trouble that I have seen posted on this board with ISL and 802.1q questions has to do with the 2950 config.

Make sure you have changed the management VLAN on the 2950 from the default VLAN 1 and then put the IP address on the new VLAN interface. It looks like you already understand that trunking needs to be enabled on those ports that will pass multi-VLAN traffic.

Those are the easy things to check.

Community Member

Re: Extending vlans from the 6509 to 2950

2950's only do dot1q trunks.

Configure a dot1q trunk between a port on the 6509 and a port on the 2950.

Make sure the trunk is a dot1q trunk.

Here is a 2950 example switch config and trunk link ..trimmed down:

Vlan 2 is management, vlan 10 is desktops:

Example:

vlan database

!

vtp domain YourVTPdomainname.org

vtp client

!

vlan 2 name Management_Vlan

!

vlan 10 name Your_workstations

!

interface FastEthernet0/1

switchport access vlan 10

switchport mode access

spanning-tree portfast

!

interface FastEthernet0/2

switchport access vlan 10

switchport mode access

spanning-tree portfast

!

Interfaces................................

!

interface GigabitEthernet0/1

switchport access vlan 2

switchport trunk encapsulation dot1q

switchport trunk native vlan 2

switchport mode trunk

switchport nonegotiate

switchport trunk allowed vlan 1-2,10,1002-1005

!

interface Vlan1

no ip address

no ip route-cache

shutdown

!

interface Vlan2

ip address 10.1.2.150 255.255.255.0

no ip route-cache

no shutdown

end

Cat OS sample config:

#module 5 : 12-port 100BaseFX MM Ethernet

set vlan 2 5/1

!

clear trunk 5/1 1,3-9,11-1005

set trunk 5/2 desirable dot1q 2,10

The above sample creates a trunk between on Cat2950 and a second switch with Cat OS

125
Views
0
Helpful
2
Replies
CreatePlease to create content