Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Final HSRP +Config Between 2 6509

Hi Expert

I Want to setup the HSRP Between the 2 Dist 6509-SUP1.PS Have a look to all my config in the Attachment!ps focus in the etherchannel config(L2)!etherchannel Config(L3) TOward the core!the HSRP Config in all VLANs!also the root primary & the root secondery!ps find where my mistake?advise to the optimum config!what u advise me!My config its correct?PS Help!PS HAVE A LOOK TO THE the Attachment!

10xs for ur time to help.

37 REPLIES

Re: Final HSRP +Config Between 2 6509

Look okay to me, 6509-1 is the HSRP and Active and the root primary for the vlans specified. Looks okay.

Please rate all posts.

New Member

Re: Final HSRP +Config Between 2 6509

Hi

10xs for ur reply!

1)what about the default route in my config on the 2 6509?do i need to assign 2 default route on the 2 switch pointing to the 2 L3 port-chanel?

2)what about the 6509-2

3)in my scope in the DHCP Server,the virtual ip in the HSRP;Sould be the default gateway for each specified specified vlans

4)do i need an ip-default gateway on each switch?

waiting ur reply

New Member

Re: Final HSRP +Config Between 2 6509

Hi

PS;Does any one reply here!

10xs

New Member

Re: Final HSRP +Config Between 2 6509

Hi!

can can anyone help on this!

10xs

Re: Final HSRP +Config Between 2 6509

Hi!

For all your VLANs, I think you should be giving different IPs, you have given the same IP as the one in 6509-1 to the corresponding VLAN in the 2nd switch. This would result in an IP conflict. For example you have given the IP - 10.10.3.2 to the VLAN 3 in both the switches!!! Give 10.10.3.2 to VLAN 3 in SW1 and 10.10.3.3 to VLAN 3 in SW2 with the standby IP being 10.10.3.1. Else I dont think that your HSRP is going to work!!!

Hope this helps.

Regards,

AbhisheK

Please rate all posts!!!

Silver

Re: Final HSRP +Config Between 2 6509

Hi Abhishek, you are correct. I overlooked it. :(

physical IP should be different, virtual IP should be the same.

Silver

Re: Final HSRP +Config Between 2 6509

Could you tell why require 2 deafult routes ? You actually are pointing to the same address. Unless there is another gatewat, and you need more default route.

What I find you just configure 6509-2 as the non-preferred HSRP gateway. What I suggest you can load-sharing the traffic by setting two VLANs to use -1 as primary and two VLANs use -2 as primary.

Yes, the virtual IP is the deafult gateway of the DHCP server which located at the correponding VLAN.

What I suggest to enable the dynamic routing protocol in the subnet of 172.16.20.x. This is because there may be issue of the return path from 172.16.20.100 to 6509-1 & -2. At least not to use default route / gateway at 172.16.20.100 and point back to the 6509-1 & -2. Otherwise, it will create routing loop.

New Member

Re: Final HSRP +Config Between 2 6509

sorry in vlan was an error in typing.but u said that the HSRP Didn't work

10xs

New Member

Re: Final HSRP +Config Between 2 6509

Hi

if i Give 10.10.3.1 to VLAN 3 in SW1 and 10.10.3.2 to VLAN 3 in SW2 with the standby IP being 10.10.3.3. this let HSRP GOING TO WORK?

10XS

Re: Final HSRP +Config Between 2 6509

Hi,

Yes then its going to work. The physical IP has to be different and the virtual IP has to be same.

Hope it helps.

Regards,

AbhisheK

Please rate all posts!

Silver

Re: Final HSRP +Config Between 2 6509

Please let us know the result of whole design if the HSRP works. i.g. default gateway, routing, etc. Thx.

New Member

Re: Final HSRP +Config Between 2 6509

Hi Jacky!

can list a simple config about ur suggestion

+EIGRP ENABLE WITH SUMMURY TOWARD THE CORE;

+ HOW TO LAD TRAFFIC?

10XS

Silver

Re: Final HSRP +Config Between 2 6509

New Member

Re: Final HSRP +Config Between 2 6509

Jacky sorry!

i mean how can i load traffic between Vlans?simple config if u can

10xs

Silver

Re: Final HSRP +Config Between 2 6509

IC. Just reading an article that referred by other Netpro. You can also consider GLBP.

http://www.cisco.com/en/US/products/ps6600/prod_presentation0900aecd801790a3.html

For the HSRP config., your new configuration is fine and just need to add another HSRP group w/ another virtual IP address (e.g. .4). Then you allocate the LAN user to two groups, one point to 1st HSRP group V.IP, another group point to 2nd HSRP group V.IP. Please read the link and it mentioned the operation.

Re: Final HSRP +Config Between 2 6509

Hi!

As i mentioned in the second post of mine, if you need to load-balance then I think you should go for GLBP. Whereas if your only need is redundancy for fail-over, then HSRP is good enough.

You'll find the links for GLBP and HSRP in the above posts of mine.

Hope this helps.

Regards,

AbhisheK

Please rate all posts!!!

New Member

Re: Final HSRP +Config Between 2 6509

Hi

friends ya rit can i use GLBP;But my 6509 its Sup1!

10xs

Silver

Re: Final HSRP +Config Between 2 6509

Please check the release notes of your Sup OS to determine the possibility to use GLBP. For a simple initial setup, I suggest to try multi-HSRP first then GLBP.

Re: Final HSRP +Config Between 2 6509

Hi,

Certainly you can use GLBP!!! And its not difficult to configure either. Almost the same way as HSRP.

To check whether your switch supports it or not, enter the following commands:

- enable

- configure terminal

- interface vlan 'id'

- glbp ?

If the prompt says "unrecognized command", then your switch doesnt support GLBP. On the other hand if your switch shows command options then your switch supports GLBP!!!

Hope this helps.

Regards,

AbhisheK

Please rate all posts!!!

Silver

Re: Final HSRP +Config Between 2 6509

Thanks. Abhishek. I learn more from you.

New Member

Re: Final HSRP +Config Between 2 6509

6509-1

interface Vlan10

ip address 10.20.20.1 255.255.255.0

ip helper-address 10.20.3.200

no ip redirects

standby 10 ip 10.20.20.3

standby 10 timers 3 9

standby 10 priority 110

standby 10 preempt

no sh

ex

.................................

6509-2

interface Vlan10

ip address 10.20.20.2 255.255.255.0

ip helper-address 10.20.3.200

no ip redirects

standby 10 ip 10.20.20.3

standby 10 timers 3 9

standby 10 priority 105

standby 10 preempt

no sh

ex

hOW Can i configure MHSRPIN THE ABOVE Can u PS Editing my config?what is the Benifets of MHSRP Rather than HSRP IN MY SITUATION

10XS

Silver

Re: Final HSRP +Config Between 2 6509

You have below :

6509-1

interface Vlan10

ip address 10.20.20.1 255.255.255.0

ip helper-address 10.20.3.200

no ip redirects

standby 10 ip 10.20.20.3

standby 10 timers 3 9

standby 10 priority 110

standby 10 preempt

standby 20 ip 10.20.20.4

standby 20 timers 3 9

standby 20 priority 105

standby 20 preempt

-----------------------------

6509-2

interface Vlan10

ip address 10.20.20.2 255.255.255.0

ip helper-address 10.20.3.200

no ip redirects

standby 10 ip 10.20.20.3

standby 10 timers 3 9

standby 10 priority 105

standby 10 preempt

standby 20 ip 10.20.20.4

standby 20 timers 3 9

standby 20 priority 110

standby 20 preempt

Just add one more group w/ new virtual IP and reserve the priority. Then one group of user will point to the .3 as GW and the other group point to the .4 as GW. You can MANUAL load-sharing the traffic at two routers but require additional admin work on the IP GW assignment at user PC.

Hope this helps.

Silver

Re: Final HSRP +Config Between 2 6509

Sorry. Should be reverse the priority.

New Member

Re: Final HSRP +Config Between 2 6509

Hi

what do u mean by rverse the priority!

10xs

Re: Final HSRP +Config Between 2 6509

You are welcome!

New Member

Re: Final HSRP +Config Between 2 6509

HI

Now i have 2 virtual ip.whcih one sould i assign in my DHCP Scope?as DG.

10XS

Silver

Re: Final HSRP +Config Between 2 6509

As I mentioned before, you have to assign part of the user to use ,3 and other user to use .4 as the default gateway.So 2 profiles in DHCP server is required.

New Member

Re: Final HSRP +Config Between 2 6509

hi Jakcy!

i tested the HSRP IN VLAN 10.but when i Disconnected the Active.30 time out occur until the standby beame Active than i received reply.how can reduce the time out?B/W: SWITCH 1 ACT AS ROOT BRIDGE

SWITCH2 ACT AS SECONDERY ROOT BRIDGE

10xs

New Member

Re: Final HSRP +Config Between 2 6509

Hi

PS;Can u Help how to reduce these 30 Timeout until the Standby became Active?

10xs

275
Views
45
Helpful
37
Replies
CreatePlease to create content