Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Flash upgrade

I'm upgrading a 1750 access router from 4Mb Flash to 8Mb. I'm aware that there is no image loaded on the flash card, however, when using xmodem or tftp the flash refuses to accept the image I'm uploading. I've tried it on two different routers just in case the router was the cause of the problem and still no joy. Then I went one step further and swapped the flash keeping the same brand (the make is SMART and the number on it SM9F208IM3) and the image upload still doesn't work. It seems highly unlikely but could it possibly be a bad batch?

Error message is identical to another message posted elsewhere on this forum:

device does not contain a valid magic number

boot: cannot open flash

boot: cannot determine file name on device "flash:"

It then goes into ROMMON mode

I later managed to source some 8Mb SHARP flash as well with my desired image (c1700-sv3y-mz.121-3b.bin) already on it and the router loads perfectly.

Any suggestions would be appreciated,

regards Allan

1 REPLY
Silver

Re: Flash upgrade

The error message that you are seeing is means the Flash is empty or the file system is corrupted. Copy a valid image on the Flash by following the procedures provided in these documents.

http://www.cisco.com/warp/public/130/recovery_c1700.html

http://www.cisco.com/warp/public/130/sw_upgrade_proc_ram.shtml

It is quite possible that the problem lies with the flash cards and not the router since the router seems to boot with a valid image.

Contact the vendor to find out if there is a problem with the cards.may be a bad batch as you said.

92
Views
0
Helpful
1
Replies
CreatePlease to create content