Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Floating static route for dialbackup not working.See Config

If anyone can help it would be much appreciated.

I am using a cisco 1721 with ADSL ip stream as our primary connection.

I am using a default route pointing down dialer 1 as my primary route.I have also configured a secondary default route pointing down dialer 2 with a metric of 100.My objjective is to use dial backup on the atm interface and use the backup sttatement backup interface dialer 2.When I pull the adsl and the atm goes downn down,a backup call is made but the interesting traffic still seems to want to use the primary default route which points downn dialer 1 instead of using dialer 2 which is the isdn backup.I am using 12.3.1 IOS which is the latest version.I am also using RIP to advertise the network downn dialer 2 because our backup core solution is a Perle ras server which can only do RIP.

Can anyone advise why the floating static route is not working.Please see config below.

wr t

Building configuration...

Current configuration : 2156 bytes

!

version 12.3

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname WIMBLEDON

!

enable secret xxxx

enable passwordxxxx

!

ip subnet-zero

!

!

no ip domain lookup

!

isdn switch-type basic-net3

!

!

!

!

interface ATM0

no ip address

backup interface Dialer2

atm vc-per-vp 2048

no atm ilmi-keepalive

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

dsl operating-mode auto

hold-queue 224 in

!

interface BRI0

description ISDN Dial Backup

no ip address

encapsulation ppp

dialer pool-member 2

isdn switch-type basic-net3

isdn sending-complete

no cdp enable

ppp authentication chap callin

!

interface FastEthernet0

ip address 10.x.x.x 255.255.255.224

ip nat inside

speed auto

no keepalive

hold-queue 100 out

!

interface Dialer1

ip address negotiated

ip nat outside

encapsulation ppp

dialer pool 1

ppp authentication chap pap callin

ppp chap hostname xxxxx

ppp chap password 7 14151D130916393C2B3A3F11

ppp pap sent-username xxxxxpassword xxxxx

!

interface Dialer2

description connected to Internet

ip address negotiated

ip accounting output-packets

encapsulation ppp

no ip split-horizon

dialer pool 2

dialer idle-timeout 600

dialer enable-timeout 120

dialer string 02086051881

dialer hold-queue 10

dialer-group 1

no cdp enable

ppp authentication chap pap callin

ppp chap hostname xxxx

ppp chap password xxxxx

ppp pap sent-username xxxpassword xxxxx

!

ppp multilink

ppp multilink load-threshold 1 either

!

router rip

version 2

no validate-update-source

passive-interface FastEthernet0

passive-interface Dialer1

network 10.0.0.0

neighbor 10.98.169.1

no auto-summary

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

ip route 0.0.0.0 0.0.0.0 dialer2

ip http server

!

!

dialer-list 1 protocol ip permit

!

!

line con 0

exec-timeout 120 0

password xxx

login

stopbits 1

line aux 0

line vty 0 4

exec-timeout 120 0

password xxxx

login

length 25

!

scheduler max-task-time 5000

!

end

4 REPLIES
New Member

Re: Floating static route for dialbackup not working.See Config

Not saying that I know for sure, but I think your problem is that the static route to dialer1 never get's invalid. Because that the interface dialer1 dont get down, it's the ATM-interface that goes down. So if you get rid of the dialer1 configuration and specify the info direct on the ATM interface I suppose it should work. Is that doable?

New Member

Re: Floating static route for dialbackup not working.See Config

Is there anyway of bypassing this without removing the dialer interface 1 configuration as all oursites are configured this way for adsl ip stream.

Do you know if it is possible to make this config work direct on the ATM interface by deleting the dialer interface.

New Member

Re: Floating static route for dialbackup not working.See Config

Hmm sorry but ATM-configuration isnt my speciality.

Hmm *thinking out loud* since the Dialer2 interface is down in normal use, you might want to try making the floating static so that interface is the first choice. Since it's normally down it should invlidate the route and make the route to dialer1 work. when the ATM is down the dialer2 gets active and so should the route as well.

just thinking...might work. but I'm not that experienced in this sort of configurations.

Bronze

Re: Floating static route for dialbackup not working.See Config

Here's a thought - eliminate interface Dialer 2. Make the BRI interface part of dialer pool 1 instead of dialer pool 2. Increase the priority of interface ATM0 with the command "dialer pool-member 1 priority 10". Delete the backup interface command on ATM0. This will (I think) give you a single dialer interface, which uses the ATM interface if it is available. If the ATM interface is not available, the dialer interface will use the lower priority interface, BRI0.

I can't test this in a lab. I am curious to see if this will work.

Good luck.

Mark

234
Views
0
Helpful
4
Replies
CreatePlease login to create content