Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Floating static route on 1721 for dialbackup wont work.See config

If anyone can help it would be much appreciated.

I am using a cisco 1721 with ADSL ip stream as our primary connection.

I am using a default route pointing down dialer 1 as my primary route.I have also configured a secondary default route pointing down dialer 2 with a metric of 100.My objjective is to use dial backup on the atm interface and use the backup sttatement backup interface dialer 2.When I pull the adsl and the atm goes downn down,a backup call is made but the interesting traffic still seems to want to use the primary default route which points downn dialer 1 instead of using dialer 2 which is the isdn backup.I am using 12.3.1 IOS which is the latest version.I am also using RIP to advertise the network downn dialer 2 because our backup core solution is a Perle ras server which can only do RIP.

Can anyone advise why the floating static route is not working.Please see config below.

wr t

Building configuration...

Current configuration : 2156 bytes

!

version 12.3

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname xxxx

!

enable secret xxxxx

enable password xxxx

!

ip subnet-zero

!

!

no ip domain lookup

!

isdn switch-type basic-net3

!

!

!

!

interface ATM0

no ip address

backup interface Dialer2

atm vc-per-vp 2048

no atm ilmi-keepalive

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

dsl operating-mode auto

hold-queue 224 in

!

interface BRI0

description ISDN Dial Backup

no ip address

encapsulation ppp

dialer pool-member 2

isdn switch-type basic-net3

isdn sending-complete

no cdp enable

ppp authentication chap callin

!

interface FastEthernet0

ip address 10.x.x.x 255.255.255.224

ip nat inside

speed auto

no keepalive

hold-queue 100 out

!

interface Dialer1

ip address negotiated

ip nat outside

encapsulation ppp

dialer pool 1

ppp authentication chap pap callin

ppp chap hostname xxxx

ppp chap password xxxx

ppp pap sent-username xxxpassword xxx

!

interface Dialer2

description connected to Internet

ip address negotiated

ip accounting output-packets

encapsulation ppp

no ip split-horizon

dialer pool 2

dialer idle-timeout 600

dialer enable-timeout 120

dialer string 02086051881

dialer hold-queue 10

dialer-group 1

no cdp enable

ppp authentication chap pap callin

ppp chap hostname xxxx

ppp chap password xxxx

ppp pap sent-username xxxxpassword xxxxx

!

ppp multilink

ppp multilink load-threshold 1 either

!

router rip

version 2

no validate-update-source

passive-interface FastEthernet0

passive-interface Dialer1

network 10.0.0.0

neighbor 10.98.169.1

no auto-summary

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

ip route 0.0.0.0 0.0.0.0 dialer2

ip http server

!

!

dialer-list 1 protocol ip permit

!

!

line con 0

exec-timeout 120 0

password xx

login

stopbits 1

line aux 0

line vty 0 4

exec-timeout 120 0

password xxxx

login

length 25

!

scheduler max-task-time 5000

!

end

5 REPLIES
Bronze

Re: Floating static route on 1721 for dialbackup wont work.See c

hi

I guess the second default route will never come in place....the first default route is still there because dialer 1 is up/up. So to be sure on that can you ones start a "debug dialer events" while you plug the adsl out and poste this to the forum.

Regards

Roger

New Member

Re: Floating static route on 1721 for dialbackup wont work.See c

will it work is i change the default router to

ip route 0.0.0.0 0.0.0.0 10.98.1.1

If i do this instead of pointing it to dialer interface 1 ity might use the secodn default route with a higher metric.

Is this correct?

Bronze

Re: Floating static route on 1721 for dialbackup wont work.See c

Hi

I do not see where you got the 10.98.1.1 address, but if this address is not

reachable if the adls is down then your second default route will kick in.

Regards

Roger

New Member

Re: Floating static route on 1721 for dialbackup wont work.See c

Hi

10.98.1.1 was just an example of a next hop across the adsl.

Thanks for youre help Roger.

Cheer

Bronze

Re: Floating static route on 1721 for dialbackup wont work.See c

So does it work now....sounds like!

Regards

Roger

94
Views
0
Helpful
5
Replies
CreatePlease to create content