Cisco Support Community

Fragmentation problems

Hello everyone.

I'm having problems transfering big packets on some devices.

It seems that when I try to use packets bigger than 5128 some are not reassembled.

I'm getting these errors:

IP: s= (GigabitEthernet0/3), d=, len 752, input feature, Access List(8), rtype 0, forus FALSE, sendself FALSE, mtu 0

ICMP: time exceeded (reassembly) sent to (dest was

show ip traffic didnt show any issues on the 3 catalyst in the path:

IP statistics:

Rcvd: 78928204 total, 3464197 local destination

0 format errors, 0 checksum errors, 1043585 bad hop count

0 unknown protocol, 0 not a gateway

0 security failures, 60 bad options, 9794 with options

Opts: 68 end, 32 nop, 0 basic security, 60 loose source route

9694 timestamp, 0 extended security, 40 record route

0 stream ID, 0 strict source route, 0 alert, 0 cipso, 0 ump

0 other

Frags: 40274 reassembled, 1752 timeouts, 0 couldn't reassemble

168815 fragmented, 14 couldn't fragment

Any clues? what is this ACL 8 that is not configured on the device where I set the debug ip packet?



Re: Fragmentation problems

Hi Vlad,

According to RFC792:

If a host reassembling a fragmented datagram cannot complete the reassembly due to missing fragments within its time limit it discards the datagram, and it may send a time exceeded message.

I would say that you are losing some packets (fragments) along the way...


Re: Fragmentation problems

I think you are right, we thought this would be the case, the problem is locating who (or which device ) is causing this fragmentated packet loss.

Any suggestion how to proceed?


CreatePlease to create content