Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Frame-relay backup using ISDN

I have had several problems trying to get ISDN to work as a backup to a Frame-relay interface without any success so far. The current attempt is shown below. In addition to the config below I have placed the backup commands on the serial sub-interface. I've also used floating static routes.

The use of floating static routes did work, however, this setup causes problems with Windows NT services bringing up the interface periodically.

Any suggestions would be appreciated.

---------------------------------------------------------------------------------------------------

CENTRAL SITE

This router uses static routes to connect to the network. It relies on the remote router to dial.

YYYRTR1#sh ru

hostname YYY14RTR1

!

logging buffered 10000 debugging

enable password 7 01115654415814

!

username XXX01rtr6 password 7 0509070C2A595E

memory-size iomem 20

clock timezone XXX

no ip subnet-zero

!

!

no ip domain-lookup

ip domain-name XXX

!

!

isdn switch-type basic-net3

call rsvp-sync

!

!

interface BRI0/0

description backup link to YYY01rtr6

bandwidth 64

no ip address

encapsulation ppp

no ip route-cache

no ip mroute-cache

dialer pool-member 1

isdn switch-type basic-net3

ppp authentication chap

!

interface Dialer1

description BRI backup to XXX01rtr6

ip address 10.18.236.7 255.255.255.0

dialer pool 1

dialer remote-name XXX01rtr6

dialer idle-timeout 60

dialer fast-idle 10

dialer string 020123456

dialer-group 1

no cdp enable

!

interface Serial0/0

description Frame Relay Y123456N

mtu 1600

bandwidth 1024

backup delay 1 5

backup interface Dialer1

no ip address

ip accounting output-packets

encapsulation frame-relay

no ip route-cache

no ip mroute-cache

no fair-queue

frame-relay lmi-type ansi

!

interface Serial0/0.1 point-to-point

description Frame Relay to XXX01RTR1

bandwidth 256

ip address 10.18.180.2 255.255.255.0

ip accounting output-packets

no ip route-cache

no ip mroute-cache

frame-relay interface-dlci 16

!

router eigrp 1

network 10.18.0.0 0.0.255.255

auto-summary

no eigrp log-neighbor-changes

!

no ip classless

no ip forward-protocol udp netbios-ns

no ip forward-protocol udp netbios-dgm

ip route 0.0.0.0 0.0.0.0 10.18.8.34

ip route 10.18.0.0 255.255.0.0 10.18.236.1 200

ip route 147.132.19.0 255.255.255.0 10.18.180.1

no ip http server

ip pim bidir-enable

!

dialer-list 1 protocol ip permit

snmp-server community XXX

snmp-server community XXX

snmp-server ifindex persist

snmp-server chassis-id XXXXX

snmp-server enable traps config

snmp-server enable traps frame-relay

snmp-server host 10.18.21.56 XXX

!

dial-peer cor custom

end

-------------------------------------------------------------------------

REMOTE ROUTER

This router is configured to initiate an ISDN session when the Frame-relay protocol drops (not the interface) on s0/0.1.

XXX01rtr6#sh ru

username YYY14RTR1 password 7 13071611001914

clock timezone XXX

clock summer-time AEDT recurring last Sun Oct 2:00 last Sun Mar 2:00

no ip subnet-zero

!

!

no ip domain-lookup

ip domain-name XXXX

ip name-server X.X.X.X

!

ip accounting-threshold 100000

!

call rsvp-sync

interface BRI0/0

description backup link for XXXXX

bandwidth 128

ip address 10.18.236.1 255.255.255.0

encapsulation ppp

no ip route-cache

no ip mroute-cache

shutdown

dialer idle-timeout 60

dialer fast-idle 5

dialer map ip 10.18.236.7 name YYY14rtr1 broadcast

dialer load-threshold 1 outbound

dialer-group 1

isdn switch-type basic-net3

ppp authentication chap

!

ip default-gateway 10.18.21.1

ip classless

ip route 10.18.182.0 255.255.255.0 10.18.236.7

no ip http server

ip pim bidir-enable

!

logging 10.18.21.56

dialer-list 1 protocol ip permit

snmp-server community XXX

snmp-server community XXX

snmp-server ifindex persist

snmp-server chassis-id XXXXX

snmp-server enable traps tty

snmp-server enable traps isdn layer2

snmp-server enable traps config

snmp-server enable traps entity

snmp-server enable traps envmon

snmp-server host 10.18.21.56 XXX

!

dial-peer cor custom

5 REPLIES
Bronze

Re: Frame-relay backup using ISDN

Generally you dont want to allow IP broadcasts to bring up your dialup link unwantedly. So instead of "dialer-list 1 protocol ip permit", always use the following :

dialer-list 1 protocol ip list 101

access-list 101 deny ip any host 255.255.255.255

access-list 101 permit ip any any

Now give that a try and see if it works as you want it to.

~Zulfi

New Member

Re: Frame-relay backup using ISDN

Thanks for that. I do normally use an access list. The interfaces are normally no shut as well.

Silver

Re: Frame-relay backup using ISDN

Just taking a quick look at your configuration, there are multiple problems.

1 - The BRI interface on the remote is shutdown, so there is no way it can dial.

2 - There is no frame relay interface configured on the remote.

3 - The "backup interface" statements should only be used on the router which is placing the call. The router receiving the call should have the ISDN interface ready to receive a call at any time.

4 - Backup interface only works reliably with frame relay if you also configure end-to-end keepalives.

5 - Fixing DDR so windows does not bring up the interface when not needed is a separate issue and should be fixed by limiting "interesting traffic" defined by dialer-list 1.

If you can't find an example configuration you like here on CCO, there are multiple examples of ISDN backup of frame relay in my book High Availability Networking with Cisco.

Good luck and have fun!

Vincent C Jones

www.networkingunlimited.com

Cisco Employee

Re: Frame-relay backup using ISDN

There are many examples of frame-relay (or WAN link) backup using isdn lines on www.cisco.com. Those examples do have network topology with step-by-step config, verification and troubleshooting information too.

Pl. visit following url for many many sample configs

http://www.cisco.com/pcgi-bin/Support/browse/psp_view.pl?p=Internetworking:DDR&viewall=true

Locate "Backup for WAN link"

New Member

Re: Frame-relay backup using ISDN

The interface is normally no shut.

The remote end is not the other end of the Frame-relay. It is linked to the Frame-relay router by static routes

I think point 4 may be the answer. I'll give it a go and let you know.

Thanks

103
Views
0
Helpful
5
Replies
CreatePlease to create content