Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Community will be in read-only mode on 12/14/2017 from 12:00 am pacific to 11:30 am.

During this time you will only be able to see content. Other interactions such as posting, replying to questions, or marking content as helpful will be disabled for few hours.

We apologize for the inconvenience while we perform important updates to the Community.

New Member

Frame Relay connectivity

I have two 2500 and one 3600 connected together via Frame Relay. I configured the 3600 to be a FR switch and is providing clocking on each interface to each of the 2500's. The 2500 are the DTE's. The interfaces are X.21 and they are connected back to back with the 3600 using a DCE cable. The interfaces show they are up, the LMI is up at both ends but I cant ping from one 2500 to the other, or to the LAN interface on each of the 2500's. Sh cdp neigh does not show any of the routers, and the ip route command only shows the subnets directly attached to each router.

Does anyone have any idea what I am doing wrong?

Many thanks.

Arturo Maldonado

21 REPLIES
New Member

Re: Frame Relay connectivity

Did you map your 2500 interfaces to the PVCs that you created on the 3600? What is the routing protocol you are running?

You may want to post your config.

New Member

Re: Frame Relay connectivity

I am sure I mapped them before but I have remove the maping because I was trying something else. Anyway, this is the current config of the three routers.

Config from Router_3 (Frame Relay switch)

interface Serial1/0

description link to Router_1

ip address 15.1.1.10 255.255.255.252

encapsulation frame-relay

no ip route-cache

no ip mroute-cache

bandwidth 1000

clockrate 1000

frame-relay intf-type dce

frame-relay route 30 interface Serial1/1 40

!

interface Serial1/1

description link to Router_2

ip address 15.1.1.6 255.255.255.252

encapsulation frame-relay

bandwidth 500

clockrate 500

frame-relay intf-type dce

!

Config from Router_1

interface Serial1

ip address 15.1.1.9 255.255.255.252

encapsulation frame-relay

no ip mroute-cache

bandwidth 1000

frame-relay map ip 15.1.1.10 30

frame-relay interface-dlci 30

Config from Router_2

interface Serial1

ip address 15.1.1.5 255.255.255.252

encapsulation frame-relay

bandwidth 500

frame-relay interface-dlci 40

!

Please note that routers 1 and 2 are the 2500s and router 3 is the 3600 con figured as FR switch.

Many thanks.

Arturo.

New Member

Re: Frame Relay connectivity

looks to me like you need to map dlci 40 back to dlci 30. so on the 3600 do this under int s1/1

frame-relay route 40 interface Serial1/0 30

Re: Frame Relay connectivity

What does a show frame-relay map command reveal on either routers ???

Once you give a "debug frame-relay packet", do you get any encapsulation failures ??

I would recommend, not using the debug command during peak hours..

New Member

Re: Frame Relay connectivity

Hi!,

I am sorry for replying late but I was away for a week and just returned today.

Answering your questions, please see the output of your recommended commands.

Router_1#sh frame-relay map

Serial1 (up): ip 15.1.1.10 dlci 30(0x1E,0x4E0), static,

CISCO, status defined, inactive

Router_1#debug frame-relay packet

Frame Relay packet debugging is on

Router_1#

Serial1: broadcast search

Serial1:encaps failed on broadcast for link 7(IP)

Serial1: broadcast search

Serial1:encaps failed on broadcast for link 7(IP)

Router_2#sh frame-relay map

Router_2#debug frame-relay packet

Frame Relay packet debugging is on

Router_2#

Serial1: broadcast search

Serial1:encaps failed on broadcast for link 7(IP)

Serial1: broadcast search

Serial1:encaps failed on broadcast for link 7(IP)

Router_3#sh frame-relay map

Router_3#debug frame-relay packet

Frame Relay packet debugging is on

Router_3#

4w0d: Serial1/1: broadcast search

4w0d: Serial1/1:encaps failed on broadcast for link 7(IP)

4w0d: Serial1/0: broadcast search

4w0d: Serial1/0:encaps failed on broadcast for link 7(IP)

Please note that Routers 1 and 2 are the 2500s which are the DTEs. Router 3 is the DEC configured as a Frame relay switch.

Many thanks.

Arturo

Re: Frame Relay connectivity

Hello Arturo,

It looks like, you got a static map on Router 1 for Router 2s ip address (15.1.1.10)

But on Router 2, you do not seem to have an ip mapping. You will need to have a similar mapping for Router 1.

command is "frame-relay map ip broadcast (note that you should map the remote ip address to the local dlci)

You seem to have encapsulation failure errors on the debug output, due to this lack of mapping.

Hope that helps!

frame-relay

Bronze

Re: Frame Relay connectivity

you are missing the frame-relay route statement on the second interface in the switch. You also did not show if you set the frame-relay switch global command. takes the ip addresses off the switch interfaces, you are building a layer 2 device not a router.

On the switch do a show frame route and see if you have matching routes that point to each other like the first two lines here from my 1720. That tells you if the switch is properly configured.

frsw#sh frame route

Input Intf Input Dlci Output Intf Output Dlci Status

Serial0 201 Serial1 102 active

Serial1 102 Serial0 201 active

Serial1 103 Serial2 301 active

Serial1 105 Serial3 501 active

Serial2 301 Serial1 103 active

Serial3 501 Serial1 105 active

New Member

Re: Frame Relay connectivity

Richard,

The switch interfaces now look like this.

interface Serial1/0

description link to Router_1

no ip address

encapsulation frame-relay

no ip route-cache

no ip mroute-cache

bandwidth 1000

clockrate 1000

frame-relay intf-type dce

frame-relay route 30 interface Serial1/1 40

!

interface Serial1/1

description link to Router_2

no ip address

encapsulation frame-relay

bandwidth 500

clockrate 500

frame-relay intf-type dce

frame-relay route 40 interface Serial1/0 30

The router was already configured with the frame-relay switching command.

After I added the frame-relay route statement to the second interface in the switch I could see the following.

Router_3#sh frame route

Input Intf Input Dlci Output Intf Output Dlci Status

Serial1/0 30 Serial1/1 40 active

Serial1/1 40 Serial1/0 30 active

However, I can't ping from Router_1 to Router_2 and viceversa. They are configured in a 30 bit subnet nor can they see each other with the show cdp neigh command.

Any more ideas?

Many thanks.

Arturo.

New Member

Re: Frame Relay connectivity

Hi! Sankar,

I added the maping you suggested and now the interfaces look like this.

These are the interfaces in the router configured as a frame relay switch.

interface Serial1/0

description link to Router_1

no ip address

encapsulation frame-relay

no ip route-cache

no ip mroute-cache

bandwidth 1000

clockrate 1000

frame-relay intf-type dce

frame-relay route 30 interface Serial1/1 40

!

interface Serial1/1

description link to Router_2

no ip address

encapsulation frame-relay

bandwidth 500

clockrate 500

frame-relay intf-type dce

frame-relay route 40 interface Serial1/0 30

This is the interface in Router_1

interface Serial1

ip address 15.1.1.6 255.255.255.252

encapsulation frame-relay

no ip mroute-cache

bandwidth 1000

frame-relay map ip 15.1.1.5 30 broadcast

frame-relay interface-dlci 30

This is the interface in Router_2

interface Serial1

ip address 15.1.1.5 255.255.255.252

encapsulation frame-relay

bandwidth 500

frame-relay map ip 15.1.1.6 40 broadcast

frame-relay interface-dlci 40

There don't seem to be encapsulation errors anymore.

Router_2#debug frame-relay packet

Frame Relay packet debugging is on

Router_2#

Serial1: broadcast search

Serial1: Broadcast on DLCI 40 link 7

Serial1(o): dlci 40(0x881), pkt type 0x800(IP), datagramsize 64

Serial1(o): dlci 40(0x881), pkt type 0x800(IP), datagramsize 64

broadcast dequeue

Serial1(o):Pkt sent on dlci 40(0x881), pkt type 0x800(IP), datagramsize 64

broadcast dequeue

Serial1(o):Pkt sent on dlci 40(0x881), pkt type 0x800(IP), datagramsize 64

Serial1(i): dlci 40(0x881), pkt type 0x800, datagramsize 64

The problem still is that I can't ping between the FR interfaces in router 1 and 2.

Any more ideas?

Many thanks for your help.

Arturo.

New Member

Re: Frame Relay connectivity

What code are you running because I noticed in some codes dcp is not enabled by default you will have to manually enable it. Also I do not see any routing protocols configured static or dynamic, so without a routing protocol you will not be able to ping your neibors lan network.

hth

Dennis

New Member

Re: Frame Relay connectivity

Dennis,

Routers 1 and 2 can see each other via another serial HDLC interface. The router configured as a switch can see another router directly attached to its ethernet interface. The problem is that neither Router 1 or 2 can see Router 3 (the switch) via the FR interfaces.

Router 1 and 2 are running EIGRP, Router 3 had EIGRP as well but I just removed it because I wasn't sure if it should have it since it is only perfoming as a switch. What do you say?

Thanks for your help.

Arturo.

Bronze

Re: Frame Relay connectivity

Do a show frame pvc and sh fram lmi on rtr1 and rtr2. That will tell you if they are talking to the fram switch and what pvc it has configured on those interfaces. Also check the lmi-type in the switch versus each router. The default changed at some point in the past and if rtr1 and2 are older they might be using a different lmi type.

New Member

Re: Frame Relay connectivity

Richard,

I think both routers are talking to the switch. See below the output of the commands.

Router_1#sh frame pvc

PVC Statistics for interface Serial1 (Frame Relay DTE)

DLCI = 30, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1

input pkts 391 output pkts 421 in bytes 26206

out bytes 29954 dropped pkts 1 in FECN pkts 0

in BECN pkts 0 out FECN pkts 0 out BECN pkts 0

in DE pkts 0 out DE pkts 0

out bcast pkts 177 out bcast bytes 11328

pvc create time 3w1d, last time pvc status changed 00:09:00

Router_1#

Router_1#

Router_1#sh frame lmi

LMI Statistics for interface Serial1 (Frame Relay DTE) LMI TYPE = CISCO

Invalid Unnumbered info 0 Invalid Prot Disc 0

Invalid dummy Call Ref 0 Invalid Msg Type 0

Invalid Status Message 0 Invalid Lock Shift 0

Invalid Information ID 0 Invalid Report IE Len 0

Invalid Report Request 0 Invalid Keep IE Len 0

Num Status Enq. Sent 147359 Num Status msgs Rcvd 147358

Num Update Status Rcvd 0 Num Status Timeouts 1

Router_2#sh frame pvc

PVC Statistics for interface Serial1 (Frame Relay DTE)

DLCI = 40, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1

input pkts 419 output pkts 380 in bytes 29724

out bytes 25102 dropped pkts 0 in FECN pkts 0

in BECN pkts 0 out FECN pkts 0 out BECN pkts 0

in DE pkts 0 out DE pkts 0

out bcast pkts 349 out bcast bytes 22064

pvc create time 2w3d, last time pvc status changed 00:06:26

Router_2#

Router_2#

Router_2#sh frame lmi

LMI Statistics for interface Serial1 (Frame Relay DTE) LMI TYPE = CISCO

Invalid Unnumbered info 0 Invalid Prot Disc 0

Invalid dummy Call Ref 0 Invalid Msg Type 0

Invalid Status Message 0 Invalid Lock Shift 0

Invalid Information ID 0 Invalid Report IE Len 0

Invalid Report Request 0 Invalid Keep IE Len 0

Num Status Enq. Sent 146962 Num Status msgs Rcvd 146963

Num Update Status Rcvd 0 Num Status Timeouts 0

Router_2#

The lmi in both interfaces in the switch are Cisco same as in the routers 1 and 2.

Thanks for your time.

Arturo.

New Member

Re: Frame Relay connectivity

Aisco router configured as a switch can also be used as a regular router I do bit all the time in the lab, so configuring eigrp on the switch should not be a problem.\

Dennis

New Member

Re: Frame Relay connectivity

Dennis,

I manage to fix my original problem. The problem was that I had misconfigured the clock rate in both interfaces of the switch. the setting is in bits per second and I assumed that it was in Kbps so I had configured a 1000 bps interface and a 500 bps interface. Instead of the 1Mbps and 500 kbps that I wanted.

Anyway now I have a different problem and I am writing to you becuase you seem to have experimented with Cisco routers as switches. The DCE as I said is a 3600 router, which I labeled as Router 3, and I want to connect it to another router (Router 4) via a Fastethernet in a different subnet to where Routers 1 and 2 are (the FR DTEs). So the question is, how can I do to advertise the subnets configured in Router 4 so Routers 1 and 2 know about them, and viceversa.

EIGRP is configured in four routers and they are all in the same AS.

Many Thanks for your help.

Arturo.

New Member

Re: Frame Relay connectivity

Hi

Arturo,

I have been watching your problem, now i have a problem with frame-relay look like your.

Can you send me a e-mail ?, maybe i can help you.

Best Regards

Luis

luis.veraza@foclan.net

New Member

Re: Frame Relay connectivity

you should also be able to do a sh fram pv on the 2500 to see what dlci's the 3600 is advertising to you. you may also need to set clock on the 2500's. here is a full mesh fram config if you want it.

sj

r7# wr t

Building configuration...

Current configuration : 6406 bytes

!

version 12.2

no parser cache

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname r7

!

logging rate-limit console 10 except errors

enable password cisco

!

!

!

ip subnet-zero

!

!

no ip domain-lookup

ip host sw 192.168.255.9

ip host linux 192.168.255.101

ip host switch 172.16.255.2

!

no ip dhcp-client network-discovery

frame-relay switching

call rsvp-sync

!

!

!

!

!

!

!

!

!

interface Serial0/0

description r1

no ip address

encapsulation frame-relay

no ip route-cache

no ip mroute-cache

logging event subif-link-status

logging event dlci-status-change

keepalive 20

no fair-queue

clockrate 72000

frame-relay lmi-type ansi

frame-relay intf-type dce

frame-relay route 102 interface Serial0/1 201

frame-relay route 103 interface Serial0/2 301

frame-relay route 104 interface Serial0/3 401

frame-relay route 105 interface Serial1/0 501

frame-relay route 106 interface Serial1/1 601

frame-relay route 107 interface Serial1/2 701

frame-relay route 108 interface Serial1/3 801

!

interface Serial0/1

description r2

no ip address

encapsulation frame-relay

no ip route-cache

no ip mroute-cache

logging event subif-link-status

logging event dlci-status-change

keepalive 20

no fair-queue

clockrate 72000

frame-relay lmi-type ansi

frame-relay intf-type dce

frame-relay route 201 interface Serial0/0 102

frame-relay route 203 interface Serial0/2 302

frame-relay route 204 interface Serial0/3 402

frame-relay route 205 interface Serial1/0 502

frame-relay route 206 interface Serial1/1 602

frame-relay route 207 interface Serial1/2 702

frame-relay route 208 interface Serial1/3 802

!

interface Serial0/2

description r3

no ip address

encapsulation frame-relay

no ip route-cache

no ip mroute-cache

logging event subif-link-status

logging event dlci-status-change

keepalive 20

no fair-queue

clockrate 2016000

frame-relay lmi-type ansi

frame-relay intf-type dce

frame-relay route 301 interface Serial0/0 103

frame-relay route 302 interface Serial0/1 203

frame-relay route 304 interface Serial0/3 403

frame-relay route 305 interface Serial1/0 503

frame-relay route 306 interface Serial1/1 603

frame-relay route 307 interface Serial1/2 703

frame-relay route 308 interface Serial1/3 803

!

interface Serial0/3

description r4

no ip address

encapsulation frame-relay

no ip route-cache

no ip mroute-cache

logging event subif-link-status

logging event dlci-status-change

keepalive 20

frame-relay lmi-type ansi

frame-relay intf-type dce

frame-relay route 401 interface Serial0/0 104

frame-relay route 402 interface Serial0/1 204

frame-relay route 403 interface Serial0/2 304

frame-relay route 405 interface Serial1/0 504

frame-relay route 406 interface Serial1/1 604

frame-relay route 407 interface Serial1/2 704

frame-relay route 408 interface Serial1/3 804

!

interface Serial1/0

description r5

no ip address

encapsulation frame-relay

no ip route-cache

no ip mroute-cache

logging event subif-link-status

logging event dlci-status-change

keepalive 20

no fair-queue

clockrate 72000

frame-relay lmi-type ansi

frame-relay intf-type dce

frame-relay route 501 interface Serial0/0 105

frame-relay route 502 interface Serial0/1 205

frame-relay route 503 interface Serial0/2 305

frame-relay route 504 interface Serial0/3 405

frame-relay route 506 interface Serial1/1 605

frame-relay route 507 interface Serial1/2 705

frame-relay route 508 interface Serial1/3 805

!

interface Serial1/1

description r6

no ip address

encapsulation frame-relay

no ip route-cache

no ip mroute-cache

logging event subif-link-status

logging event dlci-status-change

keepalive 20

no fair-queue

clockrate 72000

frame-relay lmi-type ansi

frame-relay intf-type dce

frame-relay route 601 interface Serial0/0 106

frame-relay route 602 interface Serial0/1 206

frame-relay route 603 interface Serial0/2 306

frame-relay route 604 interface Serial0/3 406

frame-relay route 605 interface Serial1/0 506

frame-relay route 607 interface Serial1/2 706

frame-relay route 608 interface Serial1/3 806

!

interface Serial1/2

description r7

ip address 30.30.30.1 255.255.255.252

no ip route-cache

no ip mroute-cache

keepalive 20

no fair-queue

clockrate 72000

!

interface Serial1/3

description r8

no ip address

encapsulation frame-relay

no ip route-cache

no ip mroute-cache

logging event subif-link-status

logging event dlci-status-change

keepalive 20

no fair-queue

clockrate 72000

frame-relay lmi-type ansi

frame-relay intf-type dce

frame-relay route 801 interface Serial0/0 108

frame-relay route 802 interface Serial0/1 208

frame-relay route 803 interface Serial0/2 308

frame-relay route 804 interface Serial0/3 408

frame-relay route 805 interface Serial1/0 508

frame-relay route 806 interface Serial1/1 608

frame-relay route 807 interface Serial1/2 708

!

interface FastEthernet2/0

ip address 192.168.255.1 255.255.255.0

duplex auto

speed auto

!

interface Serial2/0

ip address 160.160.1.2 255.255.255.252

clockrate 148000

!

interface FastEthernet2/1

ip address 10.5.0.1 255.255.255.0

duplex auto

speed auto

!

interface Serial2/1

ip address 63.63.1.1 255.255.255.252

!

interface FastEthernet3/0

ip address 10.70.0.2 255.255.255.0

duplex auto

speed auto

!

router eigrp 1

redistribute static route-map default

network 10.0.0.0

no auto-summary

no eigrp log-neighbor-changes

!

router bgp 3

bgp log-neighbor-changes

neighbor 30.30.30.2 remote-as 5

neighbor 63.63.1.2 remote-as 4

neighbor 160.160.1.1 remote-as 2

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.5.0.20

ip route 0.0.0.0 0.0.0.0 10.70.0.3

no ip http server

!

access-list 1 permit 0.0.0.0

!

!

route-map default permit 10

match ip address 1

!

!

dial-peer cor custom

!

!

!

alias exec c configure terminal

alias exec si show ip route

alias exec ci clear ip route *

alias exec oi show ip ospf interface

alias exec ion show ip ospf neighbor

alias exec ib show ip bgp

alias exec cib clear ip bgp *

alias exec ibn show ip bgp neighbor

alias exec wrb sho run | begin

alias exec sib show ip interface brief

!

line con 0

exec-timeout 0 0

privilege level 15

password cisco

logging synchronous

line aux 0

exec-timeout 0 0

privilege level 15

transport input all

line vty 0 4

exec-timeout 0 0

privilege level 15

password cisco

login

!

ntp clock-period 17179817

ntp server 137.20.20.1

!

end

r7#

New Member

Re: Frame Relay connectivity

I could not set the clock rate in the 2500's because they are the DTEs and the IOS complained that this is a feature of a DCE device. However, when trying to setup the clock rate in one of the DTEs I noticed that this setting is in bits per second, and not in kilobits per second as i initially thought. Once I corrected the clock rate value in both FR interfaces of the switch I managed to get pings from one DTE to the other across the DCE.

Many thanks to every one who helped me to sort out this problem.

Now I have a different problem. The DCE as I said is a 3600 router, which I labeld as Router 3, and I want to connect it to another router (Router 4) via a Fastethernet in a different subnet to where Routers 1 and 2 are (the FR DTEs). So the question is, how can I do to advertise the subnets configured in Router 4 so Routers 1 and 2 know abot them, and viceversa.

EIGRP is configured in four routers and they are all in the same AS.

Many Thanks.

Arturo.

Re: Frame Relay connectivity

Check to see if the segment (fast ethernet) between R3 and R4 are enabled with EIGRP.

New Member

Re: Frame Relay connectivity

I suppose it is, as they can see each other with the command sh ip eigrp neighbour.

Router_3 is esentially a FR switch and a Router. So how can we do to advertise the networks configured in the router part of Router_3 to the switch side of the same router? Is it possible at all?

I know I can achieve that by using an additional router configured as a hub router with another FR interface to Router_3 but my problem is that it may be difficult to find the hardware required, cables router, etc. That's is why I want to find an alternative to this problem with what I've got.

Many thanks.

Arturo Maldonado.

Bronze

Re: Frame Relay connectivity

The frame switch and router functions are separate. The frame switch is a telco device, not a part of your network. Any interfaces on "the frame switch" router that are not configured for switching can be used for routing so they can be build into lab scenarios but they cannot see the switch ports.

170
Views
0
Helpful
21
Replies
CreatePlease to create content