Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started.

New Member

frame-relay/ip conectivity

I have a 1721 with 12.3 software and the attached config. The isdn link works fine. The frame-relay link is not. All three links are connected to 3com NB11's. From the 1721 I cannot ping the two serial subinterfaces or the far end connection. However from the 3com I can ping it's local interface and the ones on the 1721. SH INT says that the interfaces are up, up. SH FRAME_RELAY PVC says that the pvc's are active connected and packets are being passed. I have checked ip address's and subnet masks and all appear correct. Help!

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

ip subnet-zero

!

!

no ip domain lookup

!

isdn switch-type basic-net3

!

!

!

!

interface Loopback0

ip address xxx.xxx.24.24 255.255.255.255

!

interface BRI0

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

no cdp enable

ppp authentication chap

!

interface FastEthernet0

ip address xxx.xxx.31.1 255.255.128.0

ip directed-broadcast

speed auto

half-duplex

no cdp enable

!

interface Serial0

no ip address

ip helper-address 23.200.127.255

ip directed-broadcast

encapsulation frame-relay IETF

no fair-queue

frame-relay lmi-type ansi

!

interface Serial0.16 point-to-point

description Backup PVC to LM

bandwidth 256

ip address xxx.xx.4.129 255.255.255.128

ip helper-address 23.200.127.255

ip directed-broadcast

ip ospf authentication-key cisco

ip ospf cost 4000

no cdp enable

frame-relay class data

frame-relay interface-dlci 16

!

interface Serial0.17 point-to-point

description Primary link to HQ

bandwidth 256

ip address xxx.xxx.4.1 255.255.255.128

ip helper-address 23.200.127.255

ip directed-broadcast

ip ospf authentication-key cisco

no cdp enable

frame-relay class data

frame-relay interface-dlci 17

!

interface Dialer1

ip address xxx.xxx.9.2 255.255.255.128

encapsulation ppp

dialer pool 1

dialer remote-name *******

dialer string *******

dialer-group 1

no cdp enable

ppp authentication chap

ppp chap hostname ******

ppp chap password 0 *******

!

router ospf 100

log-adjacency-changes

area 0.0.0.24 authentication

network 23.4.4.1 0.0.0.0 area 0.0.0.24

network 23.24.31.1 0.0.0.0 area 0.0.0.24

!

ip classless

ip route 0.0.0.0 0.0.0.0 23.3.9.1

ip route 23.200.4.18 255.255.255.255 23.3.9.1

no ip http server

!

!

map-class frame-relay data

frame-relay cir 192000

frame-relay bc 192000

frame-relay be 64000

frame-relay mincir 192000

access-list 101 permit ip any any

dialer-list 1 protocol ip permit

no cdp run

snmp-server community public RO

snmp-server community private RW

snmp-server enable traps tty

snmp-server host *********** private

banner motd toytown ROUTER

!

line con 0

password

login

line aux 0

line vty 0 4

password

login

!

!

end

  • Other Network Infrastructure Subjects
11 REPLIES
Silver

Re: frame-relay/ip conectivity

the first thing I would do is simplify the config by removing the OSPF authentication , and the ip addresss helper commands , see if you can ping , readd them one at see what line is causing the problem , I think it is going to be the helper command .

New Member

Re: frame-relay/ip conectivity

I tried your suggestion as below but unfortunatly it hasn't helped. I also checked the Frame-relay status and there are packets going back and forth.

!

interface Serial0.17 point-to-point

description Primary link to HQ

bandwidth 256

ip address 23.4.4.1 255.255.255.128

no cdp enable

frame-relay class data

frame-relay interface-dlci 17

Silver

Re: frame-relay/ip conectivity

Can you paste in a sh fr pvc from both sides , also what does the config on the ohther end look like , also can you enable cdp to see if you get cdp across the PVC

New Member

Re: frame-relay/ip conectivity

Hi, The far end is/are 3com NB11's (this is part of the migration project) However as I mentioned above they can ping the interfaces from their end! Why can't I ping from the box itself?

The results of SH FRAME_RELAY PVC, a ping and SH IP INT are given below hope the are of use.

Serial0.16 is up, line protocol is up

Hardware is PowerQUICC Serial

Description: Backup PVC to LM

Internet address is 23.4.4.129/25

MTU 1500 bytes, BW 256 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation FRAME-RELAY IETF

Last clearing of "show interface" counters never

Serial0.17 is up, line protocol is up

Hardware is PowerQUICC Serial

Description: Primary link to HQ

Internet address is 23.4.4.1/25

MTU 1500 bytes, BW 256 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation FRAME-RELAY IETF

Last clearing of "show interface" counters never

toytown#sh frame-relay pvc

PVC Statistics for interface Serial0 (Frame Relay DTE)

Active Inactive Deleted Static

Local 2 0 0 0

Switched 0 0 0 0

Unused 0 0 0 0

DLCI = 16, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0.16

input pkts 274 output pkts 5 in bytes 17109

out bytes 520 dropped pkts 0 in pkts dropped 0

out pkts dropped 0 out bytes dropped 0

in FECN pkts 0 in BECN pkts 0 out FECN pkts 0

out BECN pkts 0 in DE pkts 0 out DE pkts 0

out bcast pkts 0 out bcast bytes 0

5 minute input rate 2000 bits/sec, 2 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

pvc create time 01:29:54, last time pvc status changed 00:02:17

DLCI = 17, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0.17

input pkts 18 output pkts 23 in bytes 1080

out bytes 1960 dropped pkts 0 in pkts dropped 0

out pkts dropped 0 out bytes dropped 0

in FECN pkts 0 in BECN pkts 0 out FECN pkts 0

out BECN pkts 0 in DE pkts 0 out DE pkts 0

out bcast pkts 17 out bcast bytes 1360

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

pvc create time 01:30:02, last time pvc status changed 00:02:25

ping 23.4.4.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 23.4.4.1, timeout is 2 seconds:

*Mar 1 01:31:17.387: IP: s=23.4.4.1 (local), d=23.4.4.1 (Serial0.17), len 100,

sending.

*Mar 1 01:31:19.387: IP: s=23.4.4.1 (local), d=23.4.4.1 (Serial0.17), len 100,

sending.

*Mar 1 01:31:21.387: IP: s=23.4.4.1 (local), d=23.4.4.1 (Serial0.17), len 100,

sending.

*Mar 1 01:31:23.387: IP: s=23.4.4.1 (local), d=23.4.4.1 (Serial0.17), len 100,

sending.

*Mar 1 01:31:25.271: IP: s=23.4.4.1 (local), d=224.0.0.5 (Serial0.17), len 76,

sending broad/multicast

*Mar 1 01:31:25.387: IP: s=23.4.4.1 (local), d=23.4.4.1 (Serial0.17), len 100,

sending.

Success rate is 0 percent (0/5)

sh ip int serial0.17

Serial0.17 is up, line protocol is up

Internet address is 23.4.4.1/25

Broadcast address is 255.255.255.255

Address determined by non-volatile memory

MTU is 1500 bytes

Helper address is not set

Directed broadcast forwarding is disabled

Multicast reserved groups joined: 224.0.0.5 224.0.0.6

Outgoing access list is not set

Inbound access list is not set

Proxy ARP is enabled

Local Proxy ARP is disabled

Security level is default

Split horizon is enabled

ICMP redirects are always sent

ICMP unreachables are always sent

ICMP mask replies are never sent

IP fast switching is enabled

IP fast switching on the same interface is enabled

IP Flow switching is disabled

IP CEF switching is disabled

IP Fast switching turbo vector

IP multicast fast switching is disabled

IP multicast distributed fast switching is disabled

IP route-cache flags are Fast

Router Discovery is disabled

IP output packet accounting is disabled

IP access violation accounting is disabled

TCP/IP header compression is disabled

RTP/IP header compression is disabled

Policy routing is disabled

Network address translation is disabled

WCCP Redirect outbound is disabled

WCCP Redirect inbound is disabled

WCCP Redirect exclude is disabled

BGP Policy Mapping is disabled

Silver

Re: frame-relay/ip conectivity

does OSPF form an adjacency ? If it does then you could be hitting a bug , if it does not , the DLCI's could be mapped wrong in the FR cloud. On the remote end did you check to make sure you have the DLCI's/IP addresses applied to the correct interface ?

New Member

Re: frame-relay/ip conectivity

Ospf is not forming an adjacency, the far end is stuck in init, the 1721 is not doing anything. There is an existing 3com router that this is meant to replace and it works fine. This leads me to believe that the frame cloud is ok. The sh frame-relay pvc answers match what I expect as to lmi dlci etc. I am using the same ip address's etc as the existing router.

Silver

Re: frame-relay/ip conectivity

did you try to remove the helper from the nmain interface ?

Bronze

Re: frame-relay/ip conectivity

Does the 3com device have any debugs that show it is receiving any packets? Try pinging from the 3com with the cisco disconnected just to see if it is really talking to the cisco.

New Member

Re: frame-relay/ip conectivity

I did and it didn't change anything.

164
Views
0
Helpful
11
Replies